Overview

STRING_05
Overview

A purchase order (PO) is a commercial document issued by buyer to a seller, indicating types, quantities, and agreed prices for products or services the seller will provide to the buyer. Sending a PO to a supplier constitutes a legal offer to buy products or services. Acceptance of a PO by a seller usually forms a one-off between the buyer and seller, so no contract exists until the PO is accepted

PurchaseOrder Schema


Background

STRING_05
Background

There are several reasons why companies use POs.

POs allow buyers to clearly and explicitly communicate their intentions to sellers, and sellers are protected in case of a buyer's refusal to pay for goods or services. For example, Alex works for company A and orders parts from company B. The seller assumes that Alex's boss consents. If Alex is not entitled to this order - perhaps due to a miscommunication with their boss - the order can be canceled by either party. Depending on the type of product that is delivered and at what stage the PO is canceled, Company B may be entitled to production (labor, raw materials, etc.) and shipping and handling costs.

See Also
Purchase Order (Wikipedia)


String Schema
String Schema
Elements
Element | Description
StringMessageRequest |
StringMessageResponse |
Complex Types
Complex Type | Description
AccommodationCheckInOutType | Check In and/or Check Out Date and Time, either (Request) requested by customer or (Response) confirmed by ServiceProvider
AccommodationProductResponseType |
AccommodationRequestType |
AccommodationResponseType |
AccommodationRoomsRequestType |
AccommodationRoomsResponseType |
AccommodationStayRequestType |
AccommodationStayResponseType |
AccommodationTransferBusInfoRequestDataType |
AccommodationTransferBusInfoRequestType |
AccommodationTransferBusInfoResponseDataType |
AccommodationTransferBusInfoResponseType |
AccommodationTransferFlightInfoRequestDataType |
AccommodationTransferFlightInfoRequestType |
AccommodationTransferFlightInfoResponseDataType |
AccommodationTransferFlightInfoResponseType |
AccommodationTransferInfoRequestType |
AccommodationTransferInfoResponseType |
AccommodationTransferRailInfoRequestDataType |
AccommodationTransferRailInfoRequestType |
AccommodationTransferRailInfoResponseDataType |
AccommodationTransferRailInfoResponseType |
AccommodationTransferShipInfoRequestDataType |
AccommodationTransferShipInfoRequestType |
AccommodationTransferShipInfoResponseDataType |
AccommodationTransferShipInfoResponseType |
AdditionalESTAInformationType |
AddressType |
AgencyClearanceRequestType |
AgencyClearanceResponseType |
AirlineRequestType | Airline
AirlineRequestTypes | Airline types
AirlineResponseType | Airline
AirlineResponseTypes | Airline types
AirportRequestType | Airport
AirportResponseType | Airport
AttributesType | List of attributes
AttributeType | Certain attribute of the containing element
BaggageInfoType |
BoardCodeRequestType | Touroperator specific board code
BoardCodeResponseType | Touroperator specific board code
BookableClassCommonType | Class information
BookableClassRequestType |
BookableClassResponseType |
BookingChannelType | Booking Channel
BookingRequestEnvelopeType |
BookingRequestType |
BookingResponseEnvelopeType |
BookingResponseType |
CancellationPoliciesType |
CarrentalRequestType |
CarrentalResponseType |
CatalogueRequestType |
CatalogueResponseType |
CheckInData |
ClassBaseCommonType | Flight class information
ClassBaseRequestType |
ClassBaseResponseType |
ClassRequestType | Class
ClassResponseType |
CommonAgencyType |
CommonBookingType |
CommonCarRentalDataType |
CommonCruiseDataType |
CommonFlightDataType |
CommonFlightLegRequestType |
CommonFlightLegResponseType |
CommonFlightSegmentRequestType |
CommonFlightSegmentResponseType |
CommonFlightSegmentType |
CommonPriceRequestType |
CommonPriceResponseType |
CommonPriceType | Detail price assigned to a participant, service or service-type
CommonRoomType | Room information
CommonServiceRequestType |
CommonServiceResponseType |
CommonServiceType |
CommonTariffDataType |
CommonTariffRequestType |
CommonTariffResponseType |
CommonTotalBookingPriceType |
CommonTotalPriceType | Total price assigned to a participant, service or service-type
CommonTotalServicePriceType |
CommonTotalServiceTypePriceType |
CommonTotalTravellerPriceType |
CommonTravellerRequestType |
CommonTravellerResponseType |
CommonTravellerType |
CompanyNameType |
ConfigurationRequestType |
ConfigurationResponseType |
ContactDetailsType |
CountryType | Type for country information
CruiseRequestType |
CruiseResponseType |
CurrencyAmountType | Amount with according currency
CustomerRequestListRequestType |
CustomerRequestListResponseType |
CustomerRequestRequestType | Customer request
CustomerRequestResponseType |
ErrorsType | List of errors
ErrorType |
ExternalContentRequestType | Rich content information
ExternalReferenceType | Information about external system reference
FeeType |
FlightClassesRequestType |
FlightClassesResponseType |
FlightLegRequestType |
FlightLegResponseType |
FlightLegsRequestType |
FlightLegsResponseType |
FlightRequestType |
FlightResponseType |
FlightSegmentsRequestType |
FlightSegmentsResponseType |
FlightTariffsRequestType |
FlightTariffsResponseType |
GeoLocationType | Type for geo coding information
IdentifiersType | List of unique identifiers
IncludedExtraBaseRequestType |
IncludedExtraBaseResponseType |
IncludedExtraCommonType | Included extra information
IncludedExtraRequestType | Included extra
IncludedExtraResponseType |
IncludedExtrasRequestType |
IncludedExtrasResponseType |
InformationsType | List of informations
InformationType | Warning associated with certain details within the response
KeyValueType | List of key-value elements
ListType | List of strings
MealRequestType | Meal
MealResponseType |
ModficationPoliciesType |
PackageRequestType |
PackageResponseType |
PackagesRequestType |
PackagesResponseType |
PackageType |
PackageWeightType |
PassportCitizenOfForeignCountryEverSinceType |
PassportCitizenOfForeignCountryNowType |
PassportParentInfoType |
PassportStayInfoType |
PassportType |
PosType | Provides information on the originator of the query
PricesRequestType |
PricesResponseType |
ProductCodeRequestType | Touroperator specific product code
ProductCodeResponseType | Touroperator specific product code
RegionsType |
RequestorInformationType |
RoomCodeRequestType | Touroperator specific room code
RoomCodeResponseType | Touroperator specific room code
RoomRequestType |
RoomResponseType |
ServiceRequestReferencesType |
ServiceResponseReferencesType |
ServicesRequestType |
ServicesResponseAdditionalInfoType |
ServicesResponseType |
TextLanguageType | Type for region/country specific text information
TotalPriceType |
TravellersRequestType |
TravellersResponseType |
VersionRequestType |
VersionResponseType |
WarningsType | List of warnings
WarningType |
Simple Types
Simple Type | Description
AgeCategoryType |
AttributeSourceType |
BookabilityStateType | Type for specifying touristical bookability states
CabinClassType |
ConfirmationStateType | Type for specifying touristical confirmation states
CountryCodeType | ISO country code
CurrencyCodeType |
DateTimeType | Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttThh:miZ)
DateType | Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttZ)
ErrorCategoryType | Error category
FlightNumberType | Flight number, is always only the number part. The carrier code should be transmitted in the according separate carrier field.
GenderType |
IataAirlineCode |
IataAirportCode |
IcaoAirlineCode |
IcaoAirportCode |
IdentifierList | White space separated list of identifiers
IdentifierType | Type for an unique identifier
NationalitySourceType |
ProcessStateType | Type which indicates next possible process states of the result
RequestTriggerType |
SalutationType |
TimeType | Date value in ISO8601 format including the timezone (e.g. Thh:miZ)
TransactionStateType | Type which indicates an technical error while processing a request
WeightMeasureType | Weight scale information

© 2017 All Rights Reserved.

Send comments on this topic.


StringMessageRequest Element

String Schema
StringMessageRequest Element
String Schema : StringMessageRequest Element
Namespace http://string.drv.de/xmlschema/string
Diagram
AgencyClearanceRequest Element VersionRequest Element ConfigurationRequest Element BookingRequest Element Choice AgentId Element Agency Element Sequence AgencyInformation Element Sequence StringMessageRequest Element
Overview
StringMessageRequest
Sequence
AgencyInformation CommonAgencyType Complex Type
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Choice
BookingRequest BookingRequestType Complex Type
Sequence
RequestTrigger RequestTriggerType Simple Type
Trigger type which initiated the request
Services ServicesRequestType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Packages PackagesRequestType Complex Type
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Travellers TravellersRequestType Complex Type
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
ConfirmedWarnings optional IdentifiersType Complex Type
List of confirmed warning idemntifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
ConfigurationRequest ConfigurationRequestType Complex Type
Sequence
VersionRequest VersionRequestType Complex Type
Sequence
Version xs:decimal
version of client system
AgencyClearanceRequest AgencyClearanceRequestType Complex Type
Sequence
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="StringMessageRequest" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" />
      <xs:choice>
        <xs:element name="BookingRequest" type="BookingRequestType" nillable="true" />
        <xs:element name="ConfigurationRequest" type="ConfigurationRequestType" nillable="true" />
        <xs:element name="VersionRequest" type="VersionRequestType" nillable="true" />
        <xs:element name="AgencyClearanceRequest" type="AgencyClearanceRequestType" nillable="true" />
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
String Schema


AgencyInformation Element

String Schema
AgencyInformation Element
String Schema > StringMessageRequest Element : AgencyInformation Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonAgencyType Complex Type
Diagram
AgentId Element Agency Element Sequence AgencyInformation Element
Overview
AgencyInformation CommonAgencyType Complex Type
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Source
<xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageRequest Element | String Schema


AgencyClearanceRequest Element

String Schema
AgencyClearanceRequest Element
String Schema > StringMessageRequest Element : AgencyClearanceRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
AgencyClearanceRequestType Complex Type
Diagram
CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Sequence Country Element Agency Element Sequence Sequence POS Element Sequence AgencyClearanceRequest Element
Overview
AgencyClearanceRequest AgencyClearanceRequestType Complex Type
Sequence
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="AgencyClearanceRequest" type="AgencyClearanceRequestType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageRequest Element | String Schema


BookingRequest Element

String Schema
BookingRequest Element
String Schema > StringMessageRequest Element : BookingRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
BookingRequestType Complex Type
Diagram
Identifier Element Sequence ConfirmedWarnings Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element SessionId Element Sequence BookingDetails Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence Travellers Element Details Element Sequence Package Element Sequence Packages Element Service Element Sequence Services Element RequestTrigger Element Sequence BookingRequest Element
Overview
BookingRequest BookingRequestType Complex Type
Sequence
RequestTrigger RequestTriggerType Simple Type
Trigger type which initiated the request
Services ServicesRequestType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
RoomCode optional RoomCodeRequestType Complex Type
Board optional BoardCodeRequestType Complex Type
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Data optional CommonFlightDataType Complex Type
Segments optional FlightSegmentsRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
DepartureAirport optional AirportRequestType Complex Type
ArrivalAirport optional AirportRequestType Complex Type
Carrier optional AirlineRequestTypes Complex Type
Classes optional FlightClassesRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Packages PackagesRequestType Complex Type
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Travellers TravellersRequestType Complex Type
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
ConfirmedWarnings optional IdentifiersType Complex Type
List of confirmed warning idemntifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="BookingRequest" type="BookingRequestType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageRequest Element | String Schema


ConfigurationRequest Element

String Schema
ConfigurationRequest Element
String Schema > StringMessageRequest Element : ConfigurationRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
ConfigurationRequestType Complex Type
Diagram
Sequence ConfigurationRequest Element
Overview
ConfigurationRequest ConfigurationRequestType Complex Type
Sequence
Source
<xs:element name="ConfigurationRequest" type="ConfigurationRequestType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageRequest Element | String Schema


VersionRequest Element

String Schema
VersionRequest Element
String Schema > StringMessageRequest Element : VersionRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
VersionRequestType Complex Type
Diagram
Version Element Sequence VersionRequest Element
Overview
VersionRequest VersionRequestType Complex Type
Sequence
Version xs:decimal
version of client system
Source
<xs:element name="VersionRequest" type="VersionRequestType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageRequest Element | String Schema


StringMessageResponse Element

String Schema

StringMessageResponse Element

Collapse All Expand All

String Schema : StringMessageResponse Element

Namespace

http://string.drv.de/xmlschema/string

Diagram

Overview

StringMessageResponse

Sequence

AgencyInformation CommonAgencyType Complex Type

Sequence

Agency xs:string
Identification of the executing agency

AgentId xs:int
Identification of the executing agent

Choice

BookingResponse BookingResponseType Complex Type

Sequence

BookingState BookabilityStateType Simple Type
Bookability state for the whole booking

ProcessState ProcessStateType Simple Type
Indicator of next possible process states of the result

TransactionState TransactionStateType Simple Type
Indicator for a technical error while processing a request, not to be used by touroperator

Services ServicesResponseType Complex Type

Sequence

Service 0..∞

Sequence

Choice

Accommodation AccommodationResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Catalogue optional CatalogueResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

CancellationPolicies optional CancellationPoliciesType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

LocationDetails AccommodationProductResponseType Complex Type

Sequence

GeoLocation optional GeoLocationType Complex Type

Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages

Regions optional RegionsType Complex Type

InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type

Sequence

Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type

Rail optional AccommodationTransferRailInfoResponseDataType Complex Type

Ship optional AccommodationTransferShipInfoResponseDataType Complex Type

Bus optional AccommodationTransferBusInfoResponseDataType Complex Type

Rooms optional AccommodationRoomsResponseType Complex Type

Sequence

Room 0..∞ RoomResponseType Complex Type

Stay AccommodationStayResponseType Complex Type

Sequence

ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator

CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider

Flight FlightResponseType Complex Type

Sequence

Legs optional FlightLegsResponseType Complex Type

Sequence

Leg 0..∞ FlightLegResponseType Complex Type

CommonService CommonServiceResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Catalogue optional CatalogueResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

CancellationPolicies optional CancellationPoliciesType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

References optional ServiceResponseReferencesType Complex Type

Sequence

ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system

Sequence

ReferenceNumber xs:int

Code xs:token

Description 0..∞ TextLanguageType Complex Type

ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"

Sequence

Provider optional xs:string

Id optional xs:string

URL optional xs:string

Packages PackagesResponseType Complex Type

Sequence

Package 0..∞ PackageResponseType Complex Type

Sequence

Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Catalogue optional CatalogueResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

CancellationPolicies optional CancellationPoliciesType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Travellers TravellersResponseType Complex Type

Sequence

Traveller 0..∞ CommonTravellerResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

BookingDetails CommonBookingType Complex Type

Sequence

SessionId optional xs:string
Identification of the current session context

InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

Prices optional PricesResponseType Complex Type
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

DetailPrices 0..∞ CommonPriceResponseType Complex Type

Sequence

PriceName 0..∞ TextLanguageType Complex Type
Price description

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Quantity xs:int
Quantity of price

Price CurrencyAmountType Complex Type
Price amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATAmount optional CurrencyAmountType Complex Type
VAT amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATPercentage optional xs:decimal
VAT percentage

VATIncluded optional xs:boolean
Flag if VAT is included or additional

AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking

TotalPrices 0..∞ TotalPriceType Complex Type

Sequence

Choice

ServicePrice CommonTotalServicePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component

ServiceTypePrice CommonTotalServiceTypePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)

TravellerPrice CommonTotalTravellerPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedTraveller IdentifierType Simple Type
Reference to a traveller

BookingPrice CommonTotalBookingPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

Informations InformationsType Complex Type
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

InformationDetail 1..∞ InformationType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

Warnings WarningsType Complex Type
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

WarningDetail 1..∞ WarningType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user

Errors ErrorsType Complex Type
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

ErrorDetail 1..∞ ErrorType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

ErrorCategory ErrorCategoryType Simple Type
Specific error category

ConfigurationResponse ConfigurationResponseType Complex Type

Sequence

Setting 0..∞ KeyValueType Complex Type

Sequence

Key xs:token

Value xs:string

VersionResponse VersionResponseType Complex Type

Sequence

Version xs:decimal
version of operator system

AgencyClearanceResponse AgencyClearanceResponseType Complex Type

Sequence

POS PosType Complex Type

Sequence

Sequence

Agency
Identification of the executing agency

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Currency CurrencyCodeType Simple Type

Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language

Sequence

PrimaryLanguage xs:language

AdditionalLanguages 0..3 xs:language

Requestor RequestorInformationType Complex Type

Sequence

ID
ID of the requestor which must be unique within the requestors overall system

Type optional

CompanyName optional CompanyNameType Complex Type

Sequence

ShortName optional

Code optional

OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided

Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided

Sequence

Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair

Sequence

LevelID xs:int
Only 1 digit LevelIds are provided

Name

Value

ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system

Sequence

ID

BookingChannel BookingChannelType Complex Type

Sequence

Type

CompanyName optional CompanyNameType Complex Type

Sequence

ShortName optional

Code optional

OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided

Approved xs:boolean

Source
<xs:element name="StringMessageResponse" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" />
      <xs:choice>
        <xs:element name="BookingResponse" type="BookingResponseType" nillable="true" />
        <xs:element name="ConfigurationResponse" type="ConfigurationResponseType" nillable="true" />
        <xs:element name="VersionResponse" type="VersionResponseType" nillable="true" />
        <xs:element name="AgencyClearanceResponse" type="AgencyClearanceResponseType" nillable="true" />
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also

String Schema


AgencyInformation Element

String Schema
AgencyInformation Element
String Schema > StringMessageResponse Element : AgencyInformation Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonAgencyType Complex Type
Diagram
AgentId Element Agency Element Sequence AgencyInformation Element
Overview
AgencyInformation CommonAgencyType Complex Type
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Source
<xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageResponse Element | String Schema


AgencyClearanceResponse Element

String Schema
AgencyClearanceResponse Element
String Schema > StringMessageResponse Element : AgencyClearanceResponse Element
Namespace http://string.drv.de/xmlschema/string
Type
AgencyClearanceResponseType Complex Type
Diagram
Approved Element CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Sequence Country Element Agency Element Sequence Sequence POS Element Sequence AgencyClearanceResponse Element
Overview
AgencyClearanceResponse AgencyClearanceResponseType Complex Type
Sequence
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Approved xs:boolean
Source
<xs:element name="AgencyClearanceResponse" type="AgencyClearanceResponseType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageResponse Element | String Schema


BookingResponse Element

String Schema

BookingResponse Element

Collapse All Expand All

String Schema > StringMessageResponse Element : BookingResponse Element

Namespace

http://string.drv.de/xmlschema/string

Type

BookingResponseType Complex Type

Diagram

Overview

BookingResponse BookingResponseType Complex Type

Sequence

BookingState BookabilityStateType Simple Type
Bookability state for the whole booking

ProcessState ProcessStateType Simple Type
Indicator of next possible process states of the result

TransactionState TransactionStateType Simple Type
Indicator for a technical error while processing a request, not to be used by touroperator

Services ServicesResponseType Complex Type

Sequence

Service 0..∞

Sequence

Choice

Accommodation AccommodationResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

LocationDetails AccommodationProductResponseType Complex Type

Sequence

GeoLocation optional GeoLocationType Complex Type

Sequence

Longitude xs:string

Latitude xs:string

Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Regions optional RegionsType Complex Type

Sequence

Region 1..∞

InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type

Sequence

Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferFlightInfoResponseType Complex Type

Departure optional AccommodationTransferFlightInfoResponseType Complex Type

Rail optional AccommodationTransferRailInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferRailInfoResponseType Complex Type

Departure optional AccommodationTransferRailInfoResponseType Complex Type

Ship optional AccommodationTransferShipInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferShipInfoResponseType Complex Type

Departure optional AccommodationTransferShipInfoResponseType Complex Type

Bus optional AccommodationTransferBusInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferBusInfoResponseType Complex Type

Departure optional AccommodationTransferBusInfoResponseType Complex Type

Rooms optional AccommodationRoomsResponseType Complex Type

Sequence

Room 0..∞ RoomResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique room identifier

State BookabilityStateType Simple Type
Room bookability state

AssignedTravellers optional IdentifiersType Complex Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this room

RoomCode optional RoomCodeResponseType Complex Type

Board optional BoardCodeResponseType Complex Type

IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Stay AccommodationStayResponseType Complex Type

Sequence

ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator

CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider

CheckIn optional DateTimeType Simple Type

CheckOut optional DateTimeType Simple Type

Flight FlightResponseType Complex Type

Sequence

Legs optional FlightLegsResponseType Complex Type

Sequence

Leg 0..∞ FlightLegResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Data optional CommonFlightDataType Complex Type

Segments optional FlightSegmentsResponseType Complex Type

TariffDetails optional FlightTariffsResponseType Complex Type

DepartureAirport optional AirportResponseType Complex Type

ArrivalAirport optional AirportResponseType Complex Type

Carrier optional AirlineResponseTypes Complex Type

Classes optional FlightClassesResponseType Complex Type

FlightDescription 0..∞ TextLanguageType Complex Type

CommonService CommonServiceResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

References optional ServiceResponseReferencesType Complex Type

Sequence

ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system

Sequence

ReferenceNumber xs:int

Code xs:token

Description 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"

Sequence

Provider optional xs:string

Id optional xs:string

URL optional xs:string

Packages PackagesResponseType Complex Type

Sequence

Package 0..∞ PackageResponseType Complex Type

Sequence

Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

Travellers TravellersResponseType Complex Type

Sequence

Traveller 0..∞ CommonTravellerResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

BookingDetails CommonBookingType Complex Type

Sequence

SessionId optional xs:string
Identification of the current session context

InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

Prices optional PricesResponseType Complex Type
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

DetailPrices 0..∞ CommonPriceResponseType Complex Type

Sequence

PriceName 0..∞ TextLanguageType Complex Type
Price description

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Quantity xs:int
Quantity of price

Price CurrencyAmountType Complex Type
Price amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATAmount optional CurrencyAmountType Complex Type
VAT amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATPercentage optional xs:decimal
VAT percentage

VATIncluded optional xs:boolean
Flag if VAT is included or additional

AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking

TotalPrices 0..∞ TotalPriceType Complex Type

Sequence

Choice

ServicePrice CommonTotalServicePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component

ServiceTypePrice CommonTotalServiceTypePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)

TravellerPrice CommonTotalTravellerPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedTraveller IdentifierType Simple Type
Reference to a traveller

BookingPrice CommonTotalBookingPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

Informations InformationsType Complex Type
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

InformationDetail 1..∞ InformationType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

Warnings WarningsType Complex Type
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

WarningDetail 1..∞ WarningType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user

Errors ErrorsType Complex Type
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

ErrorDetail 1..∞ ErrorType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

ErrorCategory ErrorCategoryType Simple Type
Specific error category

Source
<xs:element name="BookingResponse" type="BookingResponseType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

StringMessageResponse Element | String Schema


ConfigurationResponse Element

String Schema
ConfigurationResponse Element
String Schema > StringMessageResponse Element : ConfigurationResponse Element
Namespace http://string.drv.de/xmlschema/string
Type
ConfigurationResponseType Complex Type
Diagram
Value Element Key Element Sequence Setting Element Sequence ConfigurationResponse Element
Overview
ConfigurationResponse ConfigurationResponseType Complex Type
Sequence
Setting 0..∞ KeyValueType Complex Type
Sequence
Key xs:token
Value xs:string
Source
<xs:element name="ConfigurationResponse" type="ConfigurationResponseType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageResponse Element | String Schema


VersionResponse Element

String Schema
VersionResponse Element
String Schema > StringMessageResponse Element : VersionResponse Element
Namespace http://string.drv.de/xmlschema/string
Type
VersionResponseType Complex Type
Diagram
Version Element Sequence VersionResponse Element
Overview
VersionResponse VersionResponseType Complex Type
Sequence
Version xs:decimal
version of operator system
Source
<xs:element name="VersionResponse" type="VersionResponseType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
StringMessageResponse Element | String Schema


AccommodationCheckInOutType Complex Type

String Schema
AccommodationCheckInOutType Complex Type
String Schema : AccommodationCheckInOutType Complex Type
Description
Check In and/or Check Out Date and Time, either (Request) requested by customer or (Response) confirmed by ServiceProvider
Namespace http://string.drv.de/xmlschema/string
Overview
AccommodationCheckInOutType
Check In and/or Check Out Date and Time, either (Request) requested by customer or (Response) confirmed by ServiceProvider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Used By
CheckInOut Element
CheckInOut Element
Attributes
Name | Type | Use | Default | Fixed | Description
CheckIn | DateTimeType Simple Type | optional |  |  |
CheckOut | DateTimeType Simple Type | optional |  |  |
Source
<xs:complexType name="AccommodationCheckInOutType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Check In and/or Check Out Date and Time,
either (Request) requested by customer
or (Response) confirmed by ServiceProvider</xs:documentation>
  </xs:annotation>
  <xs:attribute name="CheckIn" type="DateTimeType" />
  <xs:attribute name="CheckOut" type="DateTimeType" />
</xs:complexType>
See Also
String Schema


AccommodationProductResponseType Complex Type

String Schema
AccommodationProductResponseType Complex Type
String Schema : AccommodationProductResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Region Element Sequence Regions Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Latitude Element Longitude Element Sequence GeoLocation Element Sequence AccommodationProductResponseType Complex Type
Overview
AccommodationProductResponseType
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
LocationDetails Element
Source
<xs:complexType name="AccommodationProductResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="GeoLocation" type="GeoLocationType" nillable="true" minOccurs="0" />
    <xs:element name="Address" type="AddressType" minOccurs="0" maxOccurs="3">
      <xs:annotation>
        <xs:documentation>Possibility to provide the address data in up to 3 different languages</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Regions" type="RegionsType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Address Element

String Schema
Address Element
String Schema > AccommodationProductResponseType Complex Type : Address Element
Description
Possibility to provide the address data in up to 3 different languages
Namespace http://string.drv.de/xmlschema/string
Type
AddressType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element
Overview
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Address" type="AddressType" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Possibility to provide the address data in up to 3 different languages</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationProductResponseType Complex Type | String Schema


GeoLocation Element

String Schema
GeoLocation Element
String Schema > AccommodationProductResponseType Complex Type : GeoLocation Element
Namespace http://string.drv.de/xmlschema/string
Type
GeoLocationType Complex Type
Diagram
Latitude Element Longitude Element Sequence GeoLocation Element
Overview
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="GeoLocation" type="GeoLocationType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationProductResponseType Complex Type | String Schema


Regions Element

String Schema
Regions Element
String Schema > AccommodationProductResponseType Complex Type : Regions Element
Namespace http://string.drv.de/xmlschema/string
Type
RegionsType Complex Type
Diagram
Region Element Sequence Regions Element
Overview
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Regions" type="RegionsType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationProductResponseType Complex Type | String Schema


AccommodationRequestType Complex Type

String Schema
AccommodationRequestType Complex Type
String Schema : AccommodationRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceRequestType Complex Type
Diagram
CheckInOut Element Sequence StayRequest Element CustomerRequests Element IncludedExtras Element Board Element RoomCode Element Attributes Element AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence Rooms Element Departure Element Arrival Element Sequence Bus Element Departure Element Arrival Element Sequence Ship Element Departure Element Arrival Element Sequence Rail Element Departure Element Arrival Element Sequence Flight Element Sequence InformationForTransfer Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence AccommodationRequestType Complex Type
Overview
AccommodationRequestType Extension of CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Used By
Accommodation Element
Source
<xs:complexType name="AccommodationRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceRequestType">
      <xs:sequence>
        <xs:element name="InformationForTransfer" type="AccommodationTransferInfoRequestType" nillable="true" minOccurs="0" />
        <xs:element name="Rooms" type="AccommodationRoomsRequestType" nillable="true" minOccurs="0" />
        <xs:element name="StayRequest" type="AccommodationStayRequestType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > AccommodationRequestType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > AccommodationRequestType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > AccommodationRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > AccommodationRequestType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > AccommodationRequestType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


InformationForTransfer Element

String Schema
InformationForTransfer Element
String Schema > AccommodationRequestType Complex Type : InformationForTransfer Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferInfoRequestType Complex Type
Diagram
Sequence BusReference Element Choice Departure Element Sequence BusReference Element Choice Arrival Element Sequence Bus Element Sequence ShipReference Element Choice Departure Element Sequence ShipReference Element Choice Arrival Element Sequence Ship Element Sequence RailReference Element Choice Departure Element Sequence RailReference Element Choice Arrival Element Sequence Rail Element Sequence FlightReference Element Choice Departure Element Sequence FlightReference Element Choice Arrival Element Sequence Flight Element Sequence InformationForTransfer Element
Overview
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="InformationForTransfer" type="AccommodationTransferInfoRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationRequestType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > AccommodationRequestType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > AccommodationRequestType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeRequestType Complex Type
Diagram
Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Source
<xs:element name="Product" type="ProductCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationRequestType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > AccommodationRequestType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


RequestedPrices Element

String Schema
RequestedPrices Element
String Schema > AccommodationRequestType Complex Type : RequestedPrices Element
Description
Prices of an offer or the prices resulting from an external search
Namespace http://string.drv.de/xmlschema/string
Type
PricesRequestType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element
Overview
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="RequestedPrices" type="PricesRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Prices of an offer or the prices resulting from an external search</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


Rooms Element

String Schema
Rooms Element
String Schema > AccommodationRequestType Complex Type : Rooms Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationRoomsRequestType Complex Type
Diagram
AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Attributes Element Code Element Sequence Board Element Code Element Sequence RoomCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence Rooms Element
Overview
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Rooms" type="AccommodationRoomsRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationRequestType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > AccommodationRequestType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


StayRequest Element

String Schema
StayRequest Element
String Schema > AccommodationRequestType Complex Type : StayRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationStayRequestType Complex Type
Diagram
CheckInOut Element Sequence StayRequest Element
Overview
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Source
<xs:element name="StayRequest" type="AccommodationStayRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationRequestType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > AccommodationRequestType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationRequestType Complex Type | String Schema


AccommodationResponseType Complex Type

String Schema
AccommodationResponseType Complex Type
String Schema : AccommodationResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceResponseType Complex Type
Diagram
CheckInOut Element ChargedNights Element Sequence Stay Element CustomerRequests Element IncludedExtras Element Board Element RoomCode Element Attributes Element AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence Rooms Element Departure Element Arrival Element Sequence Bus Element Departure Element Arrival Element Sequence Ship Element Departure Element Arrival Element Sequence Rail Element Departure Element Arrival Element Sequence Flight Element Sequence InformationForTransfer Element Region Element Sequence Regions Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Latitude Element Longitude Element Sequence GeoLocation Element Sequence LocationDetails Element Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence AccommodationResponseType Complex Type
Overview
AccommodationResponseType Extension of CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
LocationDetails AccommodationProductResponseType Complex Type
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Rooms optional AccommodationRoomsResponseType Complex Type
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Stay AccommodationStayResponseType Complex Type
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Used By
Accommodation Element
Source
<xs:complexType name="AccommodationResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceResponseType">
      <xs:sequence>
        <xs:element name="LocationDetails" type="AccommodationProductResponseType" nillable="false" />
        <xs:element name="InformationForTransfer" type="AccommodationTransferInfoResponseType" nillable="true" minOccurs="0" />
        <xs:element name="Rooms" type="AccommodationRoomsResponseType" nillable="true" minOccurs="0" />
        <xs:element name="Stay" type="AccommodationStayResponseType" nillable="true" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AdditionalInfos Element

String Schema
AdditionalInfos Element
String Schema > AccommodationResponseType Complex Type : AdditionalInfos Element
Description
Additional infos (e.g. cancellation and modifications conditions)
Namespace http://string.drv.de/xmlschema/string
Type
ServicesResponseAdditionalInfoType Complex Type
Diagram
Choice From Element Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element Choice From Element Description Element Sequence Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element
Overview
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="AdditionalInfos" type="ServicesResponseAdditionalInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Additional infos (e.g. cancellation and modifications conditions)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > AccommodationResponseType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > AccommodationResponseType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > AccommodationResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > AccommodationResponseType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > AccommodationResponseType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


InformationForTransfer Element

String Schema
InformationForTransfer Element
String Schema > AccommodationResponseType Complex Type : InformationForTransfer Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferInfoResponseType Complex Type
Diagram
Sequence BusReference Element Choice Departure Element Sequence BusReference Element Choice Arrival Element Sequence Bus Element Sequence ShipReference Element Choice Departure Element Sequence ShipReference Element Choice Arrival Element Sequence Ship Element Sequence RailReference Element Choice Departure Element Sequence RailReference Element Choice Arrival Element Sequence Rail Element Sequence FlightReference Element Choice Departure Element Sequence FlightReference Element Choice Arrival Element Sequence Flight Element Sequence InformationForTransfer Element
Overview
InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="InformationForTransfer" type="AccommodationTransferInfoResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationResponseType Complex Type | String Schema


LocationDetails Element

String Schema
LocationDetails Element
String Schema > AccommodationResponseType Complex Type : LocationDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationProductResponseType Complex Type
Diagram
Region Element Sequence Regions Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Latitude Element Longitude Element Sequence GeoLocation Element Sequence LocationDetails Element
Overview
LocationDetails AccommodationProductResponseType Complex Type
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="LocationDetails" type="AccommodationProductResponseType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationResponseType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > AccommodationResponseType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > AccommodationResponseType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Product" type="ProductCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationResponseType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > AccommodationResponseType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


Rooms Element

String Schema
Rooms Element
String Schema > AccommodationResponseType Complex Type : Rooms Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationRoomsResponseType Complex Type
Diagram
State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Description Element Attributes Element Code Element Sequence Board Element Description Element Code Element Sequence RoomCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence Rooms Element
Overview
Rooms optional AccommodationRoomsResponseType Complex Type
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="Rooms" type="AccommodationRoomsResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationResponseType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > AccommodationResponseType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > AccommodationResponseType Complex Type : State Element
Description
Service bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Service bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Service bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


Stay Element

String Schema
Stay Element
String Schema > AccommodationResponseType Complex Type : Stay Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationStayResponseType Complex Type
Diagram
CheckInOut Element ChargedNights Element Sequence Stay Element
Overview
Stay AccommodationStayResponseType Complex Type
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Source
<xs:element name="Stay" type="AccommodationStayResponseType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationResponseType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > AccommodationResponseType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationResponseType Complex Type | String Schema


AccommodationRoomsRequestType Complex Type

String Schema
AccommodationRoomsRequestType Complex Type
String Schema : AccommodationRoomsRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Attributes Element Code Element Sequence Board Element Code Element Sequence RoomCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence AccommodationRoomsRequestType Complex Type
Overview
AccommodationRoomsRequestType
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Rooms Element
Source
<xs:complexType name="AccommodationRoomsRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Room" type="RoomRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Room Element

String Schema
Room Element
String Schema > AccommodationRoomsRequestType Complex Type : Room Element
Namespace http://string.drv.de/xmlschema/string
Type
RoomRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element Attribute Element Sequence Attributes Element Code Element Sequence Board Element Code Element Sequence RoomCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence Room Element
Overview
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Room" type="RoomRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationRoomsRequestType Complex Type | String Schema


AccommodationRoomsResponseType Complex Type

String Schema
AccommodationRoomsResponseType Complex Type
String Schema : AccommodationRoomsResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Description Element Attributes Element Code Element Sequence Board Element Description Element Code Element Sequence RoomCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence AccommodationRoomsResponseType Complex Type
Overview
AccommodationRoomsResponseType
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Used By
Rooms Element
Source
<xs:complexType name="AccommodationRoomsResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Room" type="RoomResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Room Element

String Schema
Room Element
String Schema > AccommodationRoomsResponseType Complex Type : Room Element
Namespace http://string.drv.de/xmlschema/string
Type
RoomResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element LanguageCode Element Text Element Sequence Description Element Attribute Element Sequence Attributes Element Code Element Sequence Board Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence RoomCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence Room Element
Overview
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="Room" type="RoomResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationRoomsResponseType Complex Type | String Schema


AccommodationStayRequestType Complex Type

String Schema
AccommodationStayRequestType Complex Type
String Schema : AccommodationStayRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
CheckInOut Element Sequence AccommodationStayRequestType Complex Type
Overview
AccommodationStayRequestType
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Used By
StayRequest Element
Source
<xs:complexType name="AccommodationStayRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="CheckInOut" type="AccommodationCheckInOutType" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Check In/Out Date and Time requested by the customer</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CheckInOut Element

String Schema
CheckInOut Element
String Schema > AccommodationStayRequestType Complex Type : CheckInOut Element
Description
Check In/Out Date and Time requested by the customer
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationCheckInOutType Complex Type
Overview
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Source
<xs:element name="CheckInOut" type="AccommodationCheckInOutType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Check In/Out Date and Time requested by the customer</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationStayRequestType Complex Type | String Schema


AccommodationStayResponseType Complex Type

String Schema
AccommodationStayResponseType Complex Type
String Schema : AccommodationStayResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
CheckInOut Element ChargedNights Element Sequence AccommodationStayResponseType Complex Type
Overview
AccommodationStayResponseType
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Used By
Stay Element
Source
<xs:complexType name="AccommodationStayResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="ChargedNights" type="xs:int">
      <xs:annotation>
        <xs:documentation>Charged nights for the accommodation calculated by the touroperator</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="CheckInOut" type="AccommodationCheckInOutType">
      <xs:annotation>
        <xs:documentation>Check In/Out Date and Time confirmed by the provider</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


ChargedNights Element

String Schema
ChargedNights Element
String Schema > AccommodationStayResponseType Complex Type : ChargedNights Element
Description
Charged nights for the accommodation calculated by the touroperator
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
Source
<xs:element name="ChargedNights" type="xs:int" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Charged nights for the accommodation calculated by the touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationStayResponseType Complex Type | String Schema


CheckInOut Element

String Schema
CheckInOut Element
String Schema > AccommodationStayResponseType Complex Type : CheckInOut Element
Description
Check In/Out Date and Time confirmed by the provider
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationCheckInOutType Complex Type
Overview
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Source
<xs:element name="CheckInOut" type="AccommodationCheckInOutType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Check In/Out Date and Time confirmed by the provider</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationStayResponseType Complex Type | String Schema


AccommodationTransferBusInfoRequestDataType Complex Type

String Schema
AccommodationTransferBusInfoRequestDataType Complex Type
String Schema : AccommodationTransferBusInfoRequestDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Departure Element BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Arrival Element Sequence AccommodationTransferBusInfoRequestDataType Complex Type
Overview
AccommodationTransferBusInfoRequestDataType
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Used By
Bus Element
Source
<xs:complexType name="AccommodationTransferBusInfoRequestDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferBusInfoRequestType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferBusInfoRequestType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferBusInfoRequestDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferBusInfoRequestType Complex Type
Diagram
BusNumber Element BusStation Element Date Element Sequence BusReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="Arrival" type="AccommodationTransferBusInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoRequestDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferBusInfoRequestDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferBusInfoRequestType Complex Type
Diagram
BusNumber Element BusStation Element Date Element Sequence BusReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="Departure" type="AccommodationTransferBusInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoRequestDataType Complex Type | String Schema


AccommodationTransferBusInfoRequestType Complex Type

String Schema
AccommodationTransferBusInfoRequestType Complex Type
String Schema : AccommodationTransferBusInfoRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
BusNumber Element BusStation Element Date Element Sequence BusReference Element Choice AccommodationTransferBusInfoRequestType Complex Type
Overview
AccommodationTransferBusInfoRequestType
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferBusInfoRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="BusReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="Date" type="DateTimeType" minOccurs="0" />
      <xs:element name="BusStation" type="TextLanguageType" minOccurs="0" />
      <xs:element name="BusNumber" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


BusReference Element

String Schema
BusReference Element
String Schema > AccommodationTransferBusInfoRequestType Complex Type : BusReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
BusReference optional
Source
<xs:element name="BusReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoRequestType Complex Type | String Schema


BusNumber Element

String Schema
BusNumber Element
String Schema > AccommodationTransferBusInfoRequestType Complex Type : BusNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
BusNumber optional xs:string
Source
<xs:element name="BusNumber" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoRequestType Complex Type | String Schema


BusStation Element

String Schema
BusStation Element
String Schema > AccommodationTransferBusInfoRequestType Complex Type : BusStation Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence BusStation Element
Overview
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="BusStation" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoRequestType Complex Type | String Schema


Date Element

String Schema
Date Element
String Schema > AccommodationTransferBusInfoRequestType Complex Type : Date Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
Date optional DateTimeType Simple Type
Source
<xs:element name="Date" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoRequestType Complex Type | String Schema


AccommodationTransferBusInfoResponseDataType Complex Type

String Schema
AccommodationTransferBusInfoResponseDataType Complex Type
String Schema : AccommodationTransferBusInfoResponseDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Departure Element BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Arrival Element Sequence AccommodationTransferBusInfoResponseDataType Complex Type
Overview
AccommodationTransferBusInfoResponseDataType
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Used By
Bus Element
Source
<xs:complexType name="AccommodationTransferBusInfoResponseDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferBusInfoResponseType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferBusInfoResponseType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferBusInfoResponseDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferBusInfoResponseType Complex Type
Diagram
BusNumber Element BusStation Element Date Element Sequence BusReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="Arrival" type="AccommodationTransferBusInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoResponseDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferBusInfoResponseDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferBusInfoResponseType Complex Type
Diagram
BusNumber Element BusStation Element Date Element Sequence BusReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="Departure" type="AccommodationTransferBusInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoResponseDataType Complex Type | String Schema


AccommodationTransferBusInfoResponseType Complex Type

String Schema
AccommodationTransferBusInfoResponseType Complex Type
String Schema : AccommodationTransferBusInfoResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
BusNumber Element BusStation Element Date Element Sequence BusReference Element Choice AccommodationTransferBusInfoResponseType Complex Type
Overview
AccommodationTransferBusInfoResponseType
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferBusInfoResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="BusReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="Date" type="DateTimeType" minOccurs="0" />
      <xs:element name="BusStation" type="TextLanguageType" minOccurs="0" />
      <xs:element name="BusNumber" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


BusReference Element

String Schema
BusReference Element
String Schema > AccommodationTransferBusInfoResponseType Complex Type : BusReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
BusReference optional
Source
<xs:element name="BusReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoResponseType Complex Type | String Schema


BusNumber Element

String Schema
BusNumber Element
String Schema > AccommodationTransferBusInfoResponseType Complex Type : BusNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
BusNumber optional xs:string
Source
<xs:element name="BusNumber" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoResponseType Complex Type | String Schema


BusStation Element

String Schema
BusStation Element
String Schema > AccommodationTransferBusInfoResponseType Complex Type : BusStation Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence BusStation Element
Overview
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="BusStation" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoResponseType Complex Type | String Schema


Date Element

String Schema
Date Element
String Schema > AccommodationTransferBusInfoResponseType Complex Type : Date Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
Date optional DateTimeType Simple Type
Source
<xs:element name="Date" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferBusInfoResponseType Complex Type | String Schema


AccommodationTransferFlightInfoRequestDataType Complex Type

String Schema
AccommodationTransferFlightInfoRequestDataType Complex Type
String Schema : AccommodationTransferFlightInfoRequestDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Sequence Carrier Element FlightNumber Element Choice ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Departure Element Sequence Carrier Element FlightNumber Element Choice ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Arrival Element Sequence AccommodationTransferFlightInfoRequestDataType Complex Type
Overview
AccommodationTransferFlightInfoRequestDataType
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Used By
Flight Element
Source
<xs:complexType name="AccommodationTransferFlightInfoRequestDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferFlightInfoRequestType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferFlightInfoRequestType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferFlightInfoRequestDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferFlightInfoRequestType Complex Type
Diagram
Carrier Element FlightNumber Element ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="Arrival" type="AccommodationTransferFlightInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoRequestDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferFlightInfoRequestDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferFlightInfoRequestType Complex Type
Diagram
Carrier Element FlightNumber Element ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="Departure" type="AccommodationTransferFlightInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoRequestDataType Complex Type | String Schema


AccommodationTransferFlightInfoRequestType Complex Type

String Schema
AccommodationTransferFlightInfoRequestType Complex Type
String Schema : AccommodationTransferFlightInfoRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Carrier Element FlightNumber Element ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice AccommodationTransferFlightInfoRequestType Complex Type
Overview
AccommodationTransferFlightInfoRequestType
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferFlightInfoRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="FlightReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="ArrivalDate" type="DateTimeType" minOccurs="0" />
      <xs:element name="ArrivalAirport" type="AirportRequestType" minOccurs="0" />
      <xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" />
      <xs:element name="Carrier" type="AirlineRequestTypes" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Carrier information of the flight</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


FlightReference Element

String Schema
FlightReference Element
String Schema > AccommodationTransferFlightInfoRequestType Complex Type : FlightReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
FlightReference optional
Source
<xs:element name="FlightReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoRequestType Complex Type | String Schema


ArrivalAirport Element

String Schema
ArrivalAirport Element
String Schema > AccommodationTransferFlightInfoRequestType Complex Type : ArrivalAirport Element
Namespace http://string.drv.de/xmlschema/string
Type
AirportRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice ArrivalAirport Element
Overview
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="ArrivalAirport" type="AirportRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoRequestType Complex Type | String Schema


ArrivalDate Element

String Schema
ArrivalDate Element
String Schema > AccommodationTransferFlightInfoRequestType Complex Type : ArrivalDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
ArrivalDate optional DateTimeType Simple Type
Source
<xs:element name="ArrivalDate" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoRequestType Complex Type | String Schema


Carrier Element

String Schema
Carrier Element
String Schema > AccommodationTransferFlightInfoRequestType Complex Type : Carrier Element
Description
Carrier information of the flight
Namespace http://string.drv.de/xmlschema/string
Type
AirlineRequestTypes Complex Type
Diagram
IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element
Overview
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="Carrier" type="AirlineRequestTypes" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Carrier information of the flight</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationTransferFlightInfoRequestType Complex Type | String Schema


FlightNumber Element

String Schema
FlightNumber Element
String Schema > AccommodationTransferFlightInfoRequestType Complex Type : FlightNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightNumberType Simple Type
Overview
FlightNumber optional FlightNumberType Simple Type
Source
<xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoRequestType Complex Type | String Schema


AccommodationTransferFlightInfoResponseDataType Complex Type

String Schema
AccommodationTransferFlightInfoResponseDataType Complex Type
String Schema : AccommodationTransferFlightInfoResponseDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Sequence Carrier Element FlightNumber Element Sequence ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Departure Element Sequence Carrier Element FlightNumber Element Sequence ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Arrival Element Sequence AccommodationTransferFlightInfoResponseDataType Complex Type
Overview
AccommodationTransferFlightInfoResponseDataType
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Flight Element
Source
<xs:complexType name="AccommodationTransferFlightInfoResponseDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferFlightInfoResponseType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferFlightInfoResponseType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferFlightInfoResponseDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferFlightInfoResponseType Complex Type
Diagram
Carrier Element FlightNumber Element ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Arrival" type="AccommodationTransferFlightInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoResponseDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferFlightInfoResponseDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferFlightInfoResponseType Complex Type
Diagram
Carrier Element FlightNumber Element ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Departure" type="AccommodationTransferFlightInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoResponseDataType Complex Type | String Schema


AccommodationTransferFlightInfoResponseType Complex Type

String Schema
AccommodationTransferFlightInfoResponseType Complex Type
String Schema : AccommodationTransferFlightInfoResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Carrier Element FlightNumber Element ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice AccommodationTransferFlightInfoResponseType Complex Type
Overview
AccommodationTransferFlightInfoResponseType
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferFlightInfoResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="FlightReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="ArrivalDate" type="DateTimeType" minOccurs="0" />
      <xs:element name="ArrivalAirport" type="AirportResponseType" minOccurs="0" />
      <xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" />
      <xs:element name="Carrier" type="AirlineResponseTypes" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Carrier information of the flight</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


FlightReference Element

String Schema
FlightReference Element
String Schema > AccommodationTransferFlightInfoResponseType Complex Type : FlightReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
FlightReference optional
Source
<xs:element name="FlightReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoResponseType Complex Type | String Schema


ArrivalAirport Element

String Schema
ArrivalAirport Element
String Schema > AccommodationTransferFlightInfoResponseType Complex Type : ArrivalAirport Element
Namespace http://string.drv.de/xmlschema/string
Type
AirportResponseType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element
Overview
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="ArrivalAirport" type="AirportResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoResponseType Complex Type | String Schema


ArrivalDate Element

String Schema
ArrivalDate Element
String Schema > AccommodationTransferFlightInfoResponseType Complex Type : ArrivalDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
ArrivalDate optional DateTimeType Simple Type
Source
<xs:element name="ArrivalDate" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoResponseType Complex Type | String Schema


Carrier Element

String Schema
Carrier Element
String Schema > AccommodationTransferFlightInfoResponseType Complex Type : Carrier Element
Description
Carrier information of the flight
Namespace http://string.drv.de/xmlschema/string
Type
AirlineResponseTypes Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence MarketingCarrier Element LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence OperatingCarrier Element Sequence Carrier Element
Overview
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Carrier" type="AirlineResponseTypes" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Carrier information of the flight</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AccommodationTransferFlightInfoResponseType Complex Type | String Schema


FlightNumber Element

String Schema
FlightNumber Element
String Schema > AccommodationTransferFlightInfoResponseType Complex Type : FlightNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightNumberType Simple Type
Overview
FlightNumber optional FlightNumberType Simple Type
Source
<xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferFlightInfoResponseType Complex Type | String Schema


AccommodationTransferInfoRequestType Complex Type

String Schema
AccommodationTransferInfoRequestType Complex Type
String Schema : AccommodationTransferInfoRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Sequence BusReference Element Choice Departure Element Sequence BusReference Element Choice Arrival Element Sequence Bus Element Sequence ShipReference Element Choice Departure Element Sequence ShipReference Element Choice Arrival Element Sequence Ship Element Sequence RailReference Element Choice Departure Element Sequence RailReference Element Choice Arrival Element Sequence Rail Element Sequence FlightReference Element Choice Departure Element Sequence FlightReference Element Choice Arrival Element Sequence Flight Element Sequence AccommodationTransferInfoRequestType Complex Type
Overview
AccommodationTransferInfoRequestType
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Used By
InformationForTransfer Element
Source
<xs:complexType name="AccommodationTransferInfoRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Flight" type="AccommodationTransferFlightInfoRequestDataType" minOccurs="0" />
    <xs:element name="Rail" type="AccommodationTransferRailInfoRequestDataType" minOccurs="0" />
    <xs:element name="Ship" type="AccommodationTransferShipInfoRequestDataType" minOccurs="0" />
    <xs:element name="Bus" type="AccommodationTransferBusInfoRequestDataType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Bus Element

String Schema
Bus Element
String Schema > AccommodationTransferInfoRequestType Complex Type : Bus Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferBusInfoRequestDataType Complex Type
Diagram
BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Departure Element BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Arrival Element Sequence Bus Element
Overview
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="Bus" type="AccommodationTransferBusInfoRequestDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoRequestType Complex Type | String Schema


Flight Element

String Schema
Flight Element
String Schema > AccommodationTransferInfoRequestType Complex Type : Flight Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferFlightInfoRequestDataType Complex Type
Diagram
Sequence Carrier Element FlightNumber Element Choice ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Departure Element Sequence Carrier Element FlightNumber Element Choice ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Arrival Element Sequence Flight Element
Overview
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="Flight" type="AccommodationTransferFlightInfoRequestDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoRequestType Complex Type | String Schema


Rail Element

String Schema
Rail Element
String Schema > AccommodationTransferInfoRequestType Complex Type : Rail Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferRailInfoRequestDataType Complex Type
Diagram
TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Departure Element TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Arrival Element Sequence Rail Element
Overview
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Source
<xs:element name="Rail" type="AccommodationTransferRailInfoRequestDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoRequestType Complex Type | String Schema


Ship Element

String Schema
Ship Element
String Schema > AccommodationTransferInfoRequestType Complex Type : Ship Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferShipInfoRequestDataType Complex Type
Diagram
ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Departure Element ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Arrival Element Sequence Ship Element
Overview
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Source
<xs:element name="Ship" type="AccommodationTransferShipInfoRequestDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoRequestType Complex Type | String Schema


AccommodationTransferInfoResponseType Complex Type

String Schema
AccommodationTransferInfoResponseType Complex Type
String Schema : AccommodationTransferInfoResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Sequence BusReference Element Choice Departure Element Sequence BusReference Element Choice Arrival Element Sequence Bus Element Sequence ShipReference Element Choice Departure Element Sequence ShipReference Element Choice Arrival Element Sequence Ship Element Sequence RailReference Element Choice Departure Element Sequence RailReference Element Choice Arrival Element Sequence Rail Element Sequence FlightReference Element Choice Departure Element Sequence FlightReference Element Choice Arrival Element Sequence Flight Element Sequence AccommodationTransferInfoResponseType Complex Type
Overview
AccommodationTransferInfoResponseType
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Used By
InformationForTransfer Element
Source
<xs:complexType name="AccommodationTransferInfoResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Flight" type="AccommodationTransferFlightInfoResponseDataType" minOccurs="0" />
    <xs:element name="Rail" type="AccommodationTransferRailInfoResponseDataType" minOccurs="0" />
    <xs:element name="Ship" type="AccommodationTransferShipInfoResponseDataType" minOccurs="0" />
    <xs:element name="Bus" type="AccommodationTransferBusInfoResponseDataType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Bus Element

String Schema
Bus Element
String Schema > AccommodationTransferInfoResponseType Complex Type : Bus Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferBusInfoResponseDataType Complex Type
Diagram
BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Departure Element BusNumber Element Sequence BusStation Element Date Element Sequence BusReference Element Choice Arrival Element Sequence Bus Element
Overview
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Source
<xs:element name="Bus" type="AccommodationTransferBusInfoResponseDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoResponseType Complex Type | String Schema


Flight Element

String Schema
Flight Element
String Schema > AccommodationTransferInfoResponseType Complex Type : Flight Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferFlightInfoResponseDataType Complex Type
Diagram
Sequence Carrier Element FlightNumber Element Sequence ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Departure Element Sequence Carrier Element FlightNumber Element Sequence ArrivalAirport Element ArrivalDate Element Sequence FlightReference Element Choice Arrival Element Sequence Flight Element
Overview
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Flight" type="AccommodationTransferFlightInfoResponseDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoResponseType Complex Type | String Schema


Rail Element

String Schema
Rail Element
String Schema > AccommodationTransferInfoResponseType Complex Type : Rail Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferRailInfoResponseDataType Complex Type
Diagram
TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Departure Element TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Arrival Element Sequence Rail Element
Overview
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Source
<xs:element name="Rail" type="AccommodationTransferRailInfoResponseDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoResponseType Complex Type | String Schema


Ship Element

String Schema
Ship Element
String Schema > AccommodationTransferInfoResponseType Complex Type : Ship Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferShipInfoResponseDataType Complex Type
Diagram
ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Departure Element ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Arrival Element Sequence Ship Element
Overview
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Source
<xs:element name="Ship" type="AccommodationTransferShipInfoResponseDataType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferInfoResponseType Complex Type | String Schema


AccommodationTransferRailInfoRequestDataType Complex Type

String Schema
AccommodationTransferRailInfoRequestDataType Complex Type
String Schema : AccommodationTransferRailInfoRequestDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Departure Element TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Arrival Element Sequence AccommodationTransferRailInfoRequestDataType Complex Type
Overview
AccommodationTransferRailInfoRequestDataType
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Used By
Rail Element
Source
<xs:complexType name="AccommodationTransferRailInfoRequestDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferRailInfoRequestType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferRailInfoRequestType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferRailInfoRequestDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferRailInfoRequestType Complex Type
Diagram
TrainNumber Element Station Element Date Element Sequence RailReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Source
<xs:element name="Arrival" type="AccommodationTransferRailInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoRequestDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferRailInfoRequestDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferRailInfoRequestType Complex Type
Diagram
TrainNumber Element Station Element Date Element Sequence RailReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Source
<xs:element name="Departure" type="AccommodationTransferRailInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoRequestDataType Complex Type | String Schema


AccommodationTransferRailInfoRequestType Complex Type

String Schema
AccommodationTransferRailInfoRequestType Complex Type
String Schema : AccommodationTransferRailInfoRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
TrainNumber Element Station Element Date Element Sequence RailReference Element Choice AccommodationTransferRailInfoRequestType Complex Type
Overview
AccommodationTransferRailInfoRequestType
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferRailInfoRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="RailReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="Date" type="DateTimeType" minOccurs="0" />
      <xs:element name="Station" type="TextLanguageType" minOccurs="0" />
      <xs:element name="TrainNumber" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


RailReference Element

String Schema
RailReference Element
String Schema > AccommodationTransferRailInfoRequestType Complex Type : RailReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
RailReference optional
Source
<xs:element name="RailReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoRequestType Complex Type | String Schema


Date Element

String Schema
Date Element
String Schema > AccommodationTransferRailInfoRequestType Complex Type : Date Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
Date optional DateTimeType Simple Type
Source
<xs:element name="Date" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoRequestType Complex Type | String Schema


Station Element

String Schema
Station Element
String Schema > AccommodationTransferRailInfoRequestType Complex Type : Station Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Station Element
Overview
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Station" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoRequestType Complex Type | String Schema


TrainNumber Element

String Schema
TrainNumber Element
String Schema > AccommodationTransferRailInfoRequestType Complex Type : TrainNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
TrainNumber optional xs:string
Source
<xs:element name="TrainNumber" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoRequestType Complex Type | String Schema


AccommodationTransferRailInfoResponseDataType Complex Type

String Schema
AccommodationTransferRailInfoResponseDataType Complex Type
String Schema : AccommodationTransferRailInfoResponseDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Departure Element TrainNumber Element Sequence Station Element Date Element Sequence RailReference Element Choice Arrival Element Sequence AccommodationTransferRailInfoResponseDataType Complex Type
Overview
AccommodationTransferRailInfoResponseDataType
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Used By
Rail Element
Source
<xs:complexType name="AccommodationTransferRailInfoResponseDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferRailInfoResponseType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferRailInfoResponseType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferRailInfoResponseDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferRailInfoResponseType Complex Type
Diagram
TrainNumber Element Station Element Date Element Sequence RailReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Source
<xs:element name="Arrival" type="AccommodationTransferRailInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoResponseDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferRailInfoResponseDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferRailInfoResponseType Complex Type
Diagram
TrainNumber Element Station Element Date Element Sequence RailReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Source
<xs:element name="Departure" type="AccommodationTransferRailInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoResponseDataType Complex Type | String Schema


AccommodationTransferRailInfoResponseType Complex Type

String Schema
AccommodationTransferRailInfoResponseType Complex Type
String Schema : AccommodationTransferRailInfoResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
TrainNumber Element Station Element Date Element Sequence RailReference Element Choice AccommodationTransferRailInfoResponseType Complex Type
Overview
AccommodationTransferRailInfoResponseType
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferRailInfoResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="RailReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="Date" type="DateTimeType" minOccurs="0" />
      <xs:element name="Station" type="TextLanguageType" minOccurs="0" />
      <xs:element name="TrainNumber" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


RailReference Element

String Schema
RailReference Element
String Schema > AccommodationTransferRailInfoResponseType Complex Type : RailReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
RailReference optional
Source
<xs:element name="RailReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoResponseType Complex Type | String Schema


Date Element

String Schema
Date Element
String Schema > AccommodationTransferRailInfoResponseType Complex Type : Date Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
Date optional DateTimeType Simple Type
Source
<xs:element name="Date" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoResponseType Complex Type | String Schema


Station Element

String Schema
Station Element
String Schema > AccommodationTransferRailInfoResponseType Complex Type : Station Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Station Element
Overview
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Station" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoResponseType Complex Type | String Schema


TrainNumber Element

String Schema
TrainNumber Element
String Schema > AccommodationTransferRailInfoResponseType Complex Type : TrainNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
TrainNumber optional xs:string
Source
<xs:element name="TrainNumber" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferRailInfoResponseType Complex Type | String Schema


AccommodationTransferShipInfoRequestDataType Complex Type

String Schema
AccommodationTransferShipInfoRequestDataType Complex Type
String Schema : AccommodationTransferShipInfoRequestDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Departure Element ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Arrival Element Sequence AccommodationTransferShipInfoRequestDataType Complex Type
Overview
AccommodationTransferShipInfoRequestDataType
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Used By
Ship Element
Source
<xs:complexType name="AccommodationTransferShipInfoRequestDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferShipInfoRequestType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferShipInfoRequestType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferShipInfoRequestDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferShipInfoRequestType Complex Type
Diagram
ShipNumber Element Harbour Element Date Element Sequence ShipReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Source
<xs:element name="Arrival" type="AccommodationTransferShipInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoRequestDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferShipInfoRequestDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferShipInfoRequestType Complex Type
Diagram
ShipNumber Element Harbour Element Date Element Sequence ShipReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Source
<xs:element name="Departure" type="AccommodationTransferShipInfoRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoRequestDataType Complex Type | String Schema


AccommodationTransferShipInfoRequestType Complex Type

String Schema
AccommodationTransferShipInfoRequestType Complex Type
String Schema : AccommodationTransferShipInfoRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ShipNumber Element Harbour Element Date Element Sequence ShipReference Element Choice AccommodationTransferShipInfoRequestType Complex Type
Overview
AccommodationTransferShipInfoRequestType
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferShipInfoRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="ShipReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="Date" type="DateTimeType" minOccurs="0" />
      <xs:element name="Harbour" type="TextLanguageType" minOccurs="0" />
      <xs:element name="ShipNumber" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


ShipReference Element

String Schema
ShipReference Element
String Schema > AccommodationTransferShipInfoRequestType Complex Type : ShipReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
ShipReference optional
Source
<xs:element name="ShipReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoRequestType Complex Type | String Schema


Date Element

String Schema
Date Element
String Schema > AccommodationTransferShipInfoRequestType Complex Type : Date Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
Date optional DateTimeType Simple Type
Source
<xs:element name="Date" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoRequestType Complex Type | String Schema


Harbour Element

String Schema
Harbour Element
String Schema > AccommodationTransferShipInfoRequestType Complex Type : Harbour Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Harbour Element
Overview
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Harbour" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoRequestType Complex Type | String Schema


ShipNumber Element

String Schema
ShipNumber Element
String Schema > AccommodationTransferShipInfoRequestType Complex Type : ShipNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ShipNumber optional xs:string
Source
<xs:element name="ShipNumber" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoRequestType Complex Type | String Schema


AccommodationTransferShipInfoResponseDataType Complex Type

String Schema
AccommodationTransferShipInfoResponseDataType Complex Type
String Schema : AccommodationTransferShipInfoResponseDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Departure Element ShipNumber Element Sequence Harbour Element Date Element Sequence ShipReference Element Choice Arrival Element Sequence AccommodationTransferShipInfoResponseDataType Complex Type
Overview
AccommodationTransferShipInfoResponseDataType
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Used By
Ship Element
Source
<xs:complexType name="AccommodationTransferShipInfoResponseDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Arrival" type="AccommodationTransferShipInfoResponseType" minOccurs="0" />
    <xs:element name="Departure" type="AccommodationTransferShipInfoResponseType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Arrival Element

String Schema
Arrival Element
String Schema > AccommodationTransferShipInfoResponseDataType Complex Type : Arrival Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferShipInfoResponseType Complex Type
Diagram
ShipNumber Element Harbour Element Date Element Sequence ShipReference Element Choice Arrival Element
Overview
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Source
<xs:element name="Arrival" type="AccommodationTransferShipInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoResponseDataType Complex Type | String Schema


Departure Element

String Schema
Departure Element
String Schema > AccommodationTransferShipInfoResponseDataType Complex Type : Departure Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationTransferShipInfoResponseType Complex Type
Diagram
ShipNumber Element Harbour Element Date Element Sequence ShipReference Element Choice Departure Element
Overview
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Source
<xs:element name="Departure" type="AccommodationTransferShipInfoResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoResponseDataType Complex Type | String Schema


AccommodationTransferShipInfoResponseType Complex Type

String Schema
AccommodationTransferShipInfoResponseType Complex Type
String Schema : AccommodationTransferShipInfoResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ShipNumber Element Harbour Element Date Element Sequence ShipReference Element Choice AccommodationTransferShipInfoResponseType Complex Type
Overview
AccommodationTransferShipInfoResponseType
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Used By
Arrival Element
Departure Element
Source
<xs:complexType name="AccommodationTransferShipInfoResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice>
    <xs:element name="ShipReference" minOccurs="0" />
    <xs:sequence>
      <xs:element name="Date" type="DateTimeType" minOccurs="0" />
      <xs:element name="Harbour" type="TextLanguageType" minOccurs="0" />
      <xs:element name="ShipNumber" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:choice>
</xs:complexType>
See Also
String Schema


ShipReference Element

String Schema
ShipReference Element
String Schema > AccommodationTransferShipInfoResponseType Complex Type : ShipReference Element
Namespace http://string.drv.de/xmlschema/string
Overview
ShipReference optional
Source
<xs:element name="ShipReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoResponseType Complex Type | String Schema


Date Element

String Schema
Date Element
String Schema > AccommodationTransferShipInfoResponseType Complex Type : Date Element
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
Date optional DateTimeType Simple Type
Source
<xs:element name="Date" type="DateTimeType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoResponseType Complex Type | String Schema


Harbour Element

String Schema
Harbour Element
String Schema > AccommodationTransferShipInfoResponseType Complex Type : Harbour Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Harbour Element
Overview
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Harbour" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoResponseType Complex Type | String Schema


ShipNumber Element

String Schema
ShipNumber Element
String Schema > AccommodationTransferShipInfoResponseType Complex Type : ShipNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ShipNumber optional xs:string
Source
<xs:element name="ShipNumber" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AccommodationTransferShipInfoResponseType Complex Type | String Schema


AdditionalESTAInformationType Complex Type

String Schema
AdditionalESTAInformationType Complex Type
String Schema : AdditionalESTAInformationType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Mail Element Phone Element CountryCode Element Name Element Sequence Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence AdditionalESTAInformationType Complex Type
Overview
AdditionalESTAInformationType
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Used By
ESTA_Information Element
ESTA_Information Element
ESTA_Information Element
Source
<xs:complexType name="AdditionalESTAInformationType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="CitizenOfForeignCountryNow" type="PassportCitizenOfForeignCountryNowType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="CitizenOfForeignCountryEverSince" type="PassportCitizenOfForeignCountryEverSinceType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="FatherInfo" type="PassportParentInfoType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="MotherInfo" type="PassportParentInfoType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="StayInfo" type="PassportStayInfoType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Mail" type="xs:string" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CitizenOfForeignCountryEverSince Element

String Schema
CitizenOfForeignCountryEverSince Element
String Schema > AdditionalESTAInformationType Complex Type : CitizenOfForeignCountryEverSince Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportCitizenOfForeignCountryEverSinceType Complex Type
Diagram
Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element
Overview
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source
<xs:element name="CitizenOfForeignCountryEverSince" type="PassportCitizenOfForeignCountryEverSinceType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalESTAInformationType Complex Type | String Schema


CitizenOfForeignCountryNow Element

String Schema
CitizenOfForeignCountryNow Element
String Schema > AdditionalESTAInformationType Complex Type : CitizenOfForeignCountryNow Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportCitizenOfForeignCountryNowType Complex Type
Diagram
SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element
Overview
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
Source
<xs:element name="CitizenOfForeignCountryNow" type="PassportCitizenOfForeignCountryNowType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalESTAInformationType Complex Type | String Schema


FatherInfo Element

String Schema
FatherInfo Element
String Schema > AdditionalESTAInformationType Complex Type : FatherInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportParentInfoType Complex Type
Diagram
Prename Element Surname Element Sequence FatherInfo Element
Overview
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
Source
<xs:element name="FatherInfo" type="PassportParentInfoType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalESTAInformationType Complex Type | String Schema


Mail Element

String Schema
Mail Element
String Schema > AdditionalESTAInformationType Complex Type : Mail Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Mail optional xs:string
Source
<xs:element name="Mail" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalESTAInformationType Complex Type | String Schema


MotherInfo Element

String Schema
MotherInfo Element
String Schema > AdditionalESTAInformationType Complex Type : MotherInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportParentInfoType Complex Type
Diagram
Prename Element Surname Element Sequence MotherInfo Element
Overview
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
Source
<xs:element name="MotherInfo" type="PassportParentInfoType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalESTAInformationType Complex Type | String Schema


StayInfo Element

String Schema
StayInfo Element
String Schema > AdditionalESTAInformationType Complex Type : StayInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportStayInfoType Complex Type
Diagram
Phone Element CountryCode Element Name Element Sequence Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element
Overview
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Source
<xs:element name="StayInfo" type="PassportStayInfoType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalESTAInformationType Complex Type | String Schema


AddressType Complex Type

String Schema
AddressType Complex Type
String Schema : AddressType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence AddressType Complex Type
Overview
AddressType
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Used By
Address Element
Address Element
Address Element
Address Element
Attributes
Name | Type | Use | Default | Fixed | Description
Language | xs:language | optional |  |  |
Source
<xs:complexType name="AddressType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Street" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="HouseNumber" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="ZIPCode" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="City" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="Country" type="CountryType" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Language" type="xs:language" />
</xs:complexType>
See Also
String Schema


City Element

String Schema
City Element
String Schema > AddressType Complex Type : City Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
City optional xs:string
Source
<xs:element name="City" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AddressType Complex Type | String Schema


Country Element

String Schema
Country Element
String Schema > AddressType Complex Type : Country Element
Namespace http://string.drv.de/xmlschema/string
Type
CountryType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element
Overview
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Country" type="CountryType" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AddressType Complex Type | String Schema


HouseNumber Element

String Schema
HouseNumber Element
String Schema > AddressType Complex Type : HouseNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
HouseNumber optional xs:string
Source
<xs:element name="HouseNumber" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AddressType Complex Type | String Schema


Street Element

String Schema
Street Element
String Schema > AddressType Complex Type : Street Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Street optional xs:string
Source
<xs:element name="Street" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AddressType Complex Type | String Schema


ZIPCode Element

String Schema
ZIPCode Element
String Schema > AddressType Complex Type : ZIPCode Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ZIPCode optional xs:string
Source
<xs:element name="ZIPCode" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AddressType Complex Type | String Schema


AgencyClearanceRequestType Complex Type

String Schema
AgencyClearanceRequestType Complex Type
String Schema : AgencyClearanceRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Sequence Country Element Agency Element Sequence Sequence POS Element Sequence AgencyClearanceRequestType Complex Type
Overview
AgencyClearanceRequestType
Sequence
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Used By
AgencyClearanceRequest Element
Source
<xs:complexType name="AgencyClearanceRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="POS" type="PosType" minOccurs="1" nillable="false" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


POS Element

String Schema
POS Element
String Schema > AgencyClearanceRequestType Complex Type : POS Element
Namespace http://string.drv.de/xmlschema/string
Type
PosType Complex Type
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Country Element Agency Element Sequence Sequence POS Element
Overview
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="POS" type="PosType" minOccurs="1" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AgencyClearanceRequestType Complex Type | String Schema


AgencyClearanceResponseType Complex Type

String Schema
AgencyClearanceResponseType Complex Type
String Schema : AgencyClearanceResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Approved Element CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Sequence Country Element Agency Element Sequence Sequence POS Element Sequence AgencyClearanceResponseType Complex Type
Overview
AgencyClearanceResponseType
Sequence
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Approved xs:boolean
Used By
AgencyClearanceResponse Element
Source
<xs:complexType name="AgencyClearanceResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="POS" type="PosType" minOccurs="1" nillable="false" />
    <xs:element name="Approved" type="xs:boolean" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Approved Element

String Schema
Approved Element
String Schema > AgencyClearanceResponseType Complex Type : Approved Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
Approved xs:boolean
Source
<xs:element name="Approved" type="xs:boolean" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AgencyClearanceResponseType Complex Type | String Schema


POS Element

String Schema
POS Element
String Schema > AgencyClearanceResponseType Complex Type : POS Element
Namespace http://string.drv.de/xmlschema/string
Type
PosType Complex Type
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Country Element Agency Element Sequence Sequence POS Element
Overview
POS PosType Complex Type
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="POS" type="PosType" minOccurs="1" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AgencyClearanceResponseType Complex Type | String Schema


AirlineRequestType Complex Type

String Schema
AirlineRequestType Complex Type
String Schema : AirlineRequestType Complex Type
Description
Airline
Namespace http://string.drv.de/xmlschema/string
Diagram
IcaoCode Element IataCode Element Choice AirlineRequestType Complex Type
Overview
AirlineRequestType
Airline
Choice
IataCode
IcaoCode
Used By
OperatingCarrier Element
MarketingCarrier Element
Source
<xs:complexType name="AirlineRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Airline</xs:documentation>
  </xs:annotation>
  <xs:choice>
    <xs:element name="IataCode" />
    <xs:element name="IcaoCode" />
  </xs:choice>
</xs:complexType>
See Also
String Schema


AirlineRequestTypes Complex Type

String Schema
AirlineRequestTypes Complex Type
String Schema : AirlineRequestTypes Complex Type
Description
Airline types
Namespace http://string.drv.de/xmlschema/string
Diagram
IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence AirlineRequestTypes Complex Type
Overview
AirlineRequestTypes
Airline types
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Used By
Carrier Element
Carrier Element
Carrier Element
Source
<xs:complexType name="AirlineRequestTypes" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Airline types</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="OperatingCarrier" type="AirlineRequestType" nillable="true" minOccurs="0" />
    <xs:element name="MarketingCarrier" type="AirlineRequestType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


MarketingCarrier Element

String Schema
MarketingCarrier Element
String Schema > AirlineRequestTypes Complex Type : MarketingCarrier Element
Namespace http://string.drv.de/xmlschema/string
Type
AirlineRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice MarketingCarrier Element
Overview
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="MarketingCarrier" type="AirlineRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineRequestTypes Complex Type | String Schema


OperatingCarrier Element

String Schema
OperatingCarrier Element
String Schema > AirlineRequestTypes Complex Type : OperatingCarrier Element
Namespace http://string.drv.de/xmlschema/string
Type
AirlineRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice OperatingCarrier Element
Overview
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="OperatingCarrier" type="AirlineRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineRequestTypes Complex Type | String Schema


AirlineResponseType Complex Type

String Schema
AirlineResponseType Complex Type
String Schema : AirlineResponseType Complex Type
Description
Airline
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of AirlineRequestType Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence AirlineResponseType Complex Type
Overview
AirlineResponseType Extension of AirlineRequestType Complex Type
Airline
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
OperatingCarrier Element
MarketingCarrier Element
Source
<xs:complexType name="AirlineResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Airline</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="AirlineRequestType">
      <xs:sequence>
        <xs:element name="AirlineName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AirlineResponseTypes Complex Type

String Schema
AirlineResponseTypes Complex Type
String Schema : AirlineResponseTypes Complex Type
Description
Airline types
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence MarketingCarrier Element LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence OperatingCarrier Element Sequence AirlineResponseTypes Complex Type
Overview
AirlineResponseTypes
Airline types
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Carrier Element
Carrier Element
Carrier Element
Source
<xs:complexType name="AirlineResponseTypes" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Airline types</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="OperatingCarrier" type="AirlineResponseType" nillable="true" minOccurs="0" />
    <xs:element name="MarketingCarrier" type="AirlineResponseType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


MarketingCarrier Element

String Schema
MarketingCarrier Element
String Schema > AirlineResponseTypes Complex Type : MarketingCarrier Element
Namespace http://string.drv.de/xmlschema/string
Type
AirlineResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence MarketingCarrier Element
Overview
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="MarketingCarrier" type="AirlineResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineResponseTypes Complex Type | String Schema


OperatingCarrier Element

String Schema
OperatingCarrier Element
String Schema > AirlineResponseTypes Complex Type : OperatingCarrier Element
Namespace http://string.drv.de/xmlschema/string
Type
AirlineResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence OperatingCarrier Element
Overview
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="OperatingCarrier" type="AirlineResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineResponseTypes Complex Type | String Schema


AirportRequestType Complex Type

String Schema
AirportRequestType Complex Type
String Schema : AirportRequestType Complex Type
Description
Airport
Namespace http://string.drv.de/xmlschema/string
Diagram
IcaoCode Element IataCode Element Choice AirportRequestType Complex Type
Overview
AirportRequestType
Airport
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Used By
DepartureAirport Element
ArrivalAirport Element
DepartureAirport Element
ArrivalAirport Element
ArrivalAirport Element
Source
<xs:complexType name="AirportRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Airport</xs:documentation>
  </xs:annotation>
  <xs:choice>
    <xs:element name="IataCode" type="IataAirportCode" />
    <xs:element name="IcaoCode" type="IcaoAirportCode" />
  </xs:choice>
</xs:complexType>
See Also
String Schema


IataCode Element

String Schema
IataCode Element
String Schema > AirportRequestType Complex Type : IataCode Element
Namespace http://string.drv.de/xmlschema/string
Type
IataAirportCode Simple Type
Overview
IataCode IataAirportCode Simple Type
Source
<xs:element name="IataCode" type="IataAirportCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirportRequestType Complex Type | String Schema


IcaoCode Element

String Schema
IcaoCode Element
String Schema > AirportRequestType Complex Type : IcaoCode Element
Namespace http://string.drv.de/xmlschema/string
Type
IcaoAirportCode Simple Type
Overview
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="IcaoCode" type="IcaoAirportCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirportRequestType Complex Type | String Schema


AirportResponseType Complex Type

String Schema
AirportResponseType Complex Type
String Schema : AirportResponseType Complex Type
Description
Airport
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of AirportRequestType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence AirportResponseType Complex Type
Overview
AirportResponseType Extension of AirportRequestType Complex Type
Airport
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Used By
DepartureAirport Element
ArrivalAirport Element
DepartureAirport Element
ArrivalAirport Element
ArrivalAirport Element
Source
<xs:complexType name="AirportResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Airport</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="AirportRequestType">
      <xs:sequence>
        <xs:element name="AirportName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
        <xs:element name="Location" type="GeoLocationType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AirportName Element

String Schema
AirportName Element
String Schema > AirportResponseType Complex Type : AirportName Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence AirportName Element
Overview
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="AirportName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirportResponseType Complex Type | String Schema


Location Element

String Schema
Location Element
String Schema > AirportResponseType Complex Type : Location Element
Namespace http://string.drv.de/xmlschema/string
Type
GeoLocationType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element
Overview
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="Location" type="GeoLocationType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirportResponseType Complex Type | String Schema


IataCode Element

String Schema
IataCode Element
String Schema > AirportResponseType Complex Type : IataCode Element
Namespace http://string.drv.de/xmlschema/string
Type
IataAirportCode Simple Type
Overview
IataCode IataAirportCode Simple Type
Source
<xs:element name="IataCode" type="IataAirportCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirportResponseType Complex Type | String Schema


IcaoCode Element

String Schema
IcaoCode Element
String Schema > AirportResponseType Complex Type : IcaoCode Element
Namespace http://string.drv.de/xmlschema/string
Type
IcaoAirportCode Simple Type
Overview
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="IcaoCode" type="IcaoAirportCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirportResponseType Complex Type | String Schema


AttributesType Complex Type

String Schema
AttributesType Complex Type
String Schema : AttributesType Complex Type
Description
List of attributes
Namespace http://string.drv.de/xmlschema/string
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence AttributesType Complex Type
Overview
AttributesType
List of attributes
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Used By
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Attributes Element
Source
<xs:complexType name="AttributesType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Attribute" type="AttributeType" nillable="false" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Attribute Element

String Schema
Attribute Element
String Schema > AttributesType Complex Type : Attribute Element
Namespace http://string.drv.de/xmlschema/string
Type
AttributeType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element
Overview
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attribute" type="AttributeType" nillable="false" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AttributesType Complex Type | String Schema


AttributeType Complex Type

String Schema
AttributeType Complex Type
String Schema : AttributeType Complex Type
Description
Certain attribute of the containing element
Namespace http://string.drv.de/xmlschema/string
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence AttributeType Complex Type
Overview
AttributeType
Certain attribute of the containing element
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Used By
Attribute Element
Source
<xs:complexType name="AttributeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Certain attribute of the containing element</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token">
      <xs:annotation>
        <xs:documentation>Code for the attribute</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Description for the attribute</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AttributeSource" type="AttributeSourceType" nillable="false">
      <xs:annotation>
        <xs:documentation>Source of the attribute</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AttributeSource Element

String Schema
AttributeSource Element
String Schema > AttributeType Complex Type : AttributeSource Element
Description
Source of the attribute
Namespace http://string.drv.de/xmlschema/string
Type
AttributeSourceType Simple Type
Overview
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="AttributeSource" type="AttributeSourceType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Source of the attribute</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AttributeType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > AttributeType Complex Type : Code Element
Description
Code for the attribute
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Code for the attribute
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Code for the attribute</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AttributeType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > AttributeType Complex Type : Description Element
Description
Description for the attribute
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Description for the attribute</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
AttributeType Complex Type | String Schema


BaggageInfoType Complex Type

String Schema
BaggageInfoType Complex Type
String Schema : BaggageInfoType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfoType Complex Type
Overview
BaggageInfoType
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Used By
BaggageInfo Element
BaggageInfo Element
BaggageInfo Element
Source
<xs:complexType name="BaggageInfoType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Pieces" type="xs:int" nillable="true" minOccurs="0" />
    <xs:element name="Weight" type="PackageWeightType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Pieces Element

String Schema
Pieces Element
String Schema > BaggageInfoType Complex Type : Pieces Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Pieces optional xs:int
Source
<xs:element name="Pieces" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BaggageInfoType Complex Type | String Schema


Weight Element

String Schema
Weight Element
String Schema > BaggageInfoType Complex Type : Weight Element
Namespace http://string.drv.de/xmlschema/string
Type
PackageWeightType Complex Type
Diagram
Measure Element Weight Element Sequence Weight Element
Overview
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Source
<xs:element name="Weight" type="PackageWeightType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BaggageInfoType Complex Type | String Schema


BoardCodeRequestType Complex Type

String Schema
BoardCodeRequestType Complex Type
String Schema : BoardCodeRequestType Complex Type
Description
Touroperator specific board code
Namespace http://string.drv.de/xmlschema/string
Diagram
AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Code Element Sequence BoardCodeRequestType Complex Type
Overview
BoardCodeRequestType
Touroperator specific board code
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Used By
Board Element
Source
<xs:complexType name="BoardCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator specific board code</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" />
    <xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>List of attributes of this board</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Attributes Element

String Schema
Attributes Element
String Schema > BoardCodeRequestType Complex Type : Attributes Element
Description
List of attributes of this board
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this board</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BoardCodeRequestType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > BoardCodeRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BoardCodeRequestType Complex Type | String Schema


BoardCodeResponseType Complex Type

String Schema
BoardCodeResponseType Complex Type
String Schema : BoardCodeResponseType Complex Type
Description
Touroperator specific board code
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of BoardCodeRequestType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Code Element Sequence BoardCodeResponseType Complex Type
Overview
BoardCodeResponseType Extension of BoardCodeRequestType Complex Type
Touroperator specific board code
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Board Element
Source
<xs:complexType name="BoardCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator specific board code</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="BoardCodeRequestType">
      <xs:sequence>
        <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Attributes Element

String Schema
Attributes Element
String Schema > BoardCodeResponseType Complex Type : Attributes Element
Description
List of attributes of this board
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this board</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BoardCodeResponseType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > BoardCodeResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BoardCodeResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > BoardCodeResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BoardCodeResponseType Complex Type | String Schema


BookableClassCommonType Complex Type

String Schema
BookableClassCommonType Complex Type
String Schema : BookableClassCommonType Complex Type
Description
Class information
Namespace http://string.drv.de/xmlschema/string
Diagram
AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence BookableClassCommonType Complex Type
Overview
BookableClassCommonType
Class information
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:complexType name="BookableClassCommonType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Class information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType">
      <xs:annotation>
        <xs:documentation>Unique class identifier</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" />
    <xs:element name="State" type="BookabilityStateType" nillable="false">
      <xs:annotation>
        <xs:documentation>Flight class bookability state</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" />
    <xs:element name="Attributes" type="AttributesType" minOccurs="0" maxOccurs="unbounded" nillable="true">
      <xs:annotation>
        <xs:documentation>List of attributes of this class</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > BookableClassCommonType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassCommonType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > BookableClassCommonType Complex Type : Attributes Element
Description
List of attributes of this class
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" minOccurs="0" maxOccurs="unbounded" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this class</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassCommonType Complex Type | String Schema


CabinClass Element

String Schema
CabinClass Element
String Schema > BookableClassCommonType Complex Type : CabinClass Element
Namespace http://string.drv.de/xmlschema/string
Type
CabinClassType Simple Type
Overview
CabinClass optional CabinClassType Simple Type
Source
<xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassCommonType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > BookableClassCommonType Complex Type : Identifier Element
Description
Unique class identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique class identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique class identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassCommonType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > BookableClassCommonType Complex Type : State Element
Description
Flight class bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Flight class bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight class bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassCommonType Complex Type | String Schema


BookableClassRequestType Complex Type

String Schema
BookableClassRequestType Complex Type
String Schema : BookableClassRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of BookableClassCommonType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element Code Element Sequence ClassCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence BookableClassRequestType Complex Type
Overview
BookableClassRequestType Extension of BookableClassCommonType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
FlightClass Element
Source
<xs:complexType name="BookableClassRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="BookableClassCommonType">
      <xs:annotation>
        <xs:documentation>Class information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="ClassCode" type="ClassRequestType" minOccurs="0" />
        <xs:element name="IncludedExtras" type="IncludedExtrasRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Included extras for this class</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>List of customer requests</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > BookableClassRequestType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > BookableClassRequestType Complex Type : Attributes Element
Description
List of attributes of this class
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" minOccurs="0" maxOccurs="unbounded" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this class</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassRequestType Complex Type | String Schema


CabinClass Element

String Schema
CabinClass Element
String Schema > BookableClassRequestType Complex Type : CabinClass Element
Namespace http://string.drv.de/xmlschema/string
Type
CabinClassType Simple Type
Overview
CabinClass optional CabinClassType Simple Type
Source
<xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassRequestType Complex Type | String Schema


ClassCode Element

String Schema
ClassCode Element
String Schema > BookableClassRequestType Complex Type : ClassCode Element
Namespace http://string.drv.de/xmlschema/string
Type
ClassRequestType Complex Type
Diagram
Code Element Sequence ClassCode Element
Overview
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="ClassCode" type="ClassRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > BookableClassRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > BookableClassRequestType Complex Type : Identifier Element
Description
Unique class identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique class identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique class identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassRequestType Complex Type | String Schema


IncludedExtras Element

String Schema
IncludedExtras Element
String Schema > BookableClassRequestType Complex Type : IncludedExtras Element
Description
Included extras for this class
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtrasRequestType Complex Type
Diagram
Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element
Overview
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="IncludedExtras" type="IncludedExtrasRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Included extras for this class</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassRequestType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > BookableClassRequestType Complex Type : State Element
Description
Flight class bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Flight class bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight class bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassRequestType Complex Type | String Schema


BookableClassResponseType Complex Type

String Schema
BookableClassResponseType Complex Type
String Schema : BookableClassResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of BookableClassCommonType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence BookableClassResponseType Complex Type
Overview
BookableClassResponseType Extension of BookableClassCommonType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Used By
FlightClass Element
Source
<xs:complexType name="BookableClassResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="BookableClassCommonType">
      <xs:annotation>
        <xs:documentation>Class information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="ClassCode" type="ClassResponseType" minOccurs="0" />
        <xs:element name="IncludedExtras" type="IncludedExtrasResponseType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Included extras for this class</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>List of customer requests</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > BookableClassResponseType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > BookableClassResponseType Complex Type : Attributes Element
Description
List of attributes of this class
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" minOccurs="0" maxOccurs="unbounded" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this class</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassResponseType Complex Type | String Schema


CabinClass Element

String Schema
CabinClass Element
String Schema > BookableClassResponseType Complex Type : CabinClass Element
Namespace http://string.drv.de/xmlschema/string
Type
CabinClassType Simple Type
Overview
CabinClass optional CabinClassType Simple Type
Source
<xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassResponseType Complex Type | String Schema


ClassCode Element

String Schema
ClassCode Element
String Schema > BookableClassResponseType Complex Type : ClassCode Element
Namespace http://string.drv.de/xmlschema/string
Type
ClassResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassCode Element
Overview
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="ClassCode" type="ClassResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookableClassResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > BookableClassResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > BookableClassResponseType Complex Type : Identifier Element
Description
Unique class identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique class identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique class identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassResponseType Complex Type | String Schema


IncludedExtras Element

String Schema
IncludedExtras Element
String Schema > BookableClassResponseType Complex Type : IncludedExtras Element
Description
Included extras for this class
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtrasResponseType Complex Type
Diagram
Description Element Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element
Overview
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="IncludedExtras" type="IncludedExtrasResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Included extras for this class</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > BookableClassResponseType Complex Type : State Element
Description
Flight class bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Flight class bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight class bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookableClassResponseType Complex Type | String Schema


BookingChannelType Complex Type

String Schema
BookingChannelType Complex Type
String Schema : BookingChannelType Complex Type
Description
Booking Channel
Namespace http://string.drv.de/xmlschema/string
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element Sequence BookingChannelType Complex Type
Overview
BookingChannelType
Booking Channel
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Used By
BookingChannel Element
Source
<xs:complexType name="BookingChannelType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Booking Channel</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Type" />
    <xs:element name="CompanyName" type="CompanyNameType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CompanyName Element

String Schema
CompanyName Element
String Schema > BookingChannelType Complex Type : CompanyName Element
Namespace http://string.drv.de/xmlschema/string
Type
CompanyNameType Complex Type
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element
Overview
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="CompanyName" type="CompanyNameType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingChannelType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > BookingChannelType Complex Type : Type Element
Namespace http://string.drv.de/xmlschema/string
Overview
Type
Source
<xs:element name="Type" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingChannelType Complex Type | String Schema


BookingRequestEnvelopeType Complex Type

String Schema
BookingRequestEnvelopeType Complex Type
String Schema : BookingRequestEnvelopeType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence ConfirmedWarnings Element EmergencyAddress Element BookingOwnerAddress Element DeliveryAddress Element InvoiceAddress Element SessionId Element Sequence BookingDetails Element Traveller Element Sequence Travellers Element Package Element Sequence Packages Element Service Element Sequence Services Element RequestTrigger Element Sequence Booking Element AgentId Element Agency Element Sequence AgencyInformation Element Sequence BookingRequestEnvelopeType Complex Type
Overview
BookingRequestEnvelopeType
Sequence
AgencyInformation CommonAgencyType Complex Type
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Booking BookingRequestType Complex Type
Sequence
RequestTrigger RequestTriggerType Simple Type
Trigger type which initiated the request
Services ServicesRequestType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Packages PackagesRequestType Complex Type
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Travellers TravellersRequestType Complex Type
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
ConfirmedWarnings optional IdentifiersType Complex Type
List of confirmed warning idemntifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:complexType name="BookingRequestEnvelopeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" />
    <xs:element name="Booking" type="BookingRequestType" nillable="false" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AgencyInformation Element

String Schema
AgencyInformation Element
String Schema > BookingRequestEnvelopeType Complex Type : AgencyInformation Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonAgencyType Complex Type
Diagram
AgentId Element Agency Element Sequence AgencyInformation Element
Overview
AgencyInformation CommonAgencyType Complex Type
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Source
<xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingRequestEnvelopeType Complex Type | String Schema


Booking Element

String Schema
Booking Element
String Schema > BookingRequestEnvelopeType Complex Type : Booking Element
Namespace http://string.drv.de/xmlschema/string
Type
BookingRequestType Complex Type
Diagram
Identifier Element Sequence ConfirmedWarnings Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element SessionId Element Sequence BookingDetails Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence Travellers Element Details Element Sequence Package Element Sequence Packages Element Service Element Sequence Services Element RequestTrigger Element Sequence Booking Element
Overview
Booking BookingRequestType Complex Type
Sequence
RequestTrigger RequestTriggerType Simple Type
Trigger type which initiated the request
Services ServicesRequestType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
RoomCode optional RoomCodeRequestType Complex Type
Board optional BoardCodeRequestType Complex Type
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Data optional CommonFlightDataType Complex Type
Segments optional FlightSegmentsRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
DepartureAirport optional AirportRequestType Complex Type
ArrivalAirport optional AirportRequestType Complex Type
Carrier optional AirlineRequestTypes Complex Type
Classes optional FlightClassesRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Packages PackagesRequestType Complex Type
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Travellers TravellersRequestType Complex Type
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
ConfirmedWarnings optional IdentifiersType Complex Type
List of confirmed warning idemntifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Booking" type="BookingRequestType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingRequestEnvelopeType Complex Type | String Schema


BookingRequestType Complex Type

String Schema
BookingRequestType Complex Type
String Schema : BookingRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence ConfirmedWarnings Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element SessionId Element Sequence BookingDetails Element ClientNumber Element Address Element ESTA_Information Element Passport Element ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence Travellers Element Details Element Sequence Package Element Sequence Packages Element Service Element Sequence Services Element RequestTrigger Element Sequence BookingRequestType Complex Type
Overview
BookingRequestType
Sequence
RequestTrigger RequestTriggerType Simple Type
Trigger type which initiated the request
Services ServicesRequestType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
RoomCode optional RoomCodeRequestType Complex Type
Board optional BoardCodeRequestType Complex Type
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Data optional CommonFlightDataType Complex Type
Segments optional FlightSegmentsRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
DepartureAirport optional AirportRequestType Complex Type
ArrivalAirport optional AirportRequestType Complex Type
Carrier optional AirlineRequestTypes Complex Type
Classes optional FlightClassesRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Packages PackagesRequestType Complex Type
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Travellers TravellersRequestType Complex Type
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
ConfirmedWarnings optional IdentifiersType Complex Type
List of confirmed warning idemntifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Booking Element
BookingRequest Element
Source
<xs:complexType name="BookingRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="RequestTrigger" type="RequestTriggerType" nillable="false">
      <xs:annotation>
        <xs:documentation>Trigger type which initiated the request</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Services" type="ServicesRequestType" nillable="false" />
    <xs:element name="Packages" type="PackagesRequestType" nillable="true" />
    <xs:element name="Travellers" type="TravellersRequestType" nillable="false" />
    <xs:element name="BookingDetails" type="CommonBookingType" nillable="true" />
    <xs:element name="ConfirmedWarnings" type="IdentifiersType" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of confirmed warning idemntifiers</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


BookingDetails Element

String Schema
BookingDetails Element
String Schema > BookingRequestType Complex Type : BookingDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonBookingType Complex Type
Diagram
ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element SessionId Element Sequence BookingDetails Element
Overview
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="BookingDetails" type="CommonBookingType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingRequestType Complex Type | String Schema


ConfirmedWarnings Element

String Schema
ConfirmedWarnings Element
String Schema > BookingRequestType Complex Type : ConfirmedWarnings Element
Description
List of confirmed warning idemntifiers
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence ConfirmedWarnings Element
Overview
ConfirmedWarnings optional IdentifiersType Complex Type
List of confirmed warning idemntifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="ConfirmedWarnings" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of confirmed warning idemntifiers</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingRequestType Complex Type | String Schema


Packages Element

String Schema
Packages Element
String Schema > BookingRequestType Complex Type : Packages Element
Namespace http://string.drv.de/xmlschema/string
Type
PackagesRequestType Complex Type
Diagram
CustomerRequests Element RequestedPrices Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence Package Element Sequence Packages Element
Overview
Packages PackagesRequestType Complex Type
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Packages" type="PackagesRequestType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingRequestType Complex Type | String Schema


RequestTrigger Element

String Schema
RequestTrigger Element
String Schema > BookingRequestType Complex Type : RequestTrigger Element
Description
Trigger type which initiated the request
Namespace http://string.drv.de/xmlschema/string
Type
RequestTriggerType Simple Type
Overview
RequestTrigger RequestTriggerType Simple Type
Trigger type which initiated the request
Source
<xs:element name="RequestTrigger" type="RequestTriggerType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Trigger type which initiated the request</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingRequestType Complex Type | String Schema


Services Element

String Schema
Services Element
String Schema > BookingRequestType Complex Type : Services Element
Namespace http://string.drv.de/xmlschema/string
Type
ServicesRequestType Complex Type
Diagram
Service Element Sequence Services Element
Overview
Services ServicesRequestType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
MarketingCarrier optional AirlineRequestType Complex Type
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Services" type="ServicesRequestType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingRequestType Complex Type | String Schema


Travellers Element

String Schema
Travellers Element
String Schema > BookingRequestType Complex Type : Travellers Element
Namespace http://string.drv.de/xmlschema/string
Type
TravellersRequestType Complex Type
Diagram
ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence Travellers Element
Overview
Travellers TravellersRequestType Complex Type
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="Travellers" type="TravellersRequestType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingRequestType Complex Type | String Schema


BookingResponseEnvelopeType Complex Type

String Schema

BookingResponseEnvelopeType Complex Type

Collapse All Expand All

String Schema : BookingResponseEnvelopeType Complex Type

Namespace

http://string.drv.de/xmlschema/string

Diagram

Overview

BookingResponseEnvelopeType

Sequence

AgencyInformation CommonAgencyType Complex Type

Sequence

Agency xs:string
Identification of the executing agency

AgentId xs:int
Identification of the executing agent

Booking BookingResponseType Complex Type

Sequence

BookingState BookabilityStateType Simple Type
Bookability state for the whole booking

ProcessState ProcessStateType Simple Type
Indicator of next possible process states of the result

TransactionState TransactionStateType Simple Type
Indicator for a technical error while processing a request, not to be used by touroperator

Services ServicesResponseType Complex Type

Sequence

Service 0..∞

Sequence

Choice

Accommodation AccommodationResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Catalogue optional CatalogueResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

CancellationPolicies optional CancellationPoliciesType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

LocationDetails AccommodationProductResponseType Complex Type

Sequence

GeoLocation optional GeoLocationType Complex Type

Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages

Regions optional RegionsType Complex Type

InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type

Sequence

Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type

Rail optional AccommodationTransferRailInfoResponseDataType Complex Type

Ship optional AccommodationTransferShipInfoResponseDataType Complex Type

Bus optional AccommodationTransferBusInfoResponseDataType Complex Type

Rooms optional AccommodationRoomsResponseType Complex Type

Sequence

Room 0..∞ RoomResponseType Complex Type

Stay AccommodationStayResponseType Complex Type

Sequence

ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator

CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider

Flight FlightResponseType Complex Type

Sequence

Legs optional FlightLegsResponseType Complex Type

Sequence

Leg 0..∞ FlightLegResponseType Complex Type

CommonService CommonServiceResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Catalogue optional CatalogueResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

CancellationPolicies optional CancellationPoliciesType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

References optional ServiceResponseReferencesType Complex Type

Sequence

ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system

Sequence

ReferenceNumber xs:int

Code xs:token

Description 0..∞ TextLanguageType Complex Type

ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"

Sequence

Provider optional xs:string

Id optional xs:string

URL optional xs:string

Packages PackagesResponseType Complex Type

Sequence

Package 0..∞ PackageResponseType Complex Type

Sequence

Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Catalogue optional CatalogueResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

CancellationPolicies optional CancellationPoliciesType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Travellers TravellersResponseType Complex Type

Sequence

Traveller 0..∞ CommonTravellerResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

BookingDetails CommonBookingType Complex Type

Sequence

SessionId optional xs:string
Identification of the current session context

InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

Prices optional PricesResponseType Complex Type
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

DetailPrices 0..∞ CommonPriceResponseType Complex Type

Sequence

PriceName 0..∞ TextLanguageType Complex Type
Price description

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Quantity xs:int
Quantity of price

Price CurrencyAmountType Complex Type
Price amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATAmount optional CurrencyAmountType Complex Type
VAT amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATPercentage optional xs:decimal
VAT percentage

VATIncluded optional xs:boolean
Flag if VAT is included or additional

AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking

TotalPrices 0..∞ TotalPriceType Complex Type

Sequence

Choice

ServicePrice CommonTotalServicePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component

ServiceTypePrice CommonTotalServiceTypePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)

TravellerPrice CommonTotalTravellerPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedTraveller IdentifierType Simple Type
Reference to a traveller

BookingPrice CommonTotalBookingPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

Informations InformationsType Complex Type
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

InformationDetail 1..∞ InformationType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

Warnings WarningsType Complex Type
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

WarningDetail 1..∞ WarningType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user

Errors ErrorsType Complex Type
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

ErrorDetail 1..∞ ErrorType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

ErrorCategory ErrorCategoryType Simple Type
Specific error category

Source
<xs:complexType name="BookingResponseEnvelopeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" />
    <xs:element name="Booking" type="BookingResponseType" nillable="false" />
  </xs:sequence>
</xs:complexType>
See Also

String Schema


AgencyInformation Element

String Schema
AgencyInformation Element
String Schema > BookingResponseEnvelopeType Complex Type : AgencyInformation Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonAgencyType Complex Type
Diagram
AgentId Element Agency Element Sequence AgencyInformation Element
Overview
AgencyInformation CommonAgencyType Complex Type
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Source
<xs:element name="AgencyInformation" type="CommonAgencyType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingResponseEnvelopeType Complex Type | String Schema


Booking Element

String Schema

Booking Element

Collapse All Expand All

String Schema > BookingResponseEnvelopeType Complex Type : Booking Element

Namespace

http://string.drv.de/xmlschema/string

Type

BookingResponseType Complex Type

Diagram

Overview

Booking BookingResponseType Complex Type

Sequence

BookingState BookabilityStateType Simple Type
Bookability state for the whole booking

ProcessState ProcessStateType Simple Type
Indicator of next possible process states of the result

TransactionState TransactionStateType Simple Type
Indicator for a technical error while processing a request, not to be used by touroperator

Services ServicesResponseType Complex Type

Sequence

Service 0..∞

Sequence

Choice

Accommodation AccommodationResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

LocationDetails AccommodationProductResponseType Complex Type

Sequence

GeoLocation optional GeoLocationType Complex Type

Sequence

Longitude xs:string

Latitude xs:string

Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Regions optional RegionsType Complex Type

Sequence

Region 1..∞

InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type

Sequence

Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferFlightInfoResponseType Complex Type

Departure optional AccommodationTransferFlightInfoResponseType Complex Type

Rail optional AccommodationTransferRailInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferRailInfoResponseType Complex Type

Departure optional AccommodationTransferRailInfoResponseType Complex Type

Ship optional AccommodationTransferShipInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferShipInfoResponseType Complex Type

Departure optional AccommodationTransferShipInfoResponseType Complex Type

Bus optional AccommodationTransferBusInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferBusInfoResponseType Complex Type

Departure optional AccommodationTransferBusInfoResponseType Complex Type

Rooms optional AccommodationRoomsResponseType Complex Type

Sequence

Room 0..∞ RoomResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique room identifier

State BookabilityStateType Simple Type
Room bookability state

AssignedTravellers optional IdentifiersType Complex Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this room

RoomCode optional RoomCodeResponseType Complex Type

Board optional BoardCodeResponseType Complex Type

IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Stay AccommodationStayResponseType Complex Type

Sequence

ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator

CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider

CheckIn optional DateTimeType Simple Type

CheckOut optional DateTimeType Simple Type

Flight FlightResponseType Complex Type

Sequence

Legs optional FlightLegsResponseType Complex Type

Sequence

Leg 0..∞ FlightLegResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Data optional CommonFlightDataType Complex Type

Segments optional FlightSegmentsResponseType Complex Type

TariffDetails optional FlightTariffsResponseType Complex Type

DepartureAirport optional AirportResponseType Complex Type

ArrivalAirport optional AirportResponseType Complex Type

Carrier optional AirlineResponseTypes Complex Type

Classes optional FlightClassesResponseType Complex Type

FlightDescription 0..∞ TextLanguageType Complex Type

CommonService CommonServiceResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

References optional ServiceResponseReferencesType Complex Type

Sequence

ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system

Sequence

ReferenceNumber xs:int

Code xs:token

Description 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"

Sequence

Provider optional xs:string

Id optional xs:string

URL optional xs:string

Packages PackagesResponseType Complex Type

Sequence

Package 0..∞ PackageResponseType Complex Type

Sequence

Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

Travellers TravellersResponseType Complex Type

Sequence

Traveller 0..∞ CommonTravellerResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

BookingDetails CommonBookingType Complex Type

Sequence

SessionId optional xs:string
Identification of the current session context

InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

Prices optional PricesResponseType Complex Type
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

DetailPrices 0..∞ CommonPriceResponseType Complex Type

Sequence

PriceName 0..∞ TextLanguageType Complex Type
Price description

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Quantity xs:int
Quantity of price

Price CurrencyAmountType Complex Type
Price amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATAmount optional CurrencyAmountType Complex Type
VAT amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATPercentage optional xs:decimal
VAT percentage

VATIncluded optional xs:boolean
Flag if VAT is included or additional

AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking

TotalPrices 0..∞ TotalPriceType Complex Type

Sequence

Choice

ServicePrice CommonTotalServicePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component

ServiceTypePrice CommonTotalServiceTypePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)

TravellerPrice CommonTotalTravellerPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedTraveller IdentifierType Simple Type
Reference to a traveller

BookingPrice CommonTotalBookingPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

Informations InformationsType Complex Type
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

InformationDetail 1..∞ InformationType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

Warnings WarningsType Complex Type
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

WarningDetail 1..∞ WarningType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user

Errors ErrorsType Complex Type
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

ErrorDetail 1..∞ ErrorType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

ErrorCategory ErrorCategoryType Simple Type
Specific error category

Source
<xs:element name="Booking" type="BookingResponseType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

BookingResponseEnvelopeType Complex Type | String Schema


BookingResponseType Complex Type

String Schema

BookingResponseType Complex Type

Collapse All Expand All

String Schema : BookingResponseType Complex Type

Namespace

http://string.drv.de/xmlschema/string

Diagram

Overview

BookingResponseType

Sequence

BookingState BookabilityStateType Simple Type
Bookability state for the whole booking

ProcessState ProcessStateType Simple Type
Indicator of next possible process states of the result

TransactionState TransactionStateType Simple Type
Indicator for a technical error while processing a request, not to be used by touroperator

Services ServicesResponseType Complex Type

Sequence

Service 0..∞

Sequence

Choice

Accommodation AccommodationResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

LocationDetails AccommodationProductResponseType Complex Type

Sequence

GeoLocation optional GeoLocationType Complex Type

Sequence

Longitude xs:string

Latitude xs:string

Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Regions optional RegionsType Complex Type

Sequence

Region 1..∞

InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type

Sequence

Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferFlightInfoResponseType Complex Type

Departure optional AccommodationTransferFlightInfoResponseType Complex Type

Rail optional AccommodationTransferRailInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferRailInfoResponseType Complex Type

Departure optional AccommodationTransferRailInfoResponseType Complex Type

Ship optional AccommodationTransferShipInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferShipInfoResponseType Complex Type

Departure optional AccommodationTransferShipInfoResponseType Complex Type

Bus optional AccommodationTransferBusInfoResponseDataType Complex Type

Sequence

Arrival optional AccommodationTransferBusInfoResponseType Complex Type

Departure optional AccommodationTransferBusInfoResponseType Complex Type

Rooms optional AccommodationRoomsResponseType Complex Type

Sequence

Room 0..∞ RoomResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique room identifier

State BookabilityStateType Simple Type
Room bookability state

AssignedTravellers optional IdentifiersType Complex Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this room

RoomCode optional RoomCodeResponseType Complex Type

Board optional BoardCodeResponseType Complex Type

IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Stay AccommodationStayResponseType Complex Type

Sequence

ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator

CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider

CheckIn optional DateTimeType Simple Type

CheckOut optional DateTimeType Simple Type

Flight FlightResponseType Complex Type

Sequence

Legs optional FlightLegsResponseType Complex Type

Sequence

Leg 0..∞ FlightLegResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Data optional CommonFlightDataType Complex Type

Segments optional FlightSegmentsResponseType Complex Type

TariffDetails optional FlightTariffsResponseType Complex Type

DepartureAirport optional AirportResponseType Complex Type

ArrivalAirport optional AirportResponseType Complex Type

Carrier optional AirlineResponseTypes Complex Type

Classes optional FlightClassesResponseType Complex Type

FlightDescription 0..∞ TextLanguageType Complex Type

CommonService CommonServiceResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

References optional ServiceResponseReferencesType Complex Type

Sequence

ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system

Sequence

ReferenceNumber xs:int

Code xs:token

Description 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"

Sequence

Provider optional xs:string

Id optional xs:string

URL optional xs:string

Packages PackagesResponseType Complex Type

Sequence

Package 0..∞ PackageResponseType Complex Type

Sequence

Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section

Sequence

Identifier IdentifierType Simple Type
Unique service identifier

Type optional xs:token
For optionally specifying the service type / kind of service

StartDate DateType Simple Type
Start date of the service

EndDate DateType Simple Type
End Date of the service

Quantity optional xs:int
Quantity of the service

AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service

Sequence

Identifier 1..∞ IdentifierType Simple Type

Attributes 0..∞ AttributesType Complex Type
List of attributes of this service

Sequence

Attribute 1..∞ AttributeType Complex Type

Sequence

Code xs:token
Code for the attribute

Description 0..∞ TextLanguageType Complex Type
Description for the attribute

AttributeSource AttributeSourceType Simple Type
Source of the attribute

PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package

Product ProductCodeResponseType Complex Type

Sequence

Code xs:token

Type optional xs:token

Description optional TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Catalogue optional CatalogueResponseType Complex Type

Sequence

Code xs:token

Season optional xs:token

Page optional xs:integer

Description optional TextLanguageType Complex Type

State BookabilityStateType Simple Type
Service bookability state

CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests

Sequence

Code optional xs:token
Touroperator code for the customer request

Description 0..∞ TextLanguageType Complex Type
Description for the customer request

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants

Sequence

Identifier 1..∞ IdentifierType Simple Type

State ConfirmationStateType Simple Type
Confirmation state of the customer request

AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)

Sequence

GeneralInformation 0..∞ TextLanguageType Complex Type

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

CancellationPolicies optional CancellationPoliciesType Complex Type

Free optional xs:boolean
True if cancelable for free

FreeTo optional xs:dateTime
End of "Free Cancellation" period

Full optional xs:boolean
True if noncancelable

FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty

Sequence

Fees 0..∞ FeeType Complex Type

ModificationPolicies optional ModficationPoliciesType Complex Type

Free optional xs:boolean
True if modifiable for free

Upgradable optional xs:boolean
True if upgradable for free

Unchangeable optional xs:boolean
True if not changeable at all

Sequence

Permitted optional

Fees 0..∞ FeeType Complex Type

Travellers TravellersResponseType Complex Type

Sequence

Traveller 0..∞ CommonTravellerResponseType Complex Type

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

BookingDetails CommonBookingType Complex Type

Sequence

SessionId optional xs:string
Identification of the current session context

InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency

Sequence

Identifier IdentifierType Simple Type

Surname optional xs:string

Prename optional xs:string

Salutation optional SalutationType Simple Type

Gender optional GenderType Simple Type

AgeCategory optional AgeCategoryType Simple Type

BirthDate optional DateType Simple Type

ContactDetails optional ContactDetailsType Complex Type

Sequence

Mail optional xs:string

Phone optional xs:string

Mobile optional xs:string

Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency

Passport 0..∞ PassportType Complex Type

Sequence

PassportNumber xs:string

Surname xs:string

BirthName xs:string

Prename xs:string

BirthDate DateType Simple Type

Nationality optional xs:string

Gender optional GenderType Simple Type

IssueDate DateType Simple Type

ExpirationDate DateType Simple Type

CityOfBirth optional xs:string

CountryOfBirth optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Authority optional xs:string

ESTA_Information optional AdditionalESTAInformationType Complex Type

Sequence

CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

Source optional NationalitySourceType Simple Type

SourceOtherInfo optional xs:string

CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type

Sequence

IsCitizenOfForeignCountry optional xs:boolean

Nationality optional xs:string

FatherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

MotherInfo optional PassportParentInfoType Complex Type

Sequence

Surname optional xs:string

Prename optional xs:string

StayInfo optional PassportStayInfoType Complex Type

Sequence

Address1 optional xs:string

Address2 optional xs:string

Appartement optional xs:string

City optional xs:string

StateOrRegion optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

Phone optional xs:string

Mail optional xs:string

Address optional AddressType Complex Type

Language optional xs:language

Sequence

Street optional xs:string

HouseNumber optional xs:string

ZIPCode optional xs:string

City optional xs:string

Country optional CountryType Complex Type

Sequence

Name xs:string
Name of the country

CountryCode CountryCodeType Simple Type
ISO code

ClientNumber optional xs:string

Prices optional PricesResponseType Complex Type
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

DetailPrices 0..∞ CommonPriceResponseType Complex Type

Sequence

PriceName 0..∞ TextLanguageType Complex Type
Price description

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

Quantity xs:int
Quantity of price

Price CurrencyAmountType Complex Type
Price amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATAmount optional CurrencyAmountType Complex Type
VAT amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

VATPercentage optional xs:decimal
VAT percentage

VATIncluded optional xs:boolean
Flag if VAT is included or additional

AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking

TotalPrices 0..∞ TotalPriceType Complex Type

Sequence

Choice

ServicePrice CommonTotalServicePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component

ServiceTypePrice CommonTotalServiceTypePriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)

TravellerPrice CommonTotalTravellerPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

AssignedTraveller IdentifierType Simple Type
Reference to a traveller

BookingPrice CommonTotalBookingPriceType Complex Type

Sequence

TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese

Sequence

Amount xs:decimal

Currency optional CurrencyCodeType Simple Type

Informations InformationsType Complex Type
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

InformationDetail 1..∞ InformationType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

Warnings WarningsType Complex Type
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

WarningDetail 1..∞ WarningType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user

Errors ErrorsType Complex Type
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.

Sequence

ErrorDetail 1..∞ ErrorType Complex Type

Sequence

Identifier IdentifierType Simple Type
Unique information identifier

Code xs:token
Code for the information defined by the touroperator

Description 0..∞ TextLanguageType Complex Type
Description for the information

Sequence

Text xs:string
Text in the given language

LanguageCode xs:language
ISO language code: either XX or XX_yy

AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServices optional IdentifiersType Complex Type
List of services which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information

Sequence

Identifier 1..∞ IdentifierType Simple Type

AssignedToBooking optional xs:boolean
Flag if this information is booking related

ErrorCategory ErrorCategoryType Simple Type
Specific error category

Used By

Booking Element
BookingResponse Element

Source
<xs:complexType name="BookingResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="BookingState" type="BookabilityStateType" nillable="true">
      <xs:annotation>
        <xs:documentation>Bookability state for the whole booking</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="ProcessState" type="ProcessStateType" nillable="true">
      <xs:annotation>
        <xs:documentation>Indicator of next possible process states of the result</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="TransactionState" type="TransactionStateType" nillable="true">
      <xs:annotation>
        <xs:documentation>Indicator for a technical error while processing a request, not to be used by touroperator</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Services" type="ServicesResponseType" nillable="false" />
    <xs:element name="Packages" type="PackagesResponseType" nillable="true" />
    <xs:element name="Travellers" type="TravellersResponseType" nillable="false" />
    <xs:element name="BookingDetails" type="CommonBookingType" nillable="true" />
    <xs:element name="Prices" type="PricesResponseType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Informations" type="InformationsType" nillable="true">
      <xs:annotation>
        <xs:documentation>General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Warnings" type="WarningsType" nillable="true">
      <xs:annotation>
        <xs:documentation>Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Errors" type="ErrorsType" nillable="true">
      <xs:annotation>
        <xs:documentation>Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also

String Schema


BookingDetails Element

String Schema
BookingDetails Element
String Schema > BookingResponseType Complex Type : BookingDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonBookingType Complex Type
Diagram
ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element SessionId Element Sequence BookingDetails Element
Overview
BookingDetails CommonBookingType Complex Type
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="BookingDetails" type="CommonBookingType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingResponseType Complex Type | String Schema


BookingState Element

String Schema
BookingState Element
String Schema > BookingResponseType Complex Type : BookingState Element
Description
Bookability state for the whole booking
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
BookingState BookabilityStateType Simple Type
Bookability state for the whole booking
Source
<xs:element name="BookingState" type="BookabilityStateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Bookability state for the whole booking</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


Errors Element

String Schema
Errors Element
String Schema > BookingResponseType Complex Type : Errors Element
Description
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.
Namespace http://string.drv.de/xmlschema/string
Type
ErrorsType Complex Type
Diagram
ErrorCategory Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence ErrorDetail Element Sequence Errors Element
Overview
Errors ErrorsType Complex Type
Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.
Sequence
ErrorDetail 1..∞ ErrorType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
ErrorCategory ErrorCategoryType Simple Type
Specific error category
Source
<xs:element name="Errors" type="ErrorsType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Errors related to this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


Informations Element

String Schema
Informations Element
String Schema > BookingResponseType Complex Type : Informations Element
Description
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.
Namespace http://string.drv.de/xmlschema/string
Type
InformationsType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence InformationDetail Element Sequence Informations Element
Overview
Informations InformationsType Complex Type
General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.
Sequence
InformationDetail 1..∞ InformationType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Source
<xs:element name="Informations" type="InformationsType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>General informations related to this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


Packages Element

String Schema
Packages Element
String Schema > BookingResponseType Complex Type : Packages Element
Namespace http://string.drv.de/xmlschema/string
Type
PackagesResponseType Complex Type
Diagram
AdditionalInfos Element CustomerRequests Element State Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence Package Element Sequence Packages Element
Overview
Packages PackagesResponseType Complex Type
Sequence
Package 0..∞ PackageResponseType Complex Type
Sequence
Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="Packages" type="PackagesResponseType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingResponseType Complex Type | String Schema


Prices Element

String Schema
Prices Element
String Schema > BookingResponseType Complex Type : Prices Element
Description
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.
Namespace http://string.drv.de/xmlschema/string
Type
PricesResponseType Complex Type
Diagram
Sequence BookingPrice Element Sequence TravellerPrice Element Sequence ServiceTypePrice Element Sequence ServicePrice Element Choice Sequence TotalPrices Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence Prices Element
Overview
Prices optional PricesResponseType Complex Type
Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.
Sequence
DetailPrices 0..∞ CommonPriceResponseType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
TotalPrices 0..∞ TotalPriceType Complex Type
Sequence
Choice
ServicePrice CommonTotalServicePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
ServiceTypePrice CommonTotalServiceTypePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
TravellerPrice CommonTotalTravellerPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
BookingPrice CommonTotalBookingPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Prices" type="PricesResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Pricing information for this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


ProcessState Element

String Schema
ProcessState Element
String Schema > BookingResponseType Complex Type : ProcessState Element
Description
Indicator of next possible process states of the result
Namespace http://string.drv.de/xmlschema/string
Type
ProcessStateType Simple Type
Overview
ProcessState ProcessStateType Simple Type
Indicator of next possible process states of the result
Source
<xs:element name="ProcessState" type="ProcessStateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Indicator of next possible process states of the result</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


Services Element

String Schema
Services Element
String Schema > BookingResponseType Complex Type : Services Element
Namespace http://string.drv.de/xmlschema/string
Type
ServicesResponseType Complex Type
Diagram
Service Element Sequence Services Element
Overview
Services ServicesResponseType Complex Type
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
LocationDetails AccommodationProductResponseType Complex Type
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Rooms optional AccommodationRoomsResponseType Complex Type
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Description 0..∞ TextLanguageType Complex Type
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Stay AccommodationStayResponseType Complex Type
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightResponseType Complex Type
Sequence
Legs optional FlightLegsResponseType Complex Type
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Catalogue optional CatalogueResponseType Complex Type
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
CancellationPolicies optional CancellationPoliciesType Complex Type
ModificationPolicies optional ModficationPoliciesType Complex Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CommonService CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
References optional ServiceResponseReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Source
<xs:element name="Services" type="ServicesResponseType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingResponseType Complex Type | String Schema


TransactionState Element

String Schema
TransactionState Element
String Schema > BookingResponseType Complex Type : TransactionState Element
Description
Indicator for a technical error while processing a request, not to be used by touroperator
Namespace http://string.drv.de/xmlschema/string
Type
TransactionStateType Simple Type
Overview
TransactionState TransactionStateType Simple Type
Indicator for a technical error while processing a request, not to be used by touroperator
Source
<xs:element name="TransactionState" type="TransactionStateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Indicator for a technical error while processing a request, not to be used by touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


Travellers Element

String Schema
Travellers Element
String Schema > BookingResponseType Complex Type : Travellers Element
Namespace http://string.drv.de/xmlschema/string
Type
TravellersResponseType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence Travellers Element
Overview
Travellers TravellersResponseType Complex Type
Sequence
Traveller 0..∞ CommonTravellerResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Travellers" type="TravellersResponseType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BookingResponseType Complex Type | String Schema


Warnings Element

String Schema
Warnings Element
String Schema > BookingResponseType Complex Type : Warnings Element
Description
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.
Namespace http://string.drv.de/xmlschema/string
Type
WarningsType Complex Type
Diagram
HasToBeConfirmed Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence WarningDetail Element Sequence Warnings Element
Overview
Warnings WarningsType Complex Type
Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.
Sequence
WarningDetail 1..∞ WarningType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user
Source
<xs:element name="Warnings" type="WarningsType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Warnings related to this booking. Might be referencing certain services, servicetypes and/or participants.</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
BookingResponseType Complex Type | String Schema


CancellationPoliciesType Complex Type

String Schema
CancellationPoliciesType Complex Type
String Schema : CancellationPoliciesType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Percentage Element Sequence Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence Fees Element Sequence CancellationPoliciesType Complex Type
Overview
CancellationPoliciesType
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Used By
CancellationPolicies Element
Attributes
Name | Type | Use | Default | Fixed | Description
Free | xs:boolean | optional |  |  | True if cancelable for free
FreeTo | xs:dateTime | optional |  |  | End of "Free Cancellation" period
Full | xs:boolean | optional |  |  | True if noncancelable
FullFrom | DateTimeType Simple Type | optional |  |  | Start date-time of 100% penalty
Source
<xs:complexType name="CancellationPoliciesType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Fees" type="FeeType" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Free" type="xs:boolean">
    <xs:annotation>
      <xs:documentation>True if cancelable for free </xs:documentation>
    </xs:annotation>
  </xs:attribute>
  <xs:attribute name="FreeTo" type="xs:dateTime">
    <xs:annotation>
      <xs:documentation>End of "Free Cancellation" period</xs:documentation>
    </xs:annotation>
  </xs:attribute>
  <xs:attribute name="Full" type="xs:boolean">
    <xs:annotation>
      <xs:documentation>True if noncancelable</xs:documentation>
    </xs:annotation>
  </xs:attribute>
  <xs:attribute name="FullFrom" type="DateTimeType">
    <xs:annotation>
      <xs:documentation>Start date-time of 100% penalty </xs:documentation>
    </xs:annotation>
  </xs:attribute>
</xs:complexType>
See Also
String Schema


Fees Element

String Schema
Fees Element
String Schema > CancellationPoliciesType Complex Type : Fees Element
Namespace http://string.drv.de/xmlschema/string
Type
FeeType Complex Type
Diagram
Percentage Element Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence Fees Element
Overview
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="Fees" type="FeeType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CancellationPoliciesType Complex Type | String Schema


CarrentalRequestType Complex Type

String Schema
CarrentalRequestType Complex Type
String Schema : CarrentalRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceRequestType Complex Type
Diagram
Data Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CarrentalRequestType Complex Type
Overview
CarrentalRequestType Extension of CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonCarRentalDataType Complex Type
Source
<xs:complexType name="CarrentalRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceRequestType">
      <xs:sequence>
        <xs:element name="Data" type="CommonCarRentalDataType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CarrentalRequestType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CarrentalRequestType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > CarrentalRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


Data Element

String Schema
Data Element
String Schema > CarrentalRequestType Complex Type : Data Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonCarRentalDataType Complex Type
Overview
Data optional CommonCarRentalDataType Complex Type
Source
<xs:element name="Data" type="CommonCarRentalDataType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CarrentalRequestType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CarrentalRequestType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CarrentalRequestType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CarrentalRequestType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > CarrentalRequestType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeRequestType Complex Type
Diagram
Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Source
<xs:element name="Product" type="ProductCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CarrentalRequestType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CarrentalRequestType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


RequestedPrices Element

String Schema
RequestedPrices Element
String Schema > CarrentalRequestType Complex Type : RequestedPrices Element
Description
Prices of an offer or the prices resulting from an external search
Namespace http://string.drv.de/xmlschema/string
Type
PricesRequestType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element
Overview
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="RequestedPrices" type="PricesRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Prices of an offer or the prices resulting from an external search</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CarrentalRequestType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CarrentalRequestType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalRequestType Complex Type | String Schema


CarrentalResponseType Complex Type

String Schema
CarrentalResponseType Complex Type
String Schema : CarrentalResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceResponseType Complex Type
Diagram
Data Element Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CarrentalResponseType Complex Type
Overview
CarrentalResponseType Extension of CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonCarRentalDataType Complex Type
Source
<xs:complexType name="CarrentalResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceResponseType">
      <xs:sequence>
        <xs:element name="Data" type="CommonCarRentalDataType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AdditionalInfos Element

String Schema
AdditionalInfos Element
String Schema > CarrentalResponseType Complex Type : AdditionalInfos Element
Description
Additional infos (e.g. cancellation and modifications conditions)
Namespace http://string.drv.de/xmlschema/string
Type
ServicesResponseAdditionalInfoType Complex Type
Diagram
Choice From Element Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element Choice From Element Description Element Sequence Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element
Overview
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="AdditionalInfos" type="ServicesResponseAdditionalInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Additional infos (e.g. cancellation and modifications conditions)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CarrentalResponseType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CarrentalResponseType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > CarrentalResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


Data Element

String Schema
Data Element
String Schema > CarrentalResponseType Complex Type : Data Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonCarRentalDataType Complex Type
Overview
Data optional CommonCarRentalDataType Complex Type
Source
<xs:element name="Data" type="CommonCarRentalDataType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CarrentalResponseType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CarrentalResponseType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CarrentalResponseType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CarrentalResponseType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > CarrentalResponseType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Product" type="ProductCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CarrentalResponseType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CarrentalResponseType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CarrentalResponseType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CarrentalResponseType Complex Type : State Element
Description
Service bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Service bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Service bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CarrentalResponseType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CarrentalResponseType Complex Type | String Schema


CatalogueRequestType Complex Type

String Schema
CatalogueRequestType Complex Type
String Schema : CatalogueRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Page Element Season Element Code Element Sequence CatalogueRequestType Complex Type
Overview
CatalogueRequestType
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Used By
Catalogue Element
Source
<xs:complexType name="CatalogueRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" />
    <xs:element name="Season" type="xs:token" minOccurs="0" />
    <xs:element name="Page" type="xs:integer" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > CatalogueRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueRequestType Complex Type | String Schema


Page Element

String Schema
Page Element
String Schema > CatalogueRequestType Complex Type : Page Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:integer
Overview
Page optional xs:integer
Source
<xs:element name="Page" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueRequestType Complex Type | String Schema


Season Element

String Schema
Season Element
String Schema > CatalogueRequestType Complex Type : Season Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Season optional xs:token
Source
<xs:element name="Season" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueRequestType Complex Type | String Schema


CatalogueResponseType Complex Type

String Schema
CatalogueResponseType Complex Type
String Schema : CatalogueResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence CatalogueResponseType Complex Type
Overview
CatalogueResponseType
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Catalogue Element
Source
<xs:complexType name="CatalogueResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" />
    <xs:element name="Season" type="xs:token" minOccurs="0" />
    <xs:element name="Page" type="xs:integer" minOccurs="0" />
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > CatalogueResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > CatalogueResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueResponseType Complex Type | String Schema


Page Element

String Schema
Page Element
String Schema > CatalogueResponseType Complex Type : Page Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:integer
Overview
Page optional xs:integer
Source
<xs:element name="Page" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueResponseType Complex Type | String Schema


Season Element

String Schema
Season Element
String Schema > CatalogueResponseType Complex Type : Season Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Season optional xs:token
Source
<xs:element name="Season" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CatalogueResponseType Complex Type | String Schema


CheckInData Complex Type

String Schema
CheckInData Complex Type
String Schema : CheckInData Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Complex Type
Overview
CheckInData
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
Used By
CheckInData Element
CheckInData Element
CheckInData Element
Source
<xs:complexType name="CheckInData" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Time" type="TimeType" nillable="true" minOccurs="0" />
    <xs:element name="Counter" type="xs:string" minOccurs="0" />
    <xs:element name="Terminal" type="xs:string" minOccurs="0" />
    <xs:element name="Gate" type="xs:string" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Counter Element

String Schema
Counter Element
String Schema > CheckInData Complex Type : Counter Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Counter optional xs:string
Source
<xs:element name="Counter" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CheckInData Complex Type | String Schema


Gate Element

String Schema
Gate Element
String Schema > CheckInData Complex Type : Gate Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Gate optional xs:string
Source
<xs:element name="Gate" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CheckInData Complex Type | String Schema


Terminal Element

String Schema
Terminal Element
String Schema > CheckInData Complex Type : Terminal Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Terminal optional xs:string
Source
<xs:element name="Terminal" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CheckInData Complex Type | String Schema


Time Element

String Schema
Time Element
String Schema > CheckInData Complex Type : Time Element
Namespace http://string.drv.de/xmlschema/string
Type
TimeType Simple Type
Overview
Time optional TimeType Simple Type
Source
<xs:element name="Time" type="TimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CheckInData Complex Type | String Schema


ClassBaseCommonType Complex Type

String Schema
ClassBaseCommonType Complex Type
String Schema : ClassBaseCommonType Complex Type
Description
Flight class information
Namespace http://string.drv.de/xmlschema/string
Diagram
CabinClass Element Sequence ClassBaseCommonType Complex Type
Overview
ClassBaseCommonType
Flight class information
Sequence
CabinClass optional CabinClassType Simple Type
Source
<xs:complexType name="ClassBaseCommonType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight class information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CabinClass Element

String Schema
CabinClass Element
String Schema > ClassBaseCommonType Complex Type : CabinClass Element
Namespace http://string.drv.de/xmlschema/string
Type
CabinClassType Simple Type
Overview
CabinClass optional CabinClassType Simple Type
Source
<xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassBaseCommonType Complex Type | String Schema


ClassBaseRequestType Complex Type

String Schema
ClassBaseRequestType Complex Type
String Schema : ClassBaseRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of ClassBaseCommonType Complex Type
Diagram
Code Element Sequence ClassCode Element CabinClass Element Sequence ClassBaseRequestType Complex Type
Overview
ClassBaseRequestType Extension of ClassBaseCommonType Complex Type
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Used By
Class Element
Source
<xs:complexType name="ClassBaseRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="ClassBaseCommonType">
      <xs:annotation>
        <xs:documentation>Class information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="ClassCode" type="ClassRequestType" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


CabinClass Element

String Schema
CabinClass Element
String Schema > ClassBaseRequestType Complex Type : CabinClass Element
Namespace http://string.drv.de/xmlschema/string
Type
CabinClassType Simple Type
Overview
CabinClass optional CabinClassType Simple Type
Source
<xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassBaseRequestType Complex Type | String Schema


ClassCode Element

String Schema
ClassCode Element
String Schema > ClassBaseRequestType Complex Type : ClassCode Element
Namespace http://string.drv.de/xmlschema/string
Type
ClassRequestType Complex Type
Diagram
Code Element Sequence ClassCode Element
Overview
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="ClassCode" type="ClassRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassBaseRequestType Complex Type | String Schema


ClassBaseResponseType Complex Type

String Schema
ClassBaseResponseType Complex Type
String Schema : ClassBaseResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of ClassBaseCommonType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassCode Element CabinClass Element Sequence ClassBaseResponseType Complex Type
Overview
ClassBaseResponseType Extension of ClassBaseCommonType Complex Type
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Class Element
Source
<xs:complexType name="ClassBaseResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="ClassBaseCommonType">
      <xs:annotation>
        <xs:documentation>Class information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="ClassCode" type="ClassResponseType" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


CabinClass Element

String Schema
CabinClass Element
String Schema > ClassBaseResponseType Complex Type : CabinClass Element
Namespace http://string.drv.de/xmlschema/string
Type
CabinClassType Simple Type
Overview
CabinClass optional CabinClassType Simple Type
Source
<xs:element name="CabinClass" type="CabinClassType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassBaseResponseType Complex Type | String Schema


ClassCode Element

String Schema
ClassCode Element
String Schema > ClassBaseResponseType Complex Type : ClassCode Element
Namespace http://string.drv.de/xmlschema/string
Type
ClassResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassCode Element
Overview
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="ClassCode" type="ClassResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassBaseResponseType Complex Type | String Schema


ClassRequestType Complex Type

String Schema
ClassRequestType Complex Type
String Schema : ClassRequestType Complex Type
Description
Class
Namespace http://string.drv.de/xmlschema/string
Diagram
Code Element Sequence ClassRequestType Complex Type
Overview
ClassRequestType
Class
Sequence
Code xs:token
Used By
ClassCode Element
ClassCode Element
Source
<xs:complexType name="ClassRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Class</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > ClassRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassRequestType Complex Type | String Schema


ClassResponseType Complex Type

String Schema
ClassResponseType Complex Type
String Schema : ClassResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of ClassRequestType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassResponseType Complex Type
Overview
ClassResponseType Extension of ClassRequestType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
ClassCode Element
ClassCode Element
Source
<xs:complexType name="ClassResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="ClassRequestType">
      <xs:sequence>
        <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > ClassResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > ClassResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassResponseType Complex Type | String Schema


CommonAgencyType Complex Type

String Schema
CommonAgencyType Complex Type
String Schema : CommonAgencyType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
AgentId Element Agency Element Sequence CommonAgencyType Complex Type
Overview
CommonAgencyType
Sequence
Agency xs:string
Identification of the executing agency
AgentId xs:int
Identification of the executing agent
Used By
AgencyInformation Element
AgencyInformation Element
AgencyInformation Element
AgencyInformation Element
Source
<xs:complexType name="CommonAgencyType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Agency" type="xs:string">
      <xs:annotation>
        <xs:documentation>Identification of the executing agency</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AgentId" type="xs:int">
      <xs:annotation>
        <xs:documentation>Identification of the executing agent</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Agency Element

String Schema
Agency Element
String Schema > CommonAgencyType Complex Type : Agency Element
Description
Identification of the executing agency
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Agency xs:string
Identification of the executing agency
Source
<xs:element name="Agency" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Identification of the executing agency</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonAgencyType Complex Type | String Schema


AgentId Element

String Schema
AgentId Element
String Schema > CommonAgencyType Complex Type : AgentId Element
Description
Identification of the executing agent
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
AgentId xs:int
Identification of the executing agent
Source
<xs:element name="AgentId" type="xs:int" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Identification of the executing agent</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonAgencyType Complex Type | String Schema


CommonBookingType Complex Type

String Schema
CommonBookingType Complex Type
String Schema : CommonBookingType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element SessionId Element Sequence CommonBookingType Complex Type
Overview
CommonBookingType
Sequence
SessionId optional xs:string
Identification of the current session context
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Used By
BookingDetails Element
BookingDetails Element
Source
<xs:complexType name="CommonBookingType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="SessionId" minOccurs="0" type="xs:string">
      <xs:annotation>
        <xs:documentation>Identification of the current session context</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="InvoiceAddress" minOccurs="0" nillable="true" type="CommonTravellerType">
      <xs:annotation>
        <xs:documentation>Client information for invoicing</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="DeliveryAddress" minOccurs="0" nillable="true" type="CommonTravellerType">
      <xs:annotation>
        <xs:documentation>Client information for documents to be sent</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="BookingOwnerAddress" minOccurs="0" nillable="true" type="CommonTravellerType">
      <xs:annotation>
        <xs:documentation>Client information for whom the booking is made</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="EmergencyAddress" minOccurs="0" nillable="true" type="CommonTravellerType">
      <xs:annotation>
        <xs:documentation>Address of a person who should be contacted in case of emergency</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


BookingOwnerAddress Element

String Schema
BookingOwnerAddress Element
String Schema > CommonBookingType Complex Type : BookingOwnerAddress Element
Description
Client information for whom the booking is made
Namespace http://string.drv.de/xmlschema/string
Type
CommonTravellerType Complex Type
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence BookingOwnerAddress Element
Overview
BookingOwnerAddress optional CommonTravellerType Complex Type
Client information for whom the booking is made
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="BookingOwnerAddress" minOccurs="0" nillable="true" type="CommonTravellerType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Client information for whom the booking is made</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonBookingType Complex Type | String Schema


DeliveryAddress Element

String Schema
DeliveryAddress Element
String Schema > CommonBookingType Complex Type : DeliveryAddress Element
Description
Client information for documents to be sent
Namespace http://string.drv.de/xmlschema/string
Type
CommonTravellerType Complex Type
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence DeliveryAddress Element
Overview
DeliveryAddress optional CommonTravellerType Complex Type
Client information for documents to be sent
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="DeliveryAddress" minOccurs="0" nillable="true" type="CommonTravellerType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Client information for documents to be sent</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonBookingType Complex Type | String Schema


EmergencyAddress Element

String Schema
EmergencyAddress Element
String Schema > CommonBookingType Complex Type : EmergencyAddress Element
Description
Address of a person who should be contacted in case of emergency
Namespace http://string.drv.de/xmlschema/string
Type
CommonTravellerType Complex Type
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence EmergencyAddress Element
Overview
EmergencyAddress optional CommonTravellerType Complex Type
Address of a person who should be contacted in case of emergency
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="EmergencyAddress" minOccurs="0" nillable="true" type="CommonTravellerType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Address of a person who should be contacted in case of emergency</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonBookingType Complex Type | String Schema


InvoiceAddress Element

String Schema
InvoiceAddress Element
String Schema > CommonBookingType Complex Type : InvoiceAddress Element
Description
Client information for invoicing
Namespace http://string.drv.de/xmlschema/string
Type
CommonTravellerType Complex Type
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence InvoiceAddress Element
Overview
InvoiceAddress optional CommonTravellerType Complex Type
Client information for invoicing
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="InvoiceAddress" minOccurs="0" nillable="true" type="CommonTravellerType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Client information for invoicing</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonBookingType Complex Type | String Schema


SessionId Element

String Schema
SessionId Element
String Schema > CommonBookingType Complex Type : SessionId Element
Description
Identification of the current session context
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
SessionId optional xs:string
Identification of the current session context
Source
<xs:element name="SessionId" minOccurs="0" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Identification of the current session context</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonBookingType Complex Type | String Schema


CommonCarRentalDataType Complex Type

String Schema
CommonCarRentalDataType Complex Type
String Schema : CommonCarRentalDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Overview
CommonCarRentalDataType
Used By
Data Element
Data Element
Source
<xs:complexType name="CommonCarRentalDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
String Schema


CommonCruiseDataType Complex Type

String Schema
CommonCruiseDataType Complex Type
String Schema : CommonCruiseDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Overview
CommonCruiseDataType
Used By
Data Element
Data Element
Source
<xs:complexType name="CommonCruiseDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
String Schema


CommonFlightDataType Complex Type

String Schema
CommonFlightDataType Complex Type
String Schema : CommonFlightDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
PointOfTurnAround Element Value Element Sequence PNR Element Sequence CommonFlightDataType Complex Type
Overview
CommonFlightDataType
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Used By
Data Element
Data Element
Source
<xs:complexType name="CommonFlightDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="PNR" type="ListType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>PNR reference</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="PointOfTurnAround" type="xs:string" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Point of turnaround of the flight (in case of return flight)</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


PNR Element

String Schema
PNR Element
String Schema > CommonFlightDataType Complex Type : PNR Element
Description
PNR reference
Namespace http://string.drv.de/xmlschema/string
Type
ListType Complex Type
Diagram
Value Element Sequence PNR Element
Overview
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
Source
<xs:element name="PNR" type="ListType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>PNR reference</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightDataType Complex Type | String Schema


PointOfTurnAround Element

String Schema
PointOfTurnAround Element
String Schema > CommonFlightDataType Complex Type : PointOfTurnAround Element
Description
Point of turnaround of the flight (in case of return flight)
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Source
<xs:element name="PointOfTurnAround" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Point of turnaround of the flight (in case of return flight)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightDataType Complex Type | String Schema


CommonFlightLegRequestType Complex Type

String Schema
CommonFlightLegRequestType Complex Type
String Schema : CommonFlightLegRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ClassCode Element CabinClass Element Sequence Class Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Identifier Element Sequence CommonFlightLegRequestType Complex Type
Overview
CommonFlightLegRequestType
Sequence
Identifier IdentifierType Simple Type
Segment 1..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:complexType name="CommonFlightLegRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType" />
    <xs:element name="Segment" type="CommonFlightSegmentRequestType" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonFlightLegRequestType Complex Type : Identifier Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightLegRequestType Complex Type | String Schema


Segment Element

String Schema
Segment Element
String Schema > CommonFlightLegRequestType Complex Type : Segment Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonFlightSegmentRequestType Complex Type
Diagram
Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element
Overview
Segment 1..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="Segment" type="CommonFlightSegmentRequestType" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightLegRequestType Complex Type | String Schema


CommonFlightLegResponseType Complex Type

String Schema
CommonFlightLegResponseType Complex Type
String Schema : CommonFlightLegResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
HasSeatmap Element ClassCode Element CabinClass Element Sequence Class Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element Location Element AirportName Element Choice Sequence ArrivalAirport Element Location Element AirportName Element Choice Sequence DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Identifier Element Sequence CommonFlightLegResponseType Complex Type
Overview
CommonFlightLegResponseType
Sequence
Identifier IdentifierType Simple Type
Segment 1..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Source
<xs:complexType name="CommonFlightLegResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType" />
    <xs:element name="Segment" type="CommonFlightSegmentResponseType" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonFlightLegResponseType Complex Type : Identifier Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightLegResponseType Complex Type | String Schema


Segment Element

String Schema
Segment Element
String Schema > CommonFlightLegResponseType Complex Type : Segment Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonFlightSegmentResponseType Complex Type
Diagram
HasSeatmap Element Description Element Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element AirlineName Element Choice Sequence MarketingCarrier Element AirlineName Element Choice Sequence OperatingCarrier Element Sequence Carrier Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element
Overview
Segment 1..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Source
<xs:element name="Segment" type="CommonFlightSegmentResponseType" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightLegResponseType Complex Type | String Schema


CommonFlightSegmentRequestType Complex Type

String Schema
CommonFlightSegmentRequestType Complex Type
String Schema : CommonFlightSegmentRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonFlightSegmentType Complex Type
Diagram
Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence CommonFlightSegmentRequestType Complex Type
Overview
CommonFlightSegmentRequestType Extension of CommonFlightSegmentType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Used By
Segment Element
Segment Element
Source
<xs:complexType name="CommonFlightSegmentRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonFlightSegmentType">
      <xs:sequence>
        <xs:element name="DepartureAirport" type="AirportRequestType">
          <xs:annotation>
            <xs:documentation>Departure airport for the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="ArrivalAirport" type="AirportRequestType">
          <xs:annotation>
            <xs:documentation>Arrival airport of the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="Carrier" type="AirlineRequestTypes" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Carrier information of the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="Class" type="ClassBaseRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Class information of the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


ArrivalAirport Element

String Schema
ArrivalAirport Element
String Schema > CommonFlightSegmentRequestType Complex Type : ArrivalAirport Element
Description
Arrival airport of the segment
Namespace http://string.drv.de/xmlschema/string
Type
AirportRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice ArrivalAirport Element
Overview
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="ArrivalAirport" type="AirportRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival airport of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


ArrivalDate Element

String Schema
ArrivalDate Element
String Schema > CommonFlightSegmentRequestType Complex Type : ArrivalDate Element
Description
Arrival date and time of the segment
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
Source
<xs:element name="ArrivalDate" type="DateTimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival date and time of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


ArrivalTerminal Element

String Schema
ArrivalTerminal Element
String Schema > CommonFlightSegmentRequestType Complex Type : ArrivalTerminal Element
Description
Arrival terminal of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ArrivalTerminal optional xs:string
Arrival terminal of the segment
Source
<xs:element name="ArrivalTerminal" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival terminal of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonFlightSegmentRequestType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


Carrier Element

String Schema
Carrier Element
String Schema > CommonFlightSegmentRequestType Complex Type : Carrier Element
Description
Carrier information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
AirlineRequestTypes Complex Type
Diagram
IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element
Overview
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="Carrier" type="AirlineRequestTypes" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Carrier information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


CheckInData Element

String Schema
CheckInData Element
String Schema > CommonFlightSegmentRequestType Complex Type : CheckInData Element
Description
Check-In information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
CheckInData Complex Type
Diagram
Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element
Overview
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
Source
<xs:element name="CheckInData" type="CheckInData" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Check-In information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


Class Element

String Schema
Class Element
String Schema > CommonFlightSegmentRequestType Complex Type : Class Element
Description
Class information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
ClassBaseRequestType Complex Type
Diagram
Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element
Overview
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="Class" type="ClassBaseRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Class information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


DepartureAirport Element

String Schema
DepartureAirport Element
String Schema > CommonFlightSegmentRequestType Complex Type : DepartureAirport Element
Description
Departure airport for the segment
Namespace http://string.drv.de/xmlschema/string
Type
AirportRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice DepartureAirport Element
Overview
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="DepartureAirport" type="AirportRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Departure airport for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


DepartureDate Element

String Schema
DepartureDate Element
String Schema > CommonFlightSegmentRequestType Complex Type : DepartureDate Element
Description
Departure date and time of the segment
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
Source
<xs:element name="DepartureDate" type="DateTimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Departure date and time of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


ETIX Element

String Schema
ETIX Element
String Schema > CommonFlightSegmentRequestType Complex Type : ETIX Element
Description
ETIX reference of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ETIX optional xs:string
ETIX reference of the segment
Source
<xs:element name="ETIX" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ETIX reference of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


FlightNumber Element

String Schema
FlightNumber Element
String Schema > CommonFlightSegmentRequestType Complex Type : FlightNumber Element
Description
Flight number of the segment
Namespace http://string.drv.de/xmlschema/string
Type
FlightNumberType Simple Type
Overview
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
Source
<xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight number of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonFlightSegmentRequestType Complex Type : Identifier Element
Description
Unique flight segment identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique flight segment identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique flight segment identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


Overnights Element

String Schema
Overnights Element
String Schema > CommonFlightSegmentRequestType Complex Type : Overnights Element
Description
Overnight counter of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Overnights optional xs:int
Overnight counter of the segment
Source
<xs:element name="Overnights" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Overnight counter of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


PNR Element

String Schema
PNR Element
String Schema > CommonFlightSegmentRequestType Complex Type : PNR Element
Description
PNR reference for the segment
Namespace http://string.drv.de/xmlschema/string
Type
ListType Complex Type
Diagram
Value Element Sequence PNR Element
Overview
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
Source
<xs:element name="PNR" type="ListType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>PNR reference for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CommonFlightSegmentRequestType Complex Type : State Element
Description
Bookability state for the segment
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State optional BookabilityStateType Simple Type
Bookability state for the segment
Source
<xs:element name="State" type="BookabilityStateType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Bookability state for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentRequestType Complex Type | String Schema


CommonFlightSegmentResponseType Complex Type

String Schema
CommonFlightSegmentResponseType Complex Type
String Schema : CommonFlightSegmentResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonFlightSegmentType Complex Type
Diagram
HasSeatmap Element Description Element Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element AirlineName Element Choice Sequence MarketingCarrier Element AirlineName Element Choice Sequence OperatingCarrier Element Sequence Carrier Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence CommonFlightSegmentResponseType Complex Type
Overview
CommonFlightSegmentResponseType Extension of CommonFlightSegmentType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Used By
Segment Element
Segment Element
Source
<xs:complexType name="CommonFlightSegmentResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonFlightSegmentType">
      <xs:sequence>
        <xs:element name="DepartureAirport" type="AirportResponseType">
          <xs:annotation>
            <xs:documentation>Departure airport for the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="ArrivalAirport" type="AirportResponseType">
          <xs:annotation>
            <xs:documentation>Arrival airport of the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="Carrier" type="AirlineResponseTypes">
          <xs:annotation>
            <xs:documentation>Carrier information of the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="Class" type="ClassBaseResponseType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Class information of the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="HasSeatmap" type="xs:boolean" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Flag if a seatmap information can be requested for the segment</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


ArrivalAirport Element

String Schema
ArrivalAirport Element
String Schema > CommonFlightSegmentResponseType Complex Type : ArrivalAirport Element
Description
Arrival airport of the segment
Namespace http://string.drv.de/xmlschema/string
Type
AirportResponseType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element
Overview
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="ArrivalAirport" type="AirportResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival airport of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


ArrivalDate Element

String Schema
ArrivalDate Element
String Schema > CommonFlightSegmentResponseType Complex Type : ArrivalDate Element
Description
Arrival date and time of the segment
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
Source
<xs:element name="ArrivalDate" type="DateTimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival date and time of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


ArrivalTerminal Element

String Schema
ArrivalTerminal Element
String Schema > CommonFlightSegmentResponseType Complex Type : ArrivalTerminal Element
Description
Arrival terminal of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ArrivalTerminal optional xs:string
Arrival terminal of the segment
Source
<xs:element name="ArrivalTerminal" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival terminal of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonFlightSegmentResponseType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


Carrier Element

String Schema
Carrier Element
String Schema > CommonFlightSegmentResponseType Complex Type : Carrier Element
Description
Carrier information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
AirlineResponseTypes Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence MarketingCarrier Element LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence OperatingCarrier Element Sequence Carrier Element
Overview
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Carrier" type="AirlineResponseTypes" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Carrier information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


CheckInData Element

String Schema
CheckInData Element
String Schema > CommonFlightSegmentResponseType Complex Type : CheckInData Element
Description
Check-In information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
CheckInData Complex Type
Diagram
Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element
Overview
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
Source
<xs:element name="CheckInData" type="CheckInData" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Check-In information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


Class Element

String Schema
Class Element
String Schema > CommonFlightSegmentResponseType Complex Type : Class Element
Description
Class information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
ClassBaseResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element
Overview
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Class" type="ClassBaseResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Class information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


DepartureAirport Element

String Schema
DepartureAirport Element
String Schema > CommonFlightSegmentResponseType Complex Type : DepartureAirport Element
Description
Departure airport for the segment
Namespace http://string.drv.de/xmlschema/string
Type
AirportResponseType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element
Overview
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="DepartureAirport" type="AirportResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Departure airport for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


DepartureDate Element

String Schema
DepartureDate Element
String Schema > CommonFlightSegmentResponseType Complex Type : DepartureDate Element
Description
Departure date and time of the segment
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
Source
<xs:element name="DepartureDate" type="DateTimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Departure date and time of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


ETIX Element

String Schema
ETIX Element
String Schema > CommonFlightSegmentResponseType Complex Type : ETIX Element
Description
ETIX reference of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ETIX optional xs:string
ETIX reference of the segment
Source
<xs:element name="ETIX" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ETIX reference of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


FlightNumber Element

String Schema
FlightNumber Element
String Schema > CommonFlightSegmentResponseType Complex Type : FlightNumber Element
Description
Flight number of the segment
Namespace http://string.drv.de/xmlschema/string
Type
FlightNumberType Simple Type
Overview
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
Source
<xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight number of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


HasSeatmap Element

String Schema
HasSeatmap Element
String Schema > CommonFlightSegmentResponseType Complex Type : HasSeatmap Element
Description
Flag if a seatmap information can be requested for the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Source
<xs:element name="HasSeatmap" type="xs:boolean" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if a seatmap information can be requested for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonFlightSegmentResponseType Complex Type : Identifier Element
Description
Unique flight segment identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique flight segment identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique flight segment identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


Overnights Element

String Schema
Overnights Element
String Schema > CommonFlightSegmentResponseType Complex Type : Overnights Element
Description
Overnight counter of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Overnights optional xs:int
Overnight counter of the segment
Source
<xs:element name="Overnights" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Overnight counter of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


PNR Element

String Schema
PNR Element
String Schema > CommonFlightSegmentResponseType Complex Type : PNR Element
Description
PNR reference for the segment
Namespace http://string.drv.de/xmlschema/string
Type
ListType Complex Type
Diagram
Value Element Sequence PNR Element
Overview
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
Source
<xs:element name="PNR" type="ListType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>PNR reference for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CommonFlightSegmentResponseType Complex Type : State Element
Description
Bookability state for the segment
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State optional BookabilityStateType Simple Type
Bookability state for the segment
Source
<xs:element name="State" type="BookabilityStateType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Bookability state for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentResponseType Complex Type | String Schema


CommonFlightSegmentType Complex Type

String Schema
CommonFlightSegmentType Complex Type
String Schema : CommonFlightSegmentType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence CommonFlightSegmentType Complex Type
Overview
CommonFlightSegmentType
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:complexType name="CommonFlightSegmentType" abstract="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType">
      <xs:annotation>
        <xs:documentation>Unique flight segment identifier</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="DepartureDate" type="DateTimeType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Departure date and time of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="ArrivalDate" type="DateTimeType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Arrival date and time of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Flight number of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="PNR" type="ListType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>PNR reference for the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="State" type="BookabilityStateType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Bookability state for the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="CheckInData" type="CheckInData" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Check-In information of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="ArrivalTerminal" type="xs:string" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Arrival terminal of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="ETIX" type="xs:string" minOccurs="0">
      <xs:annotation>
        <xs:documentation>ETIX reference of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Overnights" type="xs:int" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Overnight counter of the segment</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


ArrivalDate Element

String Schema
ArrivalDate Element
String Schema > CommonFlightSegmentType Complex Type : ArrivalDate Element
Description
Arrival date and time of the segment
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
Source
<xs:element name="ArrivalDate" type="DateTimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival date and time of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


ArrivalTerminal Element

String Schema
ArrivalTerminal Element
String Schema > CommonFlightSegmentType Complex Type : ArrivalTerminal Element
Description
Arrival terminal of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ArrivalTerminal optional xs:string
Arrival terminal of the segment
Source
<xs:element name="ArrivalTerminal" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Arrival terminal of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonFlightSegmentType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonFlightSegmentType Complex Type | String Schema


CheckInData Element

String Schema
CheckInData Element
String Schema > CommonFlightSegmentType Complex Type : CheckInData Element
Description
Check-In information of the segment
Namespace http://string.drv.de/xmlschema/string
Type
CheckInData Complex Type
Diagram
Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element
Overview
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
Source
<xs:element name="CheckInData" type="CheckInData" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Check-In information of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


DepartureDate Element

String Schema
DepartureDate Element
String Schema > CommonFlightSegmentType Complex Type : DepartureDate Element
Description
Departure date and time of the segment
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
Source
<xs:element name="DepartureDate" type="DateTimeType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Departure date and time of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


ETIX Element

String Schema
ETIX Element
String Schema > CommonFlightSegmentType Complex Type : ETIX Element
Description
ETIX reference of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ETIX optional xs:string
ETIX reference of the segment
Source
<xs:element name="ETIX" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ETIX reference of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


FlightNumber Element

String Schema
FlightNumber Element
String Schema > CommonFlightSegmentType Complex Type : FlightNumber Element
Description
Flight number of the segment
Namespace http://string.drv.de/xmlschema/string
Type
FlightNumberType Simple Type
Overview
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
Source
<xs:element name="FlightNumber" type="FlightNumberType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight number of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonFlightSegmentType Complex Type : Identifier Element
Description
Unique flight segment identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique flight segment identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique flight segment identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


Overnights Element

String Schema
Overnights Element
String Schema > CommonFlightSegmentType Complex Type : Overnights Element
Description
Overnight counter of the segment
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Overnights optional xs:int
Overnight counter of the segment
Source
<xs:element name="Overnights" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Overnight counter of the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


PNR Element

String Schema
PNR Element
String Schema > CommonFlightSegmentType Complex Type : PNR Element
Description
PNR reference for the segment
Namespace http://string.drv.de/xmlschema/string
Type
ListType Complex Type
Diagram
Value Element Sequence PNR Element
Overview
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
Source
<xs:element name="PNR" type="ListType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>PNR reference for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CommonFlightSegmentType Complex Type : State Element
Description
Bookability state for the segment
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State optional BookabilityStateType Simple Type
Bookability state for the segment
Source
<xs:element name="State" type="BookabilityStateType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Bookability state for the segment</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonFlightSegmentType Complex Type | String Schema


CommonPriceRequestType Complex Type

String Schema
CommonPriceRequestType Complex Type
String Schema : CommonPriceRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonPriceType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence CommonPriceRequestType Complex Type
Overview
CommonPriceRequestType Extension of CommonPriceType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Used By
DetailPrices Element
Source
<xs:complexType name="CommonPriceRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonPriceType" />
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedServices Element

String Schema
AssignedServices Element
String Schema > CommonPriceRequestType Complex Type : AssignedServices Element
Description
List of assigned services for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServices Element
Overview
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned services for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


AssignedServiceTypes Element

String Schema
AssignedServiceTypes Element
String Schema > CommonPriceRequestType Complex Type : AssignedServiceTypes Element
Description
List of assigned service types (e.g. rooms, flight classes) for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServiceTypes Element
Overview
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned service types (e.g. rooms, flight classes) for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


AssignedToBooking Element

String Schema
AssignedToBooking Element
String Schema > CommonPriceRequestType Complex Type : AssignedToBooking Element
Description
Flag if this price is assigned to the whole booking
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this price is assigned to the whole booking</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonPriceRequestType Complex Type : AssignedTravellers Element
Description
List of assigned participants for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned participants for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


Price Element

String Schema
Price Element
String Schema > CommonPriceRequestType Complex Type : Price Element
Description
Price amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence Price Element
Overview
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Price" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Price amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


PriceName Element

String Schema
PriceName Element
String Schema > CommonPriceRequestType Complex Type : PriceName Element
Description
Price description
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence PriceName Element
Overview
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="PriceName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Price description</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CommonPriceRequestType Complex Type : Quantity Element
Description
Quantity of price
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity xs:int
Quantity of price
Source
<xs:element name="Quantity" type="xs:int" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


VATAmount Element

String Schema
VATAmount Element
String Schema > CommonPriceRequestType Complex Type : VATAmount Element
Description
VAT amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence VATAmount Element
Overview
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="VATAmount" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>VAT amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


VATIncluded Element

String Schema
VATIncluded Element
String Schema > CommonPriceRequestType Complex Type : VATIncluded Element
Description
Flag if VAT is included or additional
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
VATIncluded optional xs:boolean
Flag if VAT is included or additional
Source
<xs:element name="VATIncluded" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if VAT is included or additional</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


VATPercentage Element

String Schema
VATPercentage Element
String Schema > CommonPriceRequestType Complex Type : VATPercentage Element
Description
VAT percentage
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
VATPercentage optional xs:decimal
VAT percentage
Source
<xs:element name="VATPercentage" type="xs:decimal" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>VAT percentage</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceRequestType Complex Type | String Schema


CommonPriceResponseType Complex Type

String Schema
CommonPriceResponseType Complex Type
String Schema : CommonPriceResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonPriceType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence CommonPriceResponseType Complex Type
Overview
CommonPriceResponseType Extension of CommonPriceType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Used By
DetailPrices Element
Source
<xs:complexType name="CommonPriceResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonPriceType" />
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedServices Element

String Schema
AssignedServices Element
String Schema > CommonPriceResponseType Complex Type : AssignedServices Element
Description
List of assigned services for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServices Element
Overview
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned services for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


AssignedServiceTypes Element

String Schema
AssignedServiceTypes Element
String Schema > CommonPriceResponseType Complex Type : AssignedServiceTypes Element
Description
List of assigned service types (e.g. rooms, flight classes) for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServiceTypes Element
Overview
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned service types (e.g. rooms, flight classes) for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


AssignedToBooking Element

String Schema
AssignedToBooking Element
String Schema > CommonPriceResponseType Complex Type : AssignedToBooking Element
Description
Flag if this price is assigned to the whole booking
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this price is assigned to the whole booking</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonPriceResponseType Complex Type : AssignedTravellers Element
Description
List of assigned participants for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned participants for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


Price Element

String Schema
Price Element
String Schema > CommonPriceResponseType Complex Type : Price Element
Description
Price amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence Price Element
Overview
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Price" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Price amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


PriceName Element

String Schema
PriceName Element
String Schema > CommonPriceResponseType Complex Type : PriceName Element
Description
Price description
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence PriceName Element
Overview
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="PriceName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Price description</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CommonPriceResponseType Complex Type : Quantity Element
Description
Quantity of price
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity xs:int
Quantity of price
Source
<xs:element name="Quantity" type="xs:int" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


VATAmount Element

String Schema
VATAmount Element
String Schema > CommonPriceResponseType Complex Type : VATAmount Element
Description
VAT amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence VATAmount Element
Overview
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="VATAmount" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>VAT amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


VATIncluded Element

String Schema
VATIncluded Element
String Schema > CommonPriceResponseType Complex Type : VATIncluded Element
Description
Flag if VAT is included or additional
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
VATIncluded optional xs:boolean
Flag if VAT is included or additional
Source
<xs:element name="VATIncluded" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if VAT is included or additional</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


VATPercentage Element

String Schema
VATPercentage Element
String Schema > CommonPriceResponseType Complex Type : VATPercentage Element
Description
VAT percentage
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
VATPercentage optional xs:decimal
VAT percentage
Source
<xs:element name="VATPercentage" type="xs:decimal" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>VAT percentage</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceResponseType Complex Type | String Schema


CommonPriceType Complex Type

String Schema
CommonPriceType Complex Type
String Schema : CommonPriceType Complex Type
Description
Detail price assigned to a participant, service or service-type
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence CommonPriceType Complex Type
Overview
CommonPriceType
Detail price assigned to a participant, service or service-type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:complexType name="CommonPriceType" abstract="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Detail price assigned to a participant, service or service-type</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="PriceName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Price description</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Quantity" type="xs:int" nillable="false">
      <xs:annotation>
        <xs:documentation>Quantity of price</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Price" type="CurrencyAmountType" nillable="false">
      <xs:annotation>
        <xs:documentation>Price amount</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="VATAmount" type="CurrencyAmountType" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>VAT amount</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="VATPercentage" type="xs:decimal" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>VAT percentage</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="VATIncluded" type="xs:boolean" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Flag if VAT is included or additional</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of assigned participants for this detail price</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of assigned services for this detail price</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of assigned service types (e.g. rooms, flight classes) for this detail price</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Flag if this price is assigned to the whole booking</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedServices Element

String Schema
AssignedServices Element
String Schema > CommonPriceType Complex Type : AssignedServices Element
Description
List of assigned services for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServices Element
Overview
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned services for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


AssignedServiceTypes Element

String Schema
AssignedServiceTypes Element
String Schema > CommonPriceType Complex Type : AssignedServiceTypes Element
Description
List of assigned service types (e.g. rooms, flight classes) for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServiceTypes Element
Overview
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned service types (e.g. rooms, flight classes) for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


AssignedToBooking Element

String Schema
AssignedToBooking Element
String Schema > CommonPriceType Complex Type : AssignedToBooking Element
Description
Flag if this price is assigned to the whole booking
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this price is assigned to the whole booking</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonPriceType Complex Type : AssignedTravellers Element
Description
List of assigned participants for this detail price
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigned participants for this detail price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


Price Element

String Schema
Price Element
String Schema > CommonPriceType Complex Type : Price Element
Description
Price amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence Price Element
Overview
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Price" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Price amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


PriceName Element

String Schema
PriceName Element
String Schema > CommonPriceType Complex Type : PriceName Element
Description
Price description
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence PriceName Element
Overview
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="PriceName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Price description</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CommonPriceType Complex Type : Quantity Element
Description
Quantity of price
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity xs:int
Quantity of price
Source
<xs:element name="Quantity" type="xs:int" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


VATAmount Element

String Schema
VATAmount Element
String Schema > CommonPriceType Complex Type : VATAmount Element
Description
VAT amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence VATAmount Element
Overview
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="VATAmount" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>VAT amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


VATIncluded Element

String Schema
VATIncluded Element
String Schema > CommonPriceType Complex Type : VATIncluded Element
Description
Flag if VAT is included or additional
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
VATIncluded optional xs:boolean
Flag if VAT is included or additional
Source
<xs:element name="VATIncluded" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if VAT is included or additional</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


VATPercentage Element

String Schema
VATPercentage Element
String Schema > CommonPriceType Complex Type : VATPercentage Element
Description
VAT percentage
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
VATPercentage optional xs:decimal
VAT percentage
Source
<xs:element name="VATPercentage" type="xs:decimal" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>VAT percentage</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonPriceType Complex Type | String Schema


CommonRoomType Complex Type

String Schema
CommonRoomType Complex Type
String Schema : CommonRoomType Complex Type
Description
Room information
Namespace http://string.drv.de/xmlschema/string
Diagram
AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence CommonRoomType Complex Type
Overview
CommonRoomType
Room information
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:complexType name="CommonRoomType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Room information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType">
      <xs:annotation>
        <xs:documentation>Unique room identifier</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="State" type="BookabilityStateType" nillable="false">
      <xs:annotation>
        <xs:documentation>Room bookability state</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" />
    <xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>List of attributes of this room</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonRoomType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonRoomType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CommonRoomType Complex Type : Attributes Element
Description
List of attributes of this room
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this room</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonRoomType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonRoomType Complex Type : Identifier Element
Description
Unique room identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique room identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique room identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonRoomType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CommonRoomType Complex Type : State Element
Description
Room bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Room bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Room bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonRoomType Complex Type | String Schema


CommonServiceRequestType Complex Type

String Schema
CommonServiceRequestType Complex Type
String Schema : CommonServiceRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CommonServiceRequestType Complex Type
Overview
CommonServiceRequestType Extension of CommonServiceType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
CommonService Element
Details Element
Source
<xs:complexType name="CommonServiceRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceType">
      <xs:sequence>
        <xs:element name="Product" type="ProductCodeRequestType" />
        <xs:element name="RequestedPrices" type="PricesRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Prices of an offer or the prices resulting from an external search</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>List of customer requests</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonServiceRequestType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CommonServiceRequestType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > CommonServiceRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CommonServiceRequestType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonServiceRequestType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CommonServiceRequestType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > CommonServiceRequestType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeRequestType Complex Type
Diagram
Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Source
<xs:element name="Product" type="ProductCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonServiceRequestType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CommonServiceRequestType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


RequestedPrices Element

String Schema
RequestedPrices Element
String Schema > CommonServiceRequestType Complex Type : RequestedPrices Element
Description
Prices of an offer or the prices resulting from an external search
Namespace http://string.drv.de/xmlschema/string
Type
PricesRequestType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element
Overview
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="RequestedPrices" type="PricesRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Prices of an offer or the prices resulting from an external search</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CommonServiceRequestType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CommonServiceRequestType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceRequestType Complex Type | String Schema


CommonServiceResponseType Complex Type

String Schema
CommonServiceResponseType Complex Type
String Schema : CommonServiceResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceType Complex Type
Diagram
Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CommonServiceResponseType Complex Type
Overview
CommonServiceResponseType Extension of CommonServiceType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Used By
CommonService Element
Details Element
Source
<xs:complexType name="CommonServiceResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceType">
      <xs:sequence>
        <xs:element name="Product" type="ProductCodeResponseType" />
        <xs:element name="State" type="BookabilityStateType" nillable="false">
          <xs:annotation>
            <xs:documentation>Service bookability state</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>List of customer requests</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="AdditionalInfos" type="ServicesResponseAdditionalInfoType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Additional infos (e.g. cancellation and modifications conditions)</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AdditionalInfos Element

String Schema
AdditionalInfos Element
String Schema > CommonServiceResponseType Complex Type : AdditionalInfos Element
Description
Additional infos (e.g. cancellation and modifications conditions)
Namespace http://string.drv.de/xmlschema/string
Type
ServicesResponseAdditionalInfoType Complex Type
Diagram
Choice From Element Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element Choice From Element Description Element Sequence Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element
Overview
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="AdditionalInfos" type="ServicesResponseAdditionalInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Additional infos (e.g. cancellation and modifications conditions)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonServiceResponseType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CommonServiceResponseType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > CommonServiceResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CommonServiceResponseType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonServiceResponseType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CommonServiceResponseType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > CommonServiceResponseType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Product" type="ProductCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonServiceResponseType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CommonServiceResponseType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CommonServiceResponseType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CommonServiceResponseType Complex Type : State Element
Description
Service bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Service bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Service bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CommonServiceResponseType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceResponseType Complex Type | String Schema


CommonServiceType Complex Type

String Schema
CommonServiceType Complex Type
String Schema : CommonServiceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CommonServiceType Complex Type
Overview
CommonServiceType
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:complexType name="CommonServiceType" abstract="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType">
      <xs:annotation>
        <xs:documentation>Unique service identifier</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Type" type="xs:token" minOccurs="0">
      <xs:annotation>
        <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="StartDate" type="DateType">
      <xs:annotation>
        <xs:documentation>Start date of the service</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="EndDate" type="DateType" nillable="true">
      <xs:annotation>
        <xs:documentation>End Date of the service</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Quantity of the service</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>List of attributes of this service</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonServiceType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CommonServiceType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CommonServiceType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonServiceType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CommonServiceType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CommonServiceType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CommonServiceType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CommonServiceType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonServiceType Complex Type | String Schema


CommonTariffDataType Complex Type

String Schema
CommonTariffDataType Complex Type
String Schema : CommonTariffDataType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence CommonTariffDataType Complex Type
Overview
CommonTariffDataType
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Source
<xs:complexType name="CommonTariffDataType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" />
    <xs:element name="AssignedLegs" type="IdentifiersType" nillable="true" minOccurs="0" />
    <xs:element name="AssignedSegments" type="IdentifiersType" nillable="true" minOccurs="0" />
    <xs:element name="BaggageInfo" type="BaggageInfoType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedLegs Element

String Schema
AssignedLegs Element
String Schema > CommonTariffDataType Complex Type : AssignedLegs Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedLegs Element
Overview
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedLegs" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffDataType Complex Type | String Schema


AssignedSegments Element

String Schema
AssignedSegments Element
String Schema > CommonTariffDataType Complex Type : AssignedSegments Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedSegments Element
Overview
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedSegments" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffDataType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonTariffDataType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffDataType Complex Type | String Schema


BaggageInfo Element

String Schema
BaggageInfo Element
String Schema > CommonTariffDataType Complex Type : BaggageInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
BaggageInfoType Complex Type
Diagram
Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element
Overview
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Source
<xs:element name="BaggageInfo" type="BaggageInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffDataType Complex Type | String Schema


CommonTariffRequestType Complex Type

String Schema
CommonTariffRequestType Complex Type
String Schema : CommonTariffRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTariffDataType Complex Type
Diagram
Code Element Sequence Meal Element Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence CommonTariffRequestType Complex Type
Overview
CommonTariffRequestType Extension of CommonTariffDataType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
Used By
TariffDetail Element
Source
<xs:complexType name="CommonTariffRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTariffDataType">
      <xs:sequence>
        <xs:element name="Meal" type="MealRequestType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedLegs Element

String Schema
AssignedLegs Element
String Schema > CommonTariffRequestType Complex Type : AssignedLegs Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedLegs Element
Overview
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedLegs" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffRequestType Complex Type | String Schema


AssignedSegments Element

String Schema
AssignedSegments Element
String Schema > CommonTariffRequestType Complex Type : AssignedSegments Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedSegments Element
Overview
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedSegments" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffRequestType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonTariffRequestType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffRequestType Complex Type | String Schema


BaggageInfo Element

String Schema
BaggageInfo Element
String Schema > CommonTariffRequestType Complex Type : BaggageInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
BaggageInfoType Complex Type
Diagram
Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element
Overview
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Source
<xs:element name="BaggageInfo" type="BaggageInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffRequestType Complex Type | String Schema


Meal Element

String Schema
Meal Element
String Schema > CommonTariffRequestType Complex Type : Meal Element
Namespace http://string.drv.de/xmlschema/string
Type
MealRequestType Complex Type
Diagram
Code Element Sequence Meal Element
Overview
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="Meal" type="MealRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffRequestType Complex Type | String Schema


CommonTariffResponseType Complex Type

String Schema
CommonTariffResponseType Complex Type
String Schema : CommonTariffResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTariffDataType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence Meal Element Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence CommonTariffResponseType Complex Type
Overview
CommonTariffResponseType Extension of CommonTariffDataType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
TariffDetail Element
Source
<xs:complexType name="CommonTariffResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTariffDataType">
      <xs:sequence>
        <xs:element name="Meal" type="MealResponseType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedLegs Element

String Schema
AssignedLegs Element
String Schema > CommonTariffResponseType Complex Type : AssignedLegs Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedLegs Element
Overview
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedLegs" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffResponseType Complex Type | String Schema


AssignedSegments Element

String Schema
AssignedSegments Element
String Schema > CommonTariffResponseType Complex Type : AssignedSegments Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedSegments Element
Overview
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedSegments" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CommonTariffResponseType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffResponseType Complex Type | String Schema


BaggageInfo Element

String Schema
BaggageInfo Element
String Schema > CommonTariffResponseType Complex Type : BaggageInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
BaggageInfoType Complex Type
Diagram
Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element
Overview
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Source
<xs:element name="BaggageInfo" type="BaggageInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffResponseType Complex Type | String Schema


Meal Element

String Schema
Meal Element
String Schema > CommonTariffResponseType Complex Type : Meal Element
Namespace http://string.drv.de/xmlschema/string
Type
MealResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence Meal Element
Overview
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Meal" type="MealResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTariffResponseType Complex Type | String Schema


CommonTotalBookingPriceType Complex Type

String Schema
CommonTotalBookingPriceType Complex Type
String Schema : CommonTotalBookingPriceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTotalPriceType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence CommonTotalBookingPriceType Complex Type
Overview
CommonTotalBookingPriceType Extension of CommonTotalPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Used By
BookingPrice Element
Source
<xs:complexType name="CommonTotalBookingPriceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTotalPriceType" />
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


RecommendedRetailPrice Element

String Schema
RecommendedRetailPrice Element
String Schema > CommonTotalBookingPriceType Complex Type : RecommendedRetailPrice Element
Description
Recommended price from touroperator
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence RecommendedRetailPrice Element
Overview
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="RecommendedRetailPrice" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Recommended price from touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalBookingPriceType Complex Type | String Schema


TotalIncentivesPrice Element

String Schema
TotalIncentivesPrice Element
String Schema > CommonTotalBookingPriceType Complex Type : TotalIncentivesPrice Element
Description
Total amount of in centivese
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element
Overview
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalIncentivesPrice" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total amount of in  centivese</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalBookingPriceType Complex Type | String Schema


TotalSalesPrice Element

String Schema
TotalSalesPrice Element
String Schema > CommonTotalBookingPriceType Complex Type : TotalSalesPrice Element
Description
Total sales amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element
Overview
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesPrice" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalBookingPriceType Complex Type | String Schema


TotalSalesTaxes Element

String Schema
TotalSalesTaxes Element
String Schema > CommonTotalBookingPriceType Complex Type : TotalSalesTaxes Element
Description
Total sales taxes included in the sales price
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesTaxes Element
Overview
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesTaxes" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales taxes included in the sales price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalBookingPriceType Complex Type | String Schema


CommonTotalPriceType Complex Type

String Schema
CommonTotalPriceType Complex Type
String Schema : CommonTotalPriceType Complex Type
Description
Total price assigned to a participant, service or service-type
Namespace http://string.drv.de/xmlschema/string
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence CommonTotalPriceType Complex Type
Overview
CommonTotalPriceType
Total price assigned to a participant, service or service-type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:complexType name="CommonTotalPriceType" abstract="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total price assigned to a participant, service or service-type</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="TotalSalesPrice" type="CurrencyAmountType" nillable="false">
      <xs:annotation>
        <xs:documentation>Total sales amount</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="RecommendedRetailPrice" type="CurrencyAmountType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Recommended price from touroperator</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="TotalSalesTaxes" type="CurrencyAmountType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Total sales taxes included in the sales price</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="TotalIncentivesPrice" type="CurrencyAmountType" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Total amount of in  centivese</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


RecommendedRetailPrice Element

String Schema
RecommendedRetailPrice Element
String Schema > CommonTotalPriceType Complex Type : RecommendedRetailPrice Element
Description
Recommended price from touroperator
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence RecommendedRetailPrice Element
Overview
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="RecommendedRetailPrice" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Recommended price from touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalPriceType Complex Type | String Schema


TotalIncentivesPrice Element

String Schema
TotalIncentivesPrice Element
String Schema > CommonTotalPriceType Complex Type : TotalIncentivesPrice Element
Description
Total amount of in centivese
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element
Overview
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalIncentivesPrice" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total amount of in  centivese</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalPriceType Complex Type | String Schema


TotalSalesPrice Element

String Schema
TotalSalesPrice Element
String Schema > CommonTotalPriceType Complex Type : TotalSalesPrice Element
Description
Total sales amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element
Overview
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesPrice" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalPriceType Complex Type | String Schema


TotalSalesTaxes Element

String Schema
TotalSalesTaxes Element
String Schema > CommonTotalPriceType Complex Type : TotalSalesTaxes Element
Description
Total sales taxes included in the sales price
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesTaxes Element
Overview
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesTaxes" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales taxes included in the sales price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalPriceType Complex Type | String Schema


CommonTotalServicePriceType Complex Type

String Schema
CommonTotalServicePriceType Complex Type
String Schema : CommonTotalServicePriceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTotalPriceType Complex Type
Diagram
AssignedService Element Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence CommonTotalServicePriceType Complex Type
Overview
CommonTotalServicePriceType Extension of CommonTotalPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
Used By
ServicePrice Element
Source
<xs:complexType name="CommonTotalServicePriceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTotalPriceType">
      <xs:sequence>
        <xs:element name="AssignedService" type="IdentifierType" nillable="false">
          <xs:annotation>
            <xs:documentation>Reference to a servicer or package in case that the price is included in another component</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedService Element

String Schema
AssignedService Element
String Schema > CommonTotalServicePriceType Complex Type : AssignedService Element
Description
Reference to a servicer or package in case that the price is included in another component
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
Source
<xs:element name="AssignedService" type="IdentifierType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a servicer or package in case that the price is included in another component</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServicePriceType Complex Type | String Schema


RecommendedRetailPrice Element

String Schema
RecommendedRetailPrice Element
String Schema > CommonTotalServicePriceType Complex Type : RecommendedRetailPrice Element
Description
Recommended price from touroperator
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence RecommendedRetailPrice Element
Overview
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="RecommendedRetailPrice" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Recommended price from touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServicePriceType Complex Type | String Schema


TotalIncentivesPrice Element

String Schema
TotalIncentivesPrice Element
String Schema > CommonTotalServicePriceType Complex Type : TotalIncentivesPrice Element
Description
Total amount of in centivese
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element
Overview
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalIncentivesPrice" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total amount of in  centivese</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServicePriceType Complex Type | String Schema


TotalSalesPrice Element

String Schema
TotalSalesPrice Element
String Schema > CommonTotalServicePriceType Complex Type : TotalSalesPrice Element
Description
Total sales amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element
Overview
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesPrice" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServicePriceType Complex Type | String Schema


TotalSalesTaxes Element

String Schema
TotalSalesTaxes Element
String Schema > CommonTotalServicePriceType Complex Type : TotalSalesTaxes Element
Description
Total sales taxes included in the sales price
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesTaxes Element
Overview
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesTaxes" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales taxes included in the sales price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServicePriceType Complex Type | String Schema


CommonTotalServiceTypePriceType Complex Type

String Schema
CommonTotalServiceTypePriceType Complex Type
String Schema : CommonTotalServiceTypePriceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTotalPriceType Complex Type
Diagram
AssignedServiceType Element Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence CommonTotalServiceTypePriceType Complex Type
Overview
CommonTotalServiceTypePriceType Extension of CommonTotalPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
Used By
ServiceTypePrice Element
Source
<xs:complexType name="CommonTotalServiceTypePriceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTotalPriceType">
      <xs:sequence>
        <xs:element name="AssignedServiceType" type="IdentifierType" nillable="false">
          <xs:annotation>
            <xs:documentation>Reference to a service type (e.g. room, flight class)</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedServiceType Element

String Schema
AssignedServiceType Element
String Schema > CommonTotalServiceTypePriceType Complex Type : AssignedServiceType Element
Description
Reference to a service type (e.g. room, flight class)
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
Source
<xs:element name="AssignedServiceType" type="IdentifierType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a service type (e.g. room, flight class)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServiceTypePriceType Complex Type | String Schema


RecommendedRetailPrice Element

String Schema
RecommendedRetailPrice Element
String Schema > CommonTotalServiceTypePriceType Complex Type : RecommendedRetailPrice Element
Description
Recommended price from touroperator
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence RecommendedRetailPrice Element
Overview
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="RecommendedRetailPrice" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Recommended price from touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServiceTypePriceType Complex Type | String Schema


TotalIncentivesPrice Element

String Schema
TotalIncentivesPrice Element
String Schema > CommonTotalServiceTypePriceType Complex Type : TotalIncentivesPrice Element
Description
Total amount of in centivese
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element
Overview
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalIncentivesPrice" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total amount of in  centivese</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServiceTypePriceType Complex Type | String Schema


TotalSalesPrice Element

String Schema
TotalSalesPrice Element
String Schema > CommonTotalServiceTypePriceType Complex Type : TotalSalesPrice Element
Description
Total sales amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element
Overview
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesPrice" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServiceTypePriceType Complex Type | String Schema


TotalSalesTaxes Element

String Schema
TotalSalesTaxes Element
String Schema > CommonTotalServiceTypePriceType Complex Type : TotalSalesTaxes Element
Description
Total sales taxes included in the sales price
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesTaxes Element
Overview
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesTaxes" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales taxes included in the sales price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalServiceTypePriceType Complex Type | String Schema


CommonTotalTravellerPriceType Complex Type

String Schema
CommonTotalTravellerPriceType Complex Type
String Schema : CommonTotalTravellerPriceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTotalPriceType Complex Type
Diagram
AssignedTraveller Element Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence CommonTotalTravellerPriceType Complex Type
Overview
CommonTotalTravellerPriceType Extension of CommonTotalPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
Used By
TravellerPrice Element
Source
<xs:complexType name="CommonTotalTravellerPriceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTotalPriceType">
      <xs:sequence>
        <xs:element name="AssignedTraveller" type="IdentifierType" nillable="false">
          <xs:annotation>
            <xs:documentation>Reference to a traveller</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTraveller Element

String Schema
AssignedTraveller Element
String Schema > CommonTotalTravellerPriceType Complex Type : AssignedTraveller Element
Description
Reference to a traveller
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
Source
<xs:element name="AssignedTraveller" type="IdentifierType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a traveller</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalTravellerPriceType Complex Type | String Schema


RecommendedRetailPrice Element

String Schema
RecommendedRetailPrice Element
String Schema > CommonTotalTravellerPriceType Complex Type : RecommendedRetailPrice Element
Description
Recommended price from touroperator
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence RecommendedRetailPrice Element
Overview
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="RecommendedRetailPrice" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Recommended price from touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalTravellerPriceType Complex Type | String Schema


TotalIncentivesPrice Element

String Schema
TotalIncentivesPrice Element
String Schema > CommonTotalTravellerPriceType Complex Type : TotalIncentivesPrice Element
Description
Total amount of in centivese
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element
Overview
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalIncentivesPrice" type="CurrencyAmountType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total amount of in  centivese</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalTravellerPriceType Complex Type | String Schema


TotalSalesPrice Element

String Schema
TotalSalesPrice Element
String Schema > CommonTotalTravellerPriceType Complex Type : TotalSalesPrice Element
Description
Total sales amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element
Overview
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesPrice" type="CurrencyAmountType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalTravellerPriceType Complex Type | String Schema


TotalSalesTaxes Element

String Schema
TotalSalesTaxes Element
String Schema > CommonTotalTravellerPriceType Complex Type : TotalSalesTaxes Element
Description
Total sales taxes included in the sales price
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesTaxes Element
Overview
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesTaxes" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales taxes included in the sales price</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTotalTravellerPriceType Complex Type | String Schema


CommonTravellerRequestType Complex Type

String Schema
CommonTravellerRequestType Complex Type
String Schema : CommonTravellerRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTravellerType Complex Type
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence CommonTravellerRequestType Complex Type
Overview
CommonTravellerRequestType Extension of CommonTravellerType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Used By
Traveller Element
Source
<xs:complexType name="CommonTravellerRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTravellerType" />
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Address Element

String Schema
Address Element
String Schema > CommonTravellerRequestType Complex Type : Address Element
Namespace http://string.drv.de/xmlschema/string
Type
AddressType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element
Overview
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Address" type="AddressType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


AgeCategory Element

String Schema
AgeCategory Element
String Schema > CommonTravellerRequestType Complex Type : AgeCategory Element
Namespace http://string.drv.de/xmlschema/string
Type
AgeCategoryType Simple Type
Overview
AgeCategory optional AgeCategoryType Simple Type
Source
<xs:element name="AgeCategory" type="AgeCategoryType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


BirthDate Element

String Schema
BirthDate Element
String Schema > CommonTravellerRequestType Complex Type : BirthDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
BirthDate optional DateType Simple Type
Source
<xs:element name="BirthDate" type="DateType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


ClientNumber Element

String Schema
ClientNumber Element
String Schema > CommonTravellerRequestType Complex Type : ClientNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ClientNumber optional xs:string
Source
<xs:element name="ClientNumber" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


ContactDetails Element

String Schema
ContactDetails Element
String Schema > CommonTravellerRequestType Complex Type : ContactDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
ContactDetailsType Complex Type
Diagram
Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element
Overview
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Source
<xs:element name="ContactDetails" type="ContactDetailsType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


ESTA_Information Element

String Schema
ESTA_Information Element
String Schema > CommonTravellerRequestType Complex Type : ESTA_Information Element
Namespace http://string.drv.de/xmlschema/string
Type
AdditionalESTAInformationType Complex Type
Diagram
Mail Element Phone Element CountryCode Element Name Element Sequence Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element
Overview
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Source
<xs:element name="ESTA_Information" type="AdditionalESTAInformationType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


Gender Element

String Schema
Gender Element
String Schema > CommonTravellerRequestType Complex Type : Gender Element
Namespace http://string.drv.de/xmlschema/string
Type
GenderType Simple Type
Overview
Gender optional GenderType Simple Type
Source
<xs:element name="Gender" type="GenderType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonTravellerRequestType Complex Type : Identifier Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


Passport Element

String Schema
Passport Element
String Schema > CommonTravellerRequestType Complex Type : Passport Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportType Complex Type
Diagram
Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element
Overview
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
Source
<xs:element name="Passport" type="PassportType" minOccurs="0" maxOccurs="unbounded" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


Prename Element

String Schema
Prename Element
String Schema > CommonTravellerRequestType Complex Type : Prename Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Prename optional xs:string
Source
<xs:element name="Prename" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


Salutation Element

String Schema
Salutation Element
String Schema > CommonTravellerRequestType Complex Type : Salutation Element
Namespace http://string.drv.de/xmlschema/string
Type
SalutationType Simple Type
Overview
Salutation optional SalutationType Simple Type
Source
<xs:element name="Salutation" type="SalutationType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


Surname Element

String Schema
Surname Element
String Schema > CommonTravellerRequestType Complex Type : Surname Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Surname optional xs:string
Source
<xs:element name="Surname" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerRequestType Complex Type | String Schema


CommonTravellerResponseType Complex Type

String Schema
CommonTravellerResponseType Complex Type
String Schema : CommonTravellerResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonTravellerType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence CommonTravellerResponseType Complex Type
Overview
CommonTravellerResponseType Extension of CommonTravellerType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Used By
Traveller Element
Source
<xs:complexType name="CommonTravellerResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonTravellerType">
      <xs:sequence>
        <xs:element name="TotalSalesPrice" type="CurrencyAmountType" minOccurs="0" maxOccurs="1" nillable="true">
          <xs:annotation>
            <xs:documentation>Total sales amount</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Address Element

String Schema
Address Element
String Schema > CommonTravellerResponseType Complex Type : Address Element
Namespace http://string.drv.de/xmlschema/string
Type
AddressType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element
Overview
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Address" type="AddressType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


AgeCategory Element

String Schema
AgeCategory Element
String Schema > CommonTravellerResponseType Complex Type : AgeCategory Element
Namespace http://string.drv.de/xmlschema/string
Type
AgeCategoryType Simple Type
Overview
AgeCategory optional AgeCategoryType Simple Type
Source
<xs:element name="AgeCategory" type="AgeCategoryType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


BirthDate Element

String Schema
BirthDate Element
String Schema > CommonTravellerResponseType Complex Type : BirthDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
BirthDate optional DateType Simple Type
Source
<xs:element name="BirthDate" type="DateType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


ClientNumber Element

String Schema
ClientNumber Element
String Schema > CommonTravellerResponseType Complex Type : ClientNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ClientNumber optional xs:string
Source
<xs:element name="ClientNumber" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


ContactDetails Element

String Schema
ContactDetails Element
String Schema > CommonTravellerResponseType Complex Type : ContactDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
ContactDetailsType Complex Type
Diagram
Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element
Overview
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Source
<xs:element name="ContactDetails" type="ContactDetailsType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


ESTA_Information Element

String Schema
ESTA_Information Element
String Schema > CommonTravellerResponseType Complex Type : ESTA_Information Element
Namespace http://string.drv.de/xmlschema/string
Type
AdditionalESTAInformationType Complex Type
Diagram
Mail Element Phone Element CountryCode Element Name Element Sequence Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element
Overview
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Source
<xs:element name="ESTA_Information" type="AdditionalESTAInformationType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


Gender Element

String Schema
Gender Element
String Schema > CommonTravellerResponseType Complex Type : Gender Element
Namespace http://string.drv.de/xmlschema/string
Type
GenderType Simple Type
Overview
Gender optional GenderType Simple Type
Source
<xs:element name="Gender" type="GenderType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonTravellerResponseType Complex Type : Identifier Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


Passport Element

String Schema
Passport Element
String Schema > CommonTravellerResponseType Complex Type : Passport Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportType Complex Type
Diagram
Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element
Overview
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
Source
<xs:element name="Passport" type="PassportType" minOccurs="0" maxOccurs="unbounded" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


Prename Element

String Schema
Prename Element
String Schema > CommonTravellerResponseType Complex Type : Prename Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Prename optional xs:string
Source
<xs:element name="Prename" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


Salutation Element

String Schema
Salutation Element
String Schema > CommonTravellerResponseType Complex Type : Salutation Element
Namespace http://string.drv.de/xmlschema/string
Type
SalutationType Simple Type
Overview
Salutation optional SalutationType Simple Type
Source
<xs:element name="Salutation" type="SalutationType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


Surname Element

String Schema
Surname Element
String Schema > CommonTravellerResponseType Complex Type : Surname Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Surname optional xs:string
Source
<xs:element name="Surname" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerResponseType Complex Type | String Schema


TotalSalesPrice Element

String Schema
TotalSalesPrice Element
String Schema > CommonTravellerResponseType Complex Type : TotalSalesPrice Element
Description
Total sales amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element
Overview
TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalSalesPrice" type="CurrencyAmountType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Total sales amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CommonTravellerResponseType Complex Type | String Schema


CommonTravellerType Complex Type

String Schema
CommonTravellerType Complex Type
String Schema : CommonTravellerType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence CommonTravellerType Complex Type
Overview
CommonTravellerType
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Used By
InvoiceAddress Element
DeliveryAddress Element
BookingOwnerAddress Element
EmergencyAddress Element
Source
<xs:complexType name="CommonTravellerType" abstract="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType" />
    <xs:element name="Surname" type="xs:string" minOccurs="0" />
    <xs:element name="Prename" type="xs:string" minOccurs="0" />
    <xs:element name="Salutation" type="SalutationType" nillable="true" minOccurs="0" />
    <xs:element name="Gender" type="GenderType" nillable="true" minOccurs="0" />
    <xs:element name="AgeCategory" type="AgeCategoryType" nillable="true" minOccurs="0" />
    <xs:element name="BirthDate" type="DateType" minOccurs="0" />
    <xs:element name="ContactDetails" type="ContactDetailsType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Passport" type="PassportType" minOccurs="0" maxOccurs="unbounded" nillable="true" />
    <xs:element name="ESTA_Information" type="AdditionalESTAInformationType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Address" type="AddressType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="ClientNumber" type="xs:string" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Address Element

String Schema
Address Element
String Schema > CommonTravellerType Complex Type : Address Element
Namespace http://string.drv.de/xmlschema/string
Type
AddressType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element
Overview
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Address" type="AddressType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


AgeCategory Element

String Schema
AgeCategory Element
String Schema > CommonTravellerType Complex Type : AgeCategory Element
Namespace http://string.drv.de/xmlschema/string
Type
AgeCategoryType Simple Type
Overview
AgeCategory optional AgeCategoryType Simple Type
Source
<xs:element name="AgeCategory" type="AgeCategoryType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


BirthDate Element

String Schema
BirthDate Element
String Schema > CommonTravellerType Complex Type : BirthDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
BirthDate optional DateType Simple Type
Source
<xs:element name="BirthDate" type="DateType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


ClientNumber Element

String Schema
ClientNumber Element
String Schema > CommonTravellerType Complex Type : ClientNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
ClientNumber optional xs:string
Source
<xs:element name="ClientNumber" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


ContactDetails Element

String Schema
ContactDetails Element
String Schema > CommonTravellerType Complex Type : ContactDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
ContactDetailsType Complex Type
Diagram
Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element
Overview
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Source
<xs:element name="ContactDetails" type="ContactDetailsType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


ESTA_Information Element

String Schema
ESTA_Information Element
String Schema > CommonTravellerType Complex Type : ESTA_Information Element
Namespace http://string.drv.de/xmlschema/string
Type
AdditionalESTAInformationType Complex Type
Diagram
Mail Element Phone Element CountryCode Element Name Element Sequence Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element
Overview
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Source
<xs:element name="ESTA_Information" type="AdditionalESTAInformationType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


Gender Element

String Schema
Gender Element
String Schema > CommonTravellerType Complex Type : Gender Element
Namespace http://string.drv.de/xmlschema/string
Type
GenderType Simple Type
Overview
Gender optional GenderType Simple Type
Source
<xs:element name="Gender" type="GenderType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CommonTravellerType Complex Type : Identifier Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


Passport Element

String Schema
Passport Element
String Schema > CommonTravellerType Complex Type : Passport Element
Namespace http://string.drv.de/xmlschema/string
Type
PassportType Complex Type
Diagram
Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element
Overview
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
Source
<xs:element name="Passport" type="PassportType" minOccurs="0" maxOccurs="unbounded" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


Prename Element

String Schema
Prename Element
String Schema > CommonTravellerType Complex Type : Prename Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Prename optional xs:string
Source
<xs:element name="Prename" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


Salutation Element

String Schema
Salutation Element
String Schema > CommonTravellerType Complex Type : Salutation Element
Namespace http://string.drv.de/xmlschema/string
Type
SalutationType Simple Type
Overview
Salutation optional SalutationType Simple Type
Source
<xs:element name="Salutation" type="SalutationType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


Surname Element

String Schema
Surname Element
String Schema > CommonTravellerType Complex Type : Surname Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Surname optional xs:string
Source
<xs:element name="Surname" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CommonTravellerType Complex Type | String Schema


CompanyNameType Complex Type

String Schema
CompanyNameType Complex Type
String Schema : CompanyNameType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyNameType Complex Type
Overview
CompanyNameType
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Used By
CompanyName Element
CompanyName Element
Source
<xs:complexType name="CompanyNameType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="ShortName" minOccurs="0" />
    <xs:element name="Code" minOccurs="0" />
    <xs:element name="OrganisationLevelID" type="xs:int" minOccurs="0">
      <xs:annotation>
        <xs:documentation>As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization
Only 1 digit LevelIds are provided</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > CompanyNameType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Overview
Code optional
Source
<xs:element name="Code" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CompanyNameType Complex Type | String Schema


OrganisationLevelID Element

String Schema
OrganisationLevelID Element
String Schema > CompanyNameType Complex Type : OrganisationLevelID Element
Description
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="OrganisationLevelID" type="xs:int" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization
Only 1 digit LevelIds are provided</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CompanyNameType Complex Type | String Schema


ShortName Element

String Schema
ShortName Element
String Schema > CompanyNameType Complex Type : ShortName Element
Namespace http://string.drv.de/xmlschema/string
Overview
ShortName optional
Source
<xs:element name="ShortName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CompanyNameType Complex Type | String Schema


ConfigurationRequestType Complex Type

String Schema
ConfigurationRequestType Complex Type
String Schema : ConfigurationRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Sequence ConfigurationRequestType Complex Type
Overview
ConfigurationRequestType
Sequence
Used By
ConfigurationRequest Element
Source
<xs:complexType name="ConfigurationRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence></xs:sequence>
</xs:complexType>
See Also
String Schema


ConfigurationResponseType Complex Type

String Schema
ConfigurationResponseType Complex Type
String Schema : ConfigurationResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Value Element Key Element Sequence Setting Element Sequence ConfigurationResponseType Complex Type
Overview
ConfigurationResponseType
Sequence
Setting 0..∞ KeyValueType Complex Type
Sequence
Key xs:token
Value xs:string
Used By
ConfigurationResponse Element
Source
<xs:complexType name="ConfigurationResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Setting" type="KeyValueType" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Setting Element

String Schema
Setting Element
String Schema > ConfigurationResponseType Complex Type : Setting Element
Namespace http://string.drv.de/xmlschema/string
Type
KeyValueType Complex Type
Diagram
Value Element Key Element Sequence Setting Element
Overview
Setting 0..∞ KeyValueType Complex Type
Sequence
Key xs:token
Value xs:string
Source
<xs:element name="Setting" type="KeyValueType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ConfigurationResponseType Complex Type | String Schema


ContactDetailsType Complex Type

String Schema
ContactDetailsType Complex Type
String Schema : ContactDetailsType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetailsType Complex Type
Overview
ContactDetailsType
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Used By
ContactDetails Element
ContactDetails Element
ContactDetails Element
Source
<xs:complexType name="ContactDetailsType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Mail" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Phone" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Mobile" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Emergency" type="xs:boolean" minOccurs="0" maxOccurs="1" nillable="true">
      <xs:annotation>
        <xs:documentation>Flag that indicates if this contact type should be used in case of an emergency</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Emergency Element

String Schema
Emergency Element
String Schema > ContactDetailsType Complex Type : Emergency Element
Description
Flag that indicates if this contact type should be used in case of an emergency
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Source
<xs:element name="Emergency" type="xs:boolean" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag that indicates if this contact type should be used in case of an emergency</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ContactDetailsType Complex Type | String Schema


Mail Element

String Schema
Mail Element
String Schema > ContactDetailsType Complex Type : Mail Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Mail optional xs:string
Source
<xs:element name="Mail" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ContactDetailsType Complex Type | String Schema


Mobile Element

String Schema
Mobile Element
String Schema > ContactDetailsType Complex Type : Mobile Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Mobile optional xs:string
Source
<xs:element name="Mobile" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ContactDetailsType Complex Type | String Schema


Phone Element

String Schema
Phone Element
String Schema > ContactDetailsType Complex Type : Phone Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Phone optional xs:string
Source
<xs:element name="Phone" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ContactDetailsType Complex Type | String Schema


CountryType Complex Type

String Schema
CountryType Complex Type
String Schema : CountryType Complex Type
Description
Type for country information
Namespace http://string.drv.de/xmlschema/string
Diagram
CountryCode Element Name Element Sequence CountryType Complex Type
Overview
CountryType
Type for country information
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Used By
Country Element
Country Element
Country Element
CountryOfBirth Element
Source
<xs:complexType name="CountryType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type for country information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Name" type="xs:string">
      <xs:annotation>
        <xs:documentation>Name of the country</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="CountryCode" type="CountryCodeType">
      <xs:annotation>
        <xs:documentation>ISO code</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CountryCode Element

String Schema
CountryCode Element
String Schema > CountryType Complex Type : CountryCode Element
Description
ISO code
Namespace http://string.drv.de/xmlschema/string
Type
CountryCodeType Simple Type
Overview
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="CountryCode" type="CountryCodeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ISO code</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CountryType Complex Type | String Schema


Name Element

String Schema
Name Element
String Schema > CountryType Complex Type : Name Element
Description
Name of the country
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Name xs:string
Name of the country
Source
<xs:element name="Name" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Name of the country</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CountryType Complex Type | String Schema


CruiseRequestType Complex Type

String Schema
CruiseRequestType Complex Type
String Schema : CruiseRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceRequestType Complex Type
Diagram
Data Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CruiseRequestType Complex Type
Overview
CruiseRequestType Extension of CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonCruiseDataType Complex Type
Source
<xs:complexType name="CruiseRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceRequestType">
      <xs:sequence>
        <xs:element name="Data" type="CommonCruiseDataType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CruiseRequestType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CruiseRequestType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > CruiseRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


Data Element

String Schema
Data Element
String Schema > CruiseRequestType Complex Type : Data Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonCruiseDataType Complex Type
Overview
Data optional CommonCruiseDataType Complex Type
Source
<xs:element name="Data" type="CommonCruiseDataType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CruiseRequestType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CruiseRequestType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CruiseRequestType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CruiseRequestType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > CruiseRequestType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeRequestType Complex Type
Diagram
Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Source
<xs:element name="Product" type="ProductCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CruiseRequestType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CruiseRequestType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


RequestedPrices Element

String Schema
RequestedPrices Element
String Schema > CruiseRequestType Complex Type : RequestedPrices Element
Description
Prices of an offer or the prices resulting from an external search
Namespace http://string.drv.de/xmlschema/string
Type
PricesRequestType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element
Overview
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="RequestedPrices" type="PricesRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Prices of an offer or the prices resulting from an external search</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CruiseRequestType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CruiseRequestType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseRequestType Complex Type | String Schema


CruiseResponseType Complex Type

String Schema
CruiseResponseType Complex Type
String Schema : CruiseResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceResponseType Complex Type
Diagram
Data Element Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CruiseResponseType Complex Type
Overview
CruiseResponseType Extension of CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonCruiseDataType Complex Type
Source
<xs:complexType name="CruiseResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceResponseType">
      <xs:sequence>
        <xs:element name="Data" type="CommonCruiseDataType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AdditionalInfos Element

String Schema
AdditionalInfos Element
String Schema > CruiseResponseType Complex Type : AdditionalInfos Element
Description
Additional infos (e.g. cancellation and modifications conditions)
Namespace http://string.drv.de/xmlschema/string
Type
ServicesResponseAdditionalInfoType Complex Type
Diagram
Choice From Element Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element Choice From Element Description Element Sequence Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element
Overview
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="AdditionalInfos" type="ServicesResponseAdditionalInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Additional infos (e.g. cancellation and modifications conditions)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CruiseResponseType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > CruiseResponseType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > CruiseResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


Data Element

String Schema
Data Element
String Schema > CruiseResponseType Complex Type : Data Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonCruiseDataType Complex Type
Overview
Data optional CommonCruiseDataType Complex Type
Source
<xs:element name="Data" type="CommonCruiseDataType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CruiseResponseType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > CruiseResponseType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > CruiseResponseType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > CruiseResponseType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > CruiseResponseType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Product" type="ProductCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CruiseResponseType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > CruiseResponseType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > CruiseResponseType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CruiseResponseType Complex Type : State Element
Description
Service bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Service bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Service bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > CruiseResponseType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CruiseResponseType Complex Type | String Schema


CurrencyAmountType Complex Type

String Schema
CurrencyAmountType Complex Type
String Schema : CurrencyAmountType Complex Type
Description
Amount with according currency
Namespace http://string.drv.de/xmlschema/string
Diagram
Currency Element Amount Element Sequence CurrencyAmountType Complex Type
Overview
CurrencyAmountType
Amount with according currency
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Used By
Price Element
VATAmount Element
TotalSalesPrice Element
RecommendedRetailPrice Element
TotalSalesTaxes Element
TotalIncentivesPrice Element
TotalSalesPrice Element
RecommendedRetailPrice Element
TotalSalesTaxes Element
TotalIncentivesPrice Element
TotalSalesPrice Element
RecommendedRetailPrice Element
TotalSalesTaxes Element
TotalIncentivesPrice Element
TotalSalesPrice Element
RecommendedRetailPrice Element
TotalSalesTaxes Element
TotalIncentivesPrice Element
TotalSalesPrice Element
RecommendedRetailPrice Element
TotalSalesTaxes Element
TotalIncentivesPrice Element
Price Element
VATAmount Element
Price Element
VATAmount Element
Amount Element
TotalSalesPrice Element
Source
<xs:complexType name="CurrencyAmountType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Amount with according currency</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Amount" type="xs:decimal" nillable="false" />
    <xs:element name="Currency" type="CurrencyCodeType" nillable="false" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Amount Element

String Schema
Amount Element
String Schema > CurrencyAmountType Complex Type : Amount Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
Amount xs:decimal
Source
<xs:element name="Amount" type="xs:decimal" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CurrencyAmountType Complex Type | String Schema


Currency Element

String Schema
Currency Element
String Schema > CurrencyAmountType Complex Type : Currency Element
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyCodeType Simple Type
Overview
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Currency" type="CurrencyCodeType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CurrencyAmountType Complex Type | String Schema


CustomerRequestListRequestType Complex Type

String Schema
CustomerRequestListRequestType Complex Type
String Schema : CustomerRequestListRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequest Element Sequence CustomerRequestListRequestType Complex Type
Overview
CustomerRequestListRequestType
Sequence
CustomerRequest 0..∞ CustomerRequestRequestType Complex Type
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:complexType name="CustomerRequestListRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="CustomerRequest" type="CustomerRequestRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CustomerRequest Element

String Schema
CustomerRequest Element
String Schema > CustomerRequestListRequestType Complex Type : CustomerRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequest Element
Overview
CustomerRequest 0..∞ CustomerRequestRequestType Complex Type
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequest" type="CustomerRequestRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CustomerRequestListRequestType Complex Type | String Schema


CustomerRequestListResponseType Complex Type

String Schema
CustomerRequestListResponseType Complex Type
String Schema : CustomerRequestListResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequest Element Sequence CustomerRequestListResponseType Complex Type
Overview
CustomerRequestListResponseType
Sequence
CustomerRequest 0..∞ CustomerRequestResponseType Complex Type
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:complexType name="CustomerRequestListResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="CustomerRequest" type="CustomerRequestResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CustomerRequest Element

String Schema
CustomerRequest Element
String Schema > CustomerRequestListResponseType Complex Type : CustomerRequest Element
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequest Element
Overview
CustomerRequest 0..∞ CustomerRequestResponseType Complex Type
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequest" type="CustomerRequestResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CustomerRequestListResponseType Complex Type | String Schema


CustomerRequestRequestType Complex Type

String Schema
CustomerRequestRequestType Complex Type
String Schema : CustomerRequestRequestType Complex Type
Description
Customer request
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequestRequestType Complex Type
Overview
CustomerRequestRequestType
Customer request
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequest Element
Source
<xs:complexType name="CustomerRequestRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Customer request</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Touroperator code for the customer request</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Description for the customer request</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of assigend participants</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CustomerRequestRequestType Complex Type : AssignedTravellers Element
Description
List of assigend participants
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigend participants</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestRequestType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > CustomerRequestRequestType Complex Type : Code Element
Description
Touroperator code for the customer request
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code optional xs:token
Touroperator code for the customer request
Source
<xs:element name="Code" type="xs:token" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator code for the customer request</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestRequestType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > CustomerRequestRequestType Complex Type : Description Element
Description
Description for the customer request
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Description for the customer request</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestRequestType Complex Type | String Schema


CustomerRequestResponseType Complex Type

String Schema
CustomerRequestResponseType Complex Type
String Schema : CustomerRequestResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CustomerRequestRequestType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequestResponseType Complex Type
Overview
CustomerRequestResponseType Extension of CustomerRequestRequestType Complex Type
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Used By
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequests Element
CustomerRequest Element
Source
<xs:complexType name="CustomerRequestResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CustomerRequestRequestType">
      <xs:sequence>
        <xs:element name="State" type="ConfirmationStateType" nillable="false">
          <xs:annotation>
            <xs:documentation>Confirmation state of the customer request</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > CustomerRequestResponseType Complex Type : AssignedTravellers Element
Description
List of assigend participants
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of assigend participants</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestResponseType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > CustomerRequestResponseType Complex Type : Code Element
Description
Touroperator code for the customer request
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code optional xs:token
Touroperator code for the customer request
Source
<xs:element name="Code" type="xs:token" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator code for the customer request</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > CustomerRequestResponseType Complex Type : Description Element
Description
Description for the customer request
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Description for the customer request</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > CustomerRequestResponseType Complex Type : State Element
Description
Confirmation state of the customer request
Namespace http://string.drv.de/xmlschema/string
Type
ConfirmationStateType Simple Type
Overview
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="State" type="ConfirmationStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Confirmation state of the customer request</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CustomerRequestResponseType Complex Type | String Schema


ErrorsType Complex Type

String Schema
ErrorsType Complex Type
String Schema : ErrorsType Complex Type
Description
List of errors
Namespace http://string.drv.de/xmlschema/string
Diagram
ErrorCategory Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence ErrorDetail Element Sequence ErrorsType Complex Type
Overview
ErrorsType
List of errors
Sequence
ErrorDetail 1..∞ ErrorType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
ErrorCategory ErrorCategoryType Simple Type
Specific error category
Used By
Errors Element
Source
<xs:complexType name="ErrorsType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of errors</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ErrorDetail" type="ErrorType" nillable="false" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


ErrorDetail Element

String Schema
ErrorDetail Element
String Schema > ErrorsType Complex Type : ErrorDetail Element
Namespace http://string.drv.de/xmlschema/string
Type
ErrorType Complex Type
Diagram
ErrorCategory Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence ErrorDetail Element
Overview
ErrorDetail 1..∞ ErrorType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
ErrorCategory ErrorCategoryType Simple Type
Specific error category
Source
<xs:element name="ErrorDetail" type="ErrorType" nillable="false" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ErrorsType Complex Type | String Schema


ErrorType Complex Type

String Schema
ErrorType Complex Type
String Schema : ErrorType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of InformationType Complex Type
Diagram
ErrorCategory Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence ErrorType Complex Type
Overview
ErrorType Extension of InformationType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
ErrorCategory ErrorCategoryType Simple Type
Specific error category
Used By
ErrorDetail Element
Source
<xs:complexType name="ErrorType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="InformationType">
      <xs:sequence>
        <xs:element name="ErrorCategory" type="ErrorCategoryType" nillable="false">
          <xs:annotation>
            <xs:documentation>Specific error category</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedServices Element

String Schema
AssignedServices Element
String Schema > ErrorType Complex Type : AssignedServices Element
Description
List of services which caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServices Element
Overview
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of services which caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


AssignedServiceTypes Element

String Schema
AssignedServiceTypes Element
String Schema > ErrorType Complex Type : AssignedServiceTypes Element
Description
List of service types (e.g. rooms, flight classes) which caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServiceTypes Element
Overview
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of service types (e.g. rooms, flight classes) which caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


AssignedToBooking Element

String Schema
AssignedToBooking Element
String Schema > ErrorType Complex Type : AssignedToBooking Element
Description
Flag if this information is booking related
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Source
<xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this information is booking related</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > ErrorType Complex Type : AssignedTravellers Element
Description
List of participants who caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of participants who caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > ErrorType Complex Type : Code Element
Description
Code for the information defined by the touroperator
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Code for the information defined by the touroperator
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Code for the information defined by the touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > ErrorType Complex Type : Description Element
Description
Description for the information
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Description for the information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


ErrorCategory Element

String Schema
ErrorCategory Element
String Schema > ErrorType Complex Type : ErrorCategory Element
Description
Specific error category
Namespace http://string.drv.de/xmlschema/string
Type
ErrorCategoryType Simple Type
Overview
ErrorCategory ErrorCategoryType Simple Type
Specific error category
Source
<xs:element name="ErrorCategory" type="ErrorCategoryType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Specific error category</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > ErrorType Complex Type : Identifier Element
Description
Unique information identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique information identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique information identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ErrorType Complex Type | String Schema


ExternalContentRequestType Complex Type

String Schema
ExternalContentRequestType Complex Type
String Schema : ExternalContentRequestType Complex Type
Description
Rich content information
Namespace http://string.drv.de/xmlschema/string
Diagram
URL Element Id Element Provider Element Sequence ExternalContentRequestType Complex Type
Overview
ExternalContentRequestType
Rich content information
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Used By
ExternalContent Element
Source
<xs:complexType name="ExternalContentRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Rich content information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Provider" type="xs:string" nillable="false" minOccurs="0" />
    <xs:element name="Id" type="xs:string" nillable="false" minOccurs="0" />
    <xs:element name="URL" type="xs:string" nillable="false" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Id Element

String Schema
Id Element
String Schema > ExternalContentRequestType Complex Type : Id Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Id optional xs:string
Source
<xs:element name="Id" type="xs:string" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ExternalContentRequestType Complex Type | String Schema


Provider Element

String Schema
Provider Element
String Schema > ExternalContentRequestType Complex Type : Provider Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Provider optional xs:string
Source
<xs:element name="Provider" type="xs:string" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ExternalContentRequestType Complex Type | String Schema


URL Element

String Schema
URL Element
String Schema > ExternalContentRequestType Complex Type : URL Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
URL optional xs:string
Source
<xs:element name="URL" type="xs:string" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ExternalContentRequestType Complex Type | String Schema


ExternalReferenceType Complex Type

String Schema
ExternalReferenceType Complex Type
String Schema : ExternalReferenceType Complex Type
Description
Information about external system reference
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReferenceType Complex Type
Overview
ExternalReferenceType
Information about external system reference
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
ExternalReference Element
ExternalReference Element
Source
<xs:complexType name="ExternalReferenceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Information about external system reference</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ReferenceNumber" type="xs:int" nillable="false" />
    <xs:element name="Code" type="xs:token" />
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > ExternalReferenceType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ExternalReferenceType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > ExternalReferenceType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ExternalReferenceType Complex Type | String Schema


ReferenceNumber Element

String Schema
ReferenceNumber Element
String Schema > ExternalReferenceType Complex Type : ReferenceNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
ReferenceNumber xs:int
Source
<xs:element name="ReferenceNumber" type="xs:int" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ExternalReferenceType Complex Type | String Schema


FeeType Complex Type

String Schema
FeeType Complex Type
String Schema : FeeType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Percentage Element Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence FeeType Complex Type
Overview
FeeType
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Used By
Fees Element
Fees Element
Source
<xs:complexType name="FeeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="From" type="DateTimeType">
      <xs:annotation>
        <xs:documentation>Start date/time of according fee</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:choice>
      <xs:element name="Nights" type="xs:int" nillable="false">
        <xs:annotation>
          <xs:documentation>Fee in number of nights</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="Amount" type="CurrencyAmountType" nillable="true" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Fee as absolute amount</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="Percentage" type="xs:decimal" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Fee as percentage value</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:choice>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Description Element

String Schema
Description Element
String Schema > FeeType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FeeType Complex Type | String Schema


From Element

String Schema
From Element
String Schema > FeeType Complex Type : From Element
Description
Start date/time of according fee
Namespace http://string.drv.de/xmlschema/string
Type
DateTimeType Simple Type
Overview
From DateTimeType Simple Type
Start date/time of according fee
Source
<xs:element name="From" type="DateTimeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date/time of according fee</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FeeType Complex Type | String Schema


Amount Element

String Schema
Amount Element
String Schema > FeeType Complex Type : Amount Element
Description
Fee as absolute amount
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyAmountType Complex Type
Diagram
Currency Element Amount Element Sequence Amount Element
Overview
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Amount" type="CurrencyAmountType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Fee as absolute amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FeeType Complex Type | String Schema


Nights Element

String Schema
Nights Element
String Schema > FeeType Complex Type : Nights Element
Description
Fee in number of nights
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Nights xs:int
Fee in number of nights
Source
<xs:element name="Nights" type="xs:int" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Fee in number of nights</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FeeType Complex Type | String Schema


Percentage Element

String Schema
Percentage Element
String Schema > FeeType Complex Type : Percentage Element
Description
Fee as percentage value
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="Percentage" type="xs:decimal" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Fee as percentage value</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FeeType Complex Type | String Schema


FlightClassesRequestType Complex Type

String Schema
FlightClassesRequestType Complex Type
String Schema : FlightClassesRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Code Element Sequence ClassCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence FlightClassesRequestType Complex Type
Overview
FlightClassesRequestType
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Classes Element
Source
<xs:complexType name="FlightClassesRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="FlightClass" type="BookableClassRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


FlightClass Element

String Schema
FlightClass Element
String Schema > FlightClassesRequestType Complex Type : FlightClass Element
Namespace http://string.drv.de/xmlschema/string
Type
BookableClassRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element Code Element Sequence ClassCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element
Overview
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="FlightClass" type="BookableClassRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightClassesRequestType Complex Type | String Schema


FlightClassesResponseType Complex Type

String Schema
FlightClassesResponseType Complex Type
String Schema : FlightClassesResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Description Element Code Element Sequence ClassCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence FlightClassesResponseType Complex Type
Overview
FlightClassesResponseType
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Used By
Classes Element
Source
<xs:complexType name="FlightClassesResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="FlightClass" type="BookableClassResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


FlightClass Element

String Schema
FlightClass Element
String Schema > FlightClassesResponseType Complex Type : FlightClass Element
Namespace http://string.drv.de/xmlschema/string
Type
BookableClassResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence ClassCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element
Overview
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="FlightClass" type="BookableClassResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightClassesResponseType Complex Type | String Schema


FlightLegRequestType Complex Type

String Schema
FlightLegRequestType Complex Type
String Schema : FlightLegRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceRequestType Complex Type
Diagram
CustomerRequests Element IncludedExtras Element ClassCode Element Attributes Element AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence Classes Element IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Meal Element BaggageInfo Element AssignedSegments Element AssignedLegs Element AssignedTravellers Element Sequence TariffDetail Element Sequence TariffDetails Element Class Element Carrier Element ArrivalAirport Element DepartureAirport Element AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element CheckInData Element State Element PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence Segments Element PointOfTurnAround Element Value Element Sequence PNR Element Sequence Data Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence FlightLegRequestType Complex Type
Overview
FlightLegRequestType Extension of CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Leg Element
Source
<xs:complexType name="FlightLegRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceRequestType">
      <xs:sequence>
        <xs:element name="Data" type="CommonFlightDataType" nillable="true" minOccurs="0" />
        <xs:element name="Segments" type="FlightSegmentsRequestType" nillable="true" minOccurs="0" />
        <xs:element name="TariffDetails" type="FlightTariffsRequestType" nillable="true" minOccurs="0" />
        <xs:element name="DepartureAirport" type="AirportRequestType" nillable="true" minOccurs="0" />
        <xs:element name="ArrivalAirport" type="AirportRequestType" nillable="true" minOccurs="0" />
        <xs:element name="Carrier" type="AirlineRequestTypes" nillable="true" minOccurs="0" />
        <xs:element name="Classes" type="FlightClassesRequestType" nillable="true" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


ArrivalAirport Element

String Schema
ArrivalAirport Element
String Schema > FlightLegRequestType Complex Type : ArrivalAirport Element
Namespace http://string.drv.de/xmlschema/string
Type
AirportRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice ArrivalAirport Element
Overview
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="ArrivalAirport" type="AirportRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > FlightLegRequestType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > FlightLegRequestType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


Carrier Element

String Schema
Carrier Element
String Schema > FlightLegRequestType Complex Type : Carrier Element
Namespace http://string.drv.de/xmlschema/string
Type
AirlineRequestTypes Complex Type
Diagram
IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element
Overview
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Source
<xs:element name="Carrier" type="AirlineRequestTypes" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


Classes Element

String Schema
Classes Element
String Schema > FlightLegRequestType Complex Type : Classes Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightClassesRequestType Complex Type
Diagram
AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Code Element Sequence ClassCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence Classes Element
Overview
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Classes" type="FlightClassesRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > FlightLegRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


Data Element

String Schema
Data Element
String Schema > FlightLegRequestType Complex Type : Data Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonFlightDataType Complex Type
Diagram
PointOfTurnAround Element Value Element Sequence PNR Element Sequence Data Element
Overview
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Source
<xs:element name="Data" type="CommonFlightDataType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


DepartureAirport Element

String Schema
DepartureAirport Element
String Schema > FlightLegRequestType Complex Type : DepartureAirport Element
Namespace http://string.drv.de/xmlschema/string
Type
AirportRequestType Complex Type
Diagram
IcaoCode Element IataCode Element Choice DepartureAirport Element
Overview
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Source
<xs:element name="DepartureAirport" type="AirportRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > FlightLegRequestType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > FlightLegRequestType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > FlightLegRequestType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > FlightLegRequestType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeRequestType Complex Type
Diagram
Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Source
<xs:element name="Product" type="ProductCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > FlightLegRequestType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


RequestedPrices Element

String Schema
RequestedPrices Element
String Schema > FlightLegRequestType Complex Type : RequestedPrices Element
Description
Prices of an offer or the prices resulting from an external search
Namespace http://string.drv.de/xmlschema/string
Type
PricesRequestType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element
Overview
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="RequestedPrices" type="PricesRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Prices of an offer or the prices resulting from an external search</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


Segments Element

String Schema
Segments Element
String Schema > FlightLegRequestType Complex Type : Segments Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightSegmentsRequestType Complex Type
Diagram
ClassCode Element CabinClass Element Sequence Class Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence Segments Element
Overview
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="Segments" type="FlightSegmentsRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > FlightLegRequestType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


TariffDetails Element

String Schema
TariffDetails Element
String Schema > FlightLegRequestType Complex Type : TariffDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightTariffsRequestType Complex Type
Diagram
Code Element Sequence Meal Element Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence TariffDetail Element Sequence TariffDetails Element
Overview
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="TariffDetails" type="FlightTariffsRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegRequestType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > FlightLegRequestType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegRequestType Complex Type | String Schema


FlightLegResponseType Complex Type

String Schema
FlightLegResponseType Complex Type
String Schema : FlightLegResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonServiceResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence FlightDescription Element CustomerRequests Element IncludedExtras Element ClassCode Element Attributes Element AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence Classes Element AirlineName Element Choice Sequence MarketingCarrier Element AirlineName Element Choice Sequence OperatingCarrier Element Sequence Carrier Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element Meal Element BaggageInfo Element AssignedSegments Element AssignedLegs Element AssignedTravellers Element Sequence TariffDetail Element Sequence TariffDetails Element HasSeatmap Element Class Element Carrier Element ArrivalAirport Element DepartureAirport Element AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element CheckInData Element State Element PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence Segments Element PointOfTurnAround Element Value Element Sequence PNR Element Sequence Data Element Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence FlightLegResponseType Complex Type
Overview
FlightLegResponseType Extension of CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Leg Element
Source
<xs:complexType name="FlightLegResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonServiceResponseType">
      <xs:sequence>
        <xs:element name="Data" type="CommonFlightDataType" nillable="true" minOccurs="0" />
        <xs:element name="Segments" type="FlightSegmentsResponseType" nillable="true" minOccurs="0" />
        <xs:element name="TariffDetails" type="FlightTariffsResponseType" nillable="true" minOccurs="0" />
        <xs:element name="DepartureAirport" type="AirportResponseType" nillable="false" minOccurs="0" />
        <xs:element name="ArrivalAirport" type="AirportResponseType" nillable="false" minOccurs="0" />
        <xs:element name="Carrier" type="AirlineResponseTypes" nillable="true" minOccurs="0" />
        <xs:element name="Classes" type="FlightClassesResponseType" nillable="true" minOccurs="0" />
        <xs:element name="FlightDescription" type="TextLanguageType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AdditionalInfos Element

String Schema
AdditionalInfos Element
String Schema > FlightLegResponseType Complex Type : AdditionalInfos Element
Description
Additional infos (e.g. cancellation and modifications conditions)
Namespace http://string.drv.de/xmlschema/string
Type
ServicesResponseAdditionalInfoType Complex Type
Diagram
Choice From Element Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element Choice From Element Description Element Sequence Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element
Overview
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="AdditionalInfos" type="ServicesResponseAdditionalInfoType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Additional infos (e.g. cancellation and modifications conditions)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


ArrivalAirport Element

String Schema
ArrivalAirport Element
String Schema > FlightLegResponseType Complex Type : ArrivalAirport Element
Namespace http://string.drv.de/xmlschema/string
Type
AirportResponseType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element
Overview
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="ArrivalAirport" type="AirportResponseType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > FlightLegResponseType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this service
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > FlightLegResponseType Complex Type : Attributes Element
Description
List of attributes of this service
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


Carrier Element

String Schema
Carrier Element
String Schema > FlightLegResponseType Complex Type : Carrier Element
Namespace http://string.drv.de/xmlschema/string
Type
AirlineResponseTypes Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence MarketingCarrier Element LanguageCode Element Text Element Sequence AirlineName Element IcaoCode Element IataCode Element Choice Sequence OperatingCarrier Element Sequence Carrier Element
Overview
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Carrier" type="AirlineResponseTypes" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


Classes Element

String Schema
Classes Element
String Schema > FlightLegResponseType Complex Type : Classes Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightClassesResponseType Complex Type
Diagram
State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element IncludedExtra Element Sequence IncludedExtras Element Description Element Code Element Sequence ClassCode Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence Classes Element
Overview
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="Classes" type="FlightClassesResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > FlightLegResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


Data Element

String Schema
Data Element
String Schema > FlightLegResponseType Complex Type : Data Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonFlightDataType Complex Type
Diagram
PointOfTurnAround Element Value Element Sequence PNR Element Sequence Data Element
Overview
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Source
<xs:element name="Data" type="CommonFlightDataType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


DepartureAirport Element

String Schema
DepartureAirport Element
String Schema > FlightLegResponseType Complex Type : DepartureAirport Element
Namespace http://string.drv.de/xmlschema/string
Type
AirportResponseType Complex Type
Diagram
Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element
Overview
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Source
<xs:element name="DepartureAirport" type="AirportResponseType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


EndDate Element

String Schema
EndDate Element
String Schema > FlightLegResponseType Complex Type : EndDate Element
Description
End Date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
EndDate DateType Simple Type
End Date of the service
Source
<xs:element name="EndDate" type="DateType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>End Date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


FlightDescription Element

String Schema
FlightDescription Element
String Schema > FlightLegResponseType Complex Type : FlightDescription Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence FlightDescription Element
Overview
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="FlightDescription" type="TextLanguageType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > FlightLegResponseType Complex Type : Identifier Element
Description
Unique service identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique service identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique service identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


PackageReference Element

String Schema
PackageReference Element
String Schema > FlightLegResponseType Complex Type : PackageReference Element
Description
Reference to a package in case that the current service is part of a package
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Source
<xs:element name="PackageReference" type="IdentifierType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference to a package in case that the current service is part of a package</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


Product Element

String Schema
Product Element
String Schema > FlightLegResponseType Complex Type : Product Element
Namespace http://string.drv.de/xmlschema/string
Type
ProductCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element
Overview
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Product" type="ProductCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


Quantity Element

String Schema
Quantity Element
String Schema > FlightLegResponseType Complex Type : Quantity Element
Description
Quantity of the service
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Quantity optional xs:int
Quantity of the service
Source
<xs:element name="Quantity" type="xs:int" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Quantity of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


Segments Element

String Schema
Segments Element
String Schema > FlightLegResponseType Complex Type : Segments Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightSegmentsResponseType Complex Type
Diagram
HasSeatmap Element ClassCode Element CabinClass Element Sequence Class Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element Location Element AirportName Element Choice Sequence ArrivalAirport Element Location Element AirportName Element Choice Sequence DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence Segments Element
Overview
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Source
<xs:element name="Segments" type="FlightSegmentsResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


StartDate Element

String Schema
StartDate Element
String Schema > FlightLegResponseType Complex Type : StartDate Element
Description
Start date of the service
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
StartDate DateType Simple Type
Start date of the service
Source
<xs:element name="StartDate" type="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Start date of the service</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > FlightLegResponseType Complex Type : State Element
Description
Service bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Service bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Service bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


TariffDetails Element

String Schema
TariffDetails Element
String Schema > FlightLegResponseType Complex Type : TariffDetails Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightTariffsResponseType Complex Type
Diagram
Description Element Code Element Sequence Meal Element Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence TariffDetail Element Sequence TariffDetails Element
Overview
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="TariffDetails" type="FlightTariffsResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegResponseType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > FlightLegResponseType Complex Type : Type Element
Description
For optionally specifying the service type / kind of service
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
For optionally specifying the service type / kind of service
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>For optionally specifying the service type / kind of service </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FlightLegResponseType Complex Type | String Schema


FlightLegsRequestType Complex Type

String Schema
FlightLegsRequestType Complex Type
String Schema : FlightLegsRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
FlightClass Element Sequence Classes Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element TariffDetail Element Sequence TariffDetails Element Segment Element Sequence Segments Element PointOfTurnAround Element PNR Element Sequence Data Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element DetailPrices Element Sequence RequestedPrices Element Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence FlightLegsRequestType Complex Type
Overview
FlightLegsRequestType
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
ExtraCode optional IncludedExtraRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Legs Element
Source
<xs:complexType name="FlightLegsRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Leg" type="FlightLegRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Leg Element

String Schema
Leg Element
String Schema > FlightLegsRequestType Complex Type : Leg Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightLegRequestType Complex Type
Diagram
CustomerRequests Element IncludedExtras Element ClassCode Element Attributes Element AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence Classes Element IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Meal Element BaggageInfo Element AssignedSegments Element AssignedLegs Element AssignedTravellers Element Sequence TariffDetail Element Sequence TariffDetails Element Class Element Carrier Element ArrivalAirport Element DepartureAirport Element AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element CheckInData Element State Element PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence Segments Element PointOfTurnAround Element Value Element Sequence PNR Element Sequence Data Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element
Overview
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Leg" type="FlightLegRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegsRequestType Complex Type | String Schema


FlightLegsResponseType Complex Type

String Schema
FlightLegsResponseType Complex Type
String Schema : FlightLegsResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence FlightDescription Element FlightClass Element Sequence Classes Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element Location Element AirportName Element Choice Sequence ArrivalAirport Element Location Element AirportName Element Choice Sequence DepartureAirport Element TariffDetail Element Sequence TariffDetails Element Segment Element Sequence Segments Element PointOfTurnAround Element PNR Element Sequence Data Element ModificationPolicies Element CancellationPolicies Element GeneralInformation Element Sequence AdditionalInfos Element State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element State Element Catalogue Element Description Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence FlightLegsResponseType Complex Type
Overview
FlightLegsResponseType
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
ExtraCode optional IncludedExtraResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Legs Element
Source
<xs:complexType name="FlightLegsResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Leg" type="FlightLegResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Leg Element

String Schema
Leg Element
String Schema > FlightLegsResponseType Complex Type : Leg Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightLegResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence FlightDescription Element CustomerRequests Element IncludedExtras Element ClassCode Element Attributes Element AssignedTravellers Element State Element CabinClass Element Identifier Element Sequence FlightClass Element Sequence Classes Element AirlineName Element Choice Sequence MarketingCarrier Element AirlineName Element Choice Sequence OperatingCarrier Element Sequence Carrier Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element Meal Element BaggageInfo Element AssignedSegments Element AssignedLegs Element AssignedTravellers Element Sequence TariffDetail Element Sequence TariffDetails Element HasSeatmap Element Class Element Carrier Element ArrivalAirport Element DepartureAirport Element AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element CheckInData Element State Element PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence Segments Element PointOfTurnAround Element Value Element Sequence PNR Element Sequence Data Element Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element
Overview
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Leg" type="FlightLegResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightLegsResponseType Complex Type | String Schema


FlightRequestType Complex Type

String Schema
FlightRequestType Complex Type
String Schema : FlightRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Classes Element Carrier Element ArrivalAirport Element DepartureAirport Element TariffDetails Element Segments Element Data Element CustomerRequests Element RequestedPrices Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence Legs Element Sequence FlightRequestType Complex Type
Overview
FlightRequestType
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
MarketingCarrier optional AirlineRequestType Complex Type
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Used By
Flight Element
Source
<xs:complexType name="FlightRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Legs" type="FlightLegsRequestType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Legs Element

String Schema
Legs Element
String Schema > FlightRequestType Complex Type : Legs Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightLegsRequestType Complex Type
Diagram
FlightClass Element Sequence Classes Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element TariffDetail Element Sequence TariffDetails Element Segment Element Sequence Segments Element PointOfTurnAround Element PNR Element Sequence Data Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element DetailPrices Element Sequence RequestedPrices Element Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence Legs Element
Overview
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
ExtraCode optional IncludedExtraRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Legs" type="FlightLegsRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightRequestType Complex Type | String Schema


FlightResponseType Complex Type

String Schema
FlightResponseType Complex Type
String Schema : FlightResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
FlightDescription Element Classes Element Carrier Element ArrivalAirport Element DepartureAirport Element TariffDetails Element Segments Element Data Element AdditionalInfos Element CustomerRequests Element State Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence Legs Element Sequence FlightResponseType Complex Type
Overview
FlightResponseType
Sequence
Legs optional FlightLegsResponseType Complex Type
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
State ConfirmationStateType Simple Type
Confirmation state of the customer request
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Flight Element
Source
<xs:complexType name="FlightResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Legs" type="FlightLegsResponseType" nillable="true" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Legs Element

String Schema
Legs Element
String Schema > FlightResponseType Complex Type : Legs Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightLegsResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence FlightDescription Element FlightClass Element Sequence Classes Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element Location Element AirportName Element Choice Sequence ArrivalAirport Element Location Element AirportName Element Choice Sequence DepartureAirport Element TariffDetail Element Sequence TariffDetails Element Segment Element Sequence Segments Element PointOfTurnAround Element PNR Element Sequence Data Element ModificationPolicies Element CancellationPolicies Element GeneralInformation Element Sequence AdditionalInfos Element State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element State Element Catalogue Element Description Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence Legs Element
Overview
Legs optional FlightLegsResponseType Complex Type
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
ExtraCode optional IncludedExtraResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Legs" type="FlightLegsResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightResponseType Complex Type | String Schema


FlightSegmentsRequestType Complex Type

String Schema
FlightSegmentsRequestType Complex Type
String Schema : FlightSegmentsRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ClassCode Element CabinClass Element Sequence Class Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence FlightSegmentsRequestType Complex Type
Overview
FlightSegmentsRequestType
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Used By
Segments Element
Source
<xs:complexType name="FlightSegmentsRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Segment" type="CommonFlightSegmentRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Segment Element

String Schema
Segment Element
String Schema > FlightSegmentsRequestType Complex Type : Segment Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonFlightSegmentRequestType Complex Type
Diagram
Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element IcaoCode Element IataCode Element Choice MarketingCarrier Element IcaoCode Element IataCode Element Choice OperatingCarrier Element Sequence Carrier Element IcaoCode Element IataCode Element Choice ArrivalAirport Element IcaoCode Element IataCode Element Choice DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element
Overview
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="Segment" type="CommonFlightSegmentRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightSegmentsRequestType Complex Type | String Schema


FlightSegmentsResponseType Complex Type

String Schema
FlightSegmentsResponseType Complex Type
String Schema : FlightSegmentsResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
HasSeatmap Element ClassCode Element CabinClass Element Sequence Class Element MarketingCarrier Element OperatingCarrier Element Sequence Carrier Element Location Element AirportName Element Choice Sequence ArrivalAirport Element Location Element AirportName Element Choice Sequence DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element Sequence FlightSegmentsResponseType Complex Type
Overview
FlightSegmentsResponseType
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Used By
Segments Element
Source
<xs:complexType name="FlightSegmentsResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Segment" type="CommonFlightSegmentResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Segment Element

String Schema
Segment Element
String Schema > FlightSegmentsResponseType Complex Type : Segment Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonFlightSegmentResponseType Complex Type
Diagram
HasSeatmap Element Description Element Code Element Sequence ClassCode Element CabinClass Element Sequence Class Element AirlineName Element Choice Sequence MarketingCarrier Element AirlineName Element Choice Sequence OperatingCarrier Element Sequence Carrier Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence ArrivalAirport Element Latitude Element Longitude Element Sequence Location Element LanguageCode Element Text Element Sequence AirportName Element IcaoCode Element IataCode Element Choice Sequence DepartureAirport Element Identifier Element Sequence AssignedTravellers Element Overnights Element ETIX Element ArrivalTerminal Element Gate Element Terminal Element Counter Element Time Element Sequence CheckInData Element State Element Value Element Sequence PNR Element FlightNumber Element ArrivalDate Element DepartureDate Element Identifier Element Sequence Segment Element
Overview
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
Source
<xs:element name="Segment" type="CommonFlightSegmentResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightSegmentsResponseType Complex Type | String Schema


FlightTariffsRequestType Complex Type

String Schema
FlightTariffsRequestType Complex Type
String Schema : FlightTariffsRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Code Element Sequence Meal Element Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence TariffDetail Element Sequence FlightTariffsRequestType Complex Type
Overview
FlightTariffsRequestType
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
Used By
TariffDetails Element
Source
<xs:complexType name="FlightTariffsRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="TariffDetail" type="CommonTariffRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


TariffDetail Element

String Schema
TariffDetail Element
String Schema > FlightTariffsRequestType Complex Type : TariffDetail Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTariffRequestType Complex Type
Diagram
Code Element Sequence Meal Element Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence TariffDetail Element
Overview
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="TariffDetail" type="CommonTariffRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightTariffsRequestType Complex Type | String Schema


FlightTariffsResponseType Complex Type

String Schema
FlightTariffsResponseType Complex Type
String Schema : FlightTariffsResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Description Element Code Element Sequence Meal Element Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence TariffDetail Element Sequence FlightTariffsResponseType Complex Type
Overview
FlightTariffsResponseType
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
TariffDetails Element
Source
<xs:complexType name="FlightTariffsResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="TariffDetail" type="CommonTariffResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


TariffDetail Element

String Schema
TariffDetail Element
String Schema > FlightTariffsResponseType Complex Type : TariffDetail Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTariffResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence Meal Element Measure Element Weight Element Sequence Weight Element Pieces Element Sequence BaggageInfo Element Identifier Element Sequence AssignedSegments Element Identifier Element Sequence AssignedLegs Element Identifier Element Sequence AssignedTravellers Element Sequence TariffDetail Element
Overview
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="TariffDetail" type="CommonTariffResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FlightTariffsResponseType Complex Type | String Schema


GeoLocationType Complex Type

String Schema
GeoLocationType Complex Type
String Schema : GeoLocationType Complex Type
Description
Type for geo coding information
Namespace http://string.drv.de/xmlschema/string
Diagram
Latitude Element Longitude Element Sequence GeoLocationType Complex Type
Overview
GeoLocationType
Type for geo coding information
Sequence
Longitude xs:string
Latitude xs:string
Used By
Location Element
GeoLocation Element
Source
<xs:complexType name="GeoLocationType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type for geo coding information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Longitude" type="xs:string" nillable="false" />
    <xs:element name="Latitude" type="xs:string" nillable="false" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Latitude Element

String Schema
Latitude Element
String Schema > GeoLocationType Complex Type : Latitude Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Latitude xs:string
Source
<xs:element name="Latitude" type="xs:string" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
GeoLocationType Complex Type | String Schema


Longitude Element

String Schema
Longitude Element
String Schema > GeoLocationType Complex Type : Longitude Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Longitude xs:string
Source
<xs:element name="Longitude" type="xs:string" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
GeoLocationType Complex Type | String Schema


IdentifiersType Complex Type

String Schema
IdentifiersType Complex Type
String Schema : IdentifiersType Complex Type
Description
List of unique identifiers
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence IdentifiersType Complex Type
Overview
IdentifiersType
List of unique identifiers
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
AssignedTravellers Element
AssignedServices Element
AssignedServiceTypes Element
AssignedTravellers Element
AssignedServices Element
AssignedServiceTypes Element
AssignedTravellers Element
AssignedServices Element
AssignedServiceTypes Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedLegs Element
AssignedSegments Element
AssignedTravellers Element
AssignedLegs Element
AssignedSegments Element
AssignedTravellers Element
AssignedLegs Element
AssignedSegments Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedTravellers Element
AssignedServices Element
AssignedServiceTypes Element
AssignedTravellers Element
AssignedServices Element
AssignedServiceTypes Element
AssignedTravellers Element
AssignedServices Element
AssignedServiceTypes Element
AssignedTravellers Element
AssignedTravellers Element
ConfirmedWarnings Element
Source
<xs:complexType name="IdentifiersType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of unique identifiers</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType" nillable="false" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Identifier Element

String Schema
Identifier Element
String Schema > IdentifiersType Complex Type : Identifier Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Identifier" type="IdentifierType" nillable="false" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IdentifiersType Complex Type | String Schema


IncludedExtraBaseRequestType Complex Type

String Schema
IncludedExtraBaseRequestType Complex Type
String Schema : IncludedExtraBaseRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of IncludedExtraCommonType Complex Type
Diagram
Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtraBaseRequestType Complex Type
Overview
IncludedExtraBaseRequestType Extension of IncludedExtraCommonType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Used By
IncludedExtra Element
Source
<xs:complexType name="IncludedExtraBaseRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="IncludedExtraCommonType">
      <xs:annotation>
        <xs:documentation>Included extra information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="ExtraCode" type="IncludedExtraRequestType" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > IncludedExtraBaseRequestType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this included extra
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this included extra</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
IncludedExtraBaseRequestType Complex Type | String Schema


ExtraCode Element

String Schema
ExtraCode Element
String Schema > IncludedExtraBaseRequestType Complex Type : ExtraCode Element
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtraRequestType Complex Type
Diagram
Code Element Sequence ExtraCode Element
Overview
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="ExtraCode" type="IncludedExtraRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtraBaseRequestType Complex Type | String Schema


IncludedExtraBaseResponseType Complex Type

String Schema
IncludedExtraBaseResponseType Complex Type
String Schema : IncludedExtraBaseResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of IncludedExtraCommonType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtraBaseResponseType Complex Type
Overview
IncludedExtraBaseResponseType Extension of IncludedExtraCommonType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
IncludedExtra Element
Source
<xs:complexType name="IncludedExtraBaseResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="IncludedExtraCommonType">
      <xs:annotation>
        <xs:documentation>Included extra information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="ExtraCode" type="IncludedExtraResponseType" minOccurs="0" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > IncludedExtraBaseResponseType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this included extra
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this included extra</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
IncludedExtraBaseResponseType Complex Type | String Schema


ExtraCode Element

String Schema
ExtraCode Element
String Schema > IncludedExtraBaseResponseType Complex Type : ExtraCode Element
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtraResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ExtraCode Element
Overview
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="ExtraCode" type="IncludedExtraResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtraBaseResponseType Complex Type | String Schema


IncludedExtraCommonType Complex Type

String Schema
IncludedExtraCommonType Complex Type
String Schema : IncludedExtraCommonType Complex Type
Description
Included extra information
Namespace http://string.drv.de/xmlschema/string
Diagram
Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtraCommonType Complex Type
Overview
IncludedExtraCommonType
Included extra information
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:complexType name="IncludedExtraCommonType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Included extra information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of traveller identifiers assigned to this included extra</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > IncludedExtraCommonType Complex Type : AssignedTravellers Element
Description
List of traveller identifiers assigned to this included extra
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of traveller identifiers assigned to this included extra</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
IncludedExtraCommonType Complex Type | String Schema


IncludedExtraRequestType Complex Type

String Schema
IncludedExtraRequestType Complex Type
String Schema : IncludedExtraRequestType Complex Type
Description
Included extra
Namespace http://string.drv.de/xmlschema/string
Diagram
Code Element Sequence IncludedExtraRequestType Complex Type
Overview
IncludedExtraRequestType
Included extra
Sequence
Code xs:token
Used By
ExtraCode Element
Source
<xs:complexType name="IncludedExtraRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Included extra</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > IncludedExtraRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtraRequestType Complex Type | String Schema


IncludedExtraResponseType Complex Type

String Schema
IncludedExtraResponseType Complex Type
String Schema : IncludedExtraResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of IncludedExtraRequestType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence IncludedExtraResponseType Complex Type
Overview
IncludedExtraResponseType Extension of IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
ExtraCode Element
Source
<xs:complexType name="IncludedExtraResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="IncludedExtraRequestType">
      <xs:sequence>
        <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > IncludedExtraResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtraResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > IncludedExtraResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtraResponseType Complex Type | String Schema


IncludedExtrasRequestType Complex Type

String Schema
IncludedExtrasRequestType Complex Type
String Schema : IncludedExtrasRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtrasRequestType Complex Type
Overview
IncludedExtrasRequestType
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Used By
IncludedExtras Element
IncludedExtras Element
Source
<xs:complexType name="IncludedExtrasRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="IncludedExtra" type="IncludedExtraBaseRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


IncludedExtra Element

String Schema
IncludedExtra Element
String Schema > IncludedExtrasRequestType Complex Type : IncludedExtra Element
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtraBaseRequestType Complex Type
Diagram
Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element
Overview
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="IncludedExtra" type="IncludedExtraBaseRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtrasRequestType Complex Type | String Schema


IncludedExtrasResponseType Complex Type

String Schema
IncludedExtrasResponseType Complex Type
String Schema : IncludedExtrasResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Description Element Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtrasResponseType Complex Type
Overview
IncludedExtrasResponseType
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
IncludedExtras Element
IncludedExtras Element
Source
<xs:complexType name="IncludedExtrasResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="IncludedExtra" type="IncludedExtraBaseResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


IncludedExtra Element

String Schema
IncludedExtra Element
String Schema > IncludedExtrasResponseType Complex Type : IncludedExtra Element
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtraBaseResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element
Overview
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="IncludedExtra" type="IncludedExtraBaseResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
IncludedExtrasResponseType Complex Type | String Schema


InformationsType Complex Type

String Schema
InformationsType Complex Type
String Schema : InformationsType Complex Type
Description
List of informations
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence InformationDetail Element Sequence InformationsType Complex Type
Overview
InformationsType
List of informations
Sequence
InformationDetail 1..∞ InformationType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Used By
Informations Element
Source
<xs:complexType name="InformationsType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of informations</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="InformationDetail" type="InformationType" nillable="false" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


InformationDetail Element

String Schema
InformationDetail Element
String Schema > InformationsType Complex Type : InformationDetail Element
Namespace http://string.drv.de/xmlschema/string
Type
InformationType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence InformationDetail Element
Overview
InformationDetail 1..∞ InformationType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Source
<xs:element name="InformationDetail" type="InformationType" nillable="false" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
InformationsType Complex Type | String Schema


InformationType Complex Type

String Schema
InformationType Complex Type
String Schema : InformationType Complex Type
Description
Warning associated with certain details within the response
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence InformationType Complex Type
Overview
InformationType
Warning associated with certain details within the response
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Used By
InformationDetail Element
Source
<xs:complexType name="InformationType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Warning associated with certain details within the response</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Identifier" type="IdentifierType">
      <xs:annotation>
        <xs:documentation>Unique information identifier</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Code" type="xs:token">
      <xs:annotation>
        <xs:documentation>Code for the information defined by the touroperator</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Description for the information</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of participants who caused this information</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of services which caused this information</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0">
      <xs:annotation>
        <xs:documentation>List of service types (e.g. rooms, flight classes) which caused this information</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0">
      <xs:annotation>
        <xs:documentation>Flag if this information is booking related</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


AssignedServices Element

String Schema
AssignedServices Element
String Schema > InformationType Complex Type : AssignedServices Element
Description
List of services which caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServices Element
Overview
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of services which caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


AssignedServiceTypes Element

String Schema
AssignedServiceTypes Element
String Schema > InformationType Complex Type : AssignedServiceTypes Element
Description
List of service types (e.g. rooms, flight classes) which caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServiceTypes Element
Overview
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of service types (e.g. rooms, flight classes) which caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


AssignedToBooking Element

String Schema
AssignedToBooking Element
String Schema > InformationType Complex Type : AssignedToBooking Element
Description
Flag if this information is booking related
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Source
<xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this information is booking related</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > InformationType Complex Type : AssignedTravellers Element
Description
List of participants who caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of participants who caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > InformationType Complex Type : Code Element
Description
Code for the information defined by the touroperator
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Code for the information defined by the touroperator
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Code for the information defined by the touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > InformationType Complex Type : Description Element
Description
Description for the information
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Description for the information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > InformationType Complex Type : Identifier Element
Description
Unique information identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique information identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique information identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
InformationType Complex Type | String Schema


KeyValueType Complex Type

String Schema
KeyValueType Complex Type
String Schema : KeyValueType Complex Type
Description
List of key-value elements
Namespace http://string.drv.de/xmlschema/string
Diagram
Value Element Key Element Sequence KeyValueType Complex Type
Overview
KeyValueType
List of key-value elements
Sequence
Key xs:token
Value xs:string
Used By
Setting Element
Source
<xs:complexType name="KeyValueType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of key-value elements</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Key" type="xs:token" />
    <xs:element name="Value" type="xs:string" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Key Element

String Schema
Key Element
String Schema > KeyValueType Complex Type : Key Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Key xs:token
Source
<xs:element name="Key" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
KeyValueType Complex Type | String Schema


Value Element

String Schema
Value Element
String Schema > KeyValueType Complex Type : Value Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Value xs:string
Source
<xs:element name="Value" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
KeyValueType Complex Type | String Schema


ListType Complex Type

String Schema
ListType Complex Type
String Schema : ListType Complex Type
Description
List of strings
Namespace http://string.drv.de/xmlschema/string
Diagram
Value Element Sequence ListType Complex Type
Overview
ListType
List of strings
Sequence
Value 1..∞ xs:string
Used By
PNR Element
PNR Element
PNR Element
PNR Element
Source
<xs:complexType name="ListType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of strings</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Value" type="xs:string" nillable="false" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Value Element

String Schema
Value Element
String Schema > ListType Complex Type : Value Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Value 1..∞ xs:string
Source
<xs:element name="Value" type="xs:string" nillable="false" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ListType Complex Type | String Schema


MealRequestType Complex Type

String Schema
MealRequestType Complex Type
String Schema : MealRequestType Complex Type
Description
Meal
Namespace http://string.drv.de/xmlschema/string
Diagram
Code Element Sequence MealRequestType Complex Type
Overview
MealRequestType
Meal
Sequence
Code xs:token
Used By
Meal Element
Source
<xs:complexType name="MealRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Meal</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > MealRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MealRequestType Complex Type | String Schema


MealResponseType Complex Type

String Schema
MealResponseType Complex Type
String Schema : MealResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of MealRequestType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence MealResponseType Complex Type
Overview
MealResponseType Extension of MealRequestType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Meal Element
Source
<xs:complexType name="MealResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="MealRequestType">
      <xs:sequence>
        <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > MealResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MealResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > MealResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MealResponseType Complex Type | String Schema


ModficationPoliciesType Complex Type

String Schema
ModficationPoliciesType Complex Type
String Schema : ModficationPoliciesType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Percentage Element Sequence Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence Fees Element Permitted Element Sequence ModficationPoliciesType Complex Type
Overview
ModficationPoliciesType
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Used By
ModificationPolicies Element
Attributes
Name | Type | Use | Default | Fixed | Description
Free | xs:boolean | optional |  |  | True if modifiable for free
Upgradable | xs:boolean | optional |  |  | True if upgradable for free
Unchangeable | xs:boolean | optional |  |  | True if not changeable at all
Source
<xs:complexType name="ModficationPoliciesType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Permitted" minOccurs="0">
      <xs:complexType>
        <xs:attribute name="Passengers" type="xs:boolean" />
        <xs:attribute name="From" type="xs:boolean" />
        <xs:attribute name="To" type="xs:boolean" />
        <xs:attribute name="Duration" type="xs:boolean" />
        <xs:attribute name="Room" type="xs:boolean" />
        <xs:attribute name="Board" type="xs:token" />
      </xs:complexType>
    </xs:element>
    <xs:element name="Fees" type="FeeType" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Free" type="xs:boolean">
    <xs:annotation>
      <xs:documentation>True if modifiable for free </xs:documentation>
    </xs:annotation>
  </xs:attribute>
  <xs:attribute name="Upgradable" type="xs:boolean">
    <xs:annotation>
      <xs:documentation>True if upgradable for free </xs:documentation>
    </xs:annotation>
  </xs:attribute>
  <xs:attribute name="Unchangeable" type="xs:boolean">
    <xs:annotation>
      <xs:documentation>True if not changeable at all</xs:documentation>
    </xs:annotation>
  </xs:attribute>
</xs:complexType>
See Also
String Schema


Fees Element

String Schema
Fees Element
String Schema > ModficationPoliciesType Complex Type : Fees Element
Namespace http://string.drv.de/xmlschema/string
Type
FeeType Complex Type
Diagram
Percentage Element Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence Fees Element
Overview
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="Fees" type="FeeType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ModficationPoliciesType Complex Type | String Schema


Permitted Element

String Schema
Permitted Element
String Schema > ModficationPoliciesType Complex Type : Permitted Element
Namespace http://string.drv.de/xmlschema/string
Overview
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Attributes
Name | Type | Use | Default | Fixed | Description
Passengers | xs:boolean | optional |  |  |
From | xs:boolean | optional |  |  |
To | xs:boolean | optional |  |  |
Duration | xs:boolean | optional |  |  |
Room | xs:boolean | optional |  |  |
Board | xs:token | optional |  |  |
Source
<xs:element name="Permitted" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="Passengers" type="xs:boolean" />
    <xs:attribute name="From" type="xs:boolean" />
    <xs:attribute name="To" type="xs:boolean" />
    <xs:attribute name="Duration" type="xs:boolean" />
    <xs:attribute name="Room" type="xs:boolean" />
    <xs:attribute name="Board" type="xs:token" />
  </xs:complexType>
</xs:element>
See Also
ModficationPoliciesType Complex Type | String Schema


PackageRequestType Complex Type

String Schema
PackageRequestType Complex Type
String Schema : PackageRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element DetailPrices Element Sequence RequestedPrices Element Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence PackageRequestType Complex Type
Overview
PackageRequestType
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Package Element
Source
<xs:complexType name="PackageRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Details" type="CommonServiceRequestType" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Details Element

String Schema
Details Element
String Schema > PackageRequestType Complex Type : Details Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonServiceRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element
Overview
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Details" type="CommonServiceRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PackageRequestType Complex Type | String Schema


PackageResponseType Complex Type

String Schema
PackageResponseType Complex Type
String Schema : PackageResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ModificationPolicies Element CancellationPolicies Element GeneralInformation Element Sequence AdditionalInfos Element State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element State Element Catalogue Element Description Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence PackageResponseType Complex Type
Overview
PackageResponseType
Sequence
Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Used By
Package Element
Source
<xs:complexType name="PackageResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Details" type="CommonServiceResponseType">
      <xs:annotation>
        <xs:documentation>Details of included services can be found in Services section</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Details Element

String Schema
Details Element
String Schema > PackageResponseType Complex Type : Details Element
Description
Details of included services can be found in Services section
Namespace http://string.drv.de/xmlschema/string
Type
CommonServiceResponseType Complex Type
Diagram
Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element
Overview
Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="Details" type="CommonServiceResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Details of included services can be found in Services section</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PackageResponseType Complex Type | String Schema


PackagesRequestType Complex Type

String Schema
PackagesRequestType Complex Type
String Schema : PackagesRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
CustomerRequests Element RequestedPrices Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence Package Element Sequence PackagesRequestType Complex Type
Overview
PackagesRequestType
Sequence
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Packages Element
Source
<xs:complexType name="PackagesRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Package" type="PackageRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Package Element

String Schema
Package Element
String Schema > PackagesRequestType Complex Type : Package Element
Namespace http://string.drv.de/xmlschema/string
Type
PackageRequestType Complex Type
Diagram
AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element DetailPrices Element Sequence RequestedPrices Element Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence Package Element
Overview
Package 0..∞ PackageRequestType Complex Type
Sequence
Details CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="Package" type="PackageRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PackagesRequestType Complex Type | String Schema


PackagesResponseType Complex Type

String Schema
PackagesResponseType Complex Type
String Schema : PackagesResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
AdditionalInfos Element CustomerRequests Element State Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence Package Element Sequence PackagesResponseType Complex Type
Overview
PackagesResponseType
Sequence
Package 0..∞ PackageResponseType Complex Type
Sequence
Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
Used By
Packages Element
Source
<xs:complexType name="PackagesResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Package" type="PackageResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Package Element

String Schema
Package Element
String Schema > PackagesResponseType Complex Type : Package Element
Namespace http://string.drv.de/xmlschema/string
Type
PackageResponseType Complex Type
Diagram
ModificationPolicies Element CancellationPolicies Element GeneralInformation Element Sequence AdditionalInfos Element State Element AssignedTravellers Element Description Element Code Element Sequence CustomerRequests Element State Element Catalogue Element Description Element Type Element Code Element Sequence Product Element PackageReference Element Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Details Element Sequence Package Element
Overview
Package 0..∞ PackageResponseType Complex Type
Sequence
Details CommonServiceResponseType Complex Type
Details of included services can be found in Services section
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="Package" type="PackageResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PackagesResponseType Complex Type | String Schema


PackageType Complex Type

String Schema
PackageType Complex Type
String Schema : PackageType Complex Type
Namespace http://string.drv.de/xmlschema/string
Overview
PackageType
Source
<xs:complexType name="PackageType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
String Schema


PackageWeightType Complex Type

String Schema
PackageWeightType Complex Type
String Schema : PackageWeightType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Measure Element Weight Element Sequence PackageWeightType Complex Type
Overview
PackageWeightType
Sequence
Weight optional xs:int
Measure optional WeightMeasureType Simple Type
Used By
Weight Element
Source
<xs:complexType name="PackageWeightType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Weight" type="xs:int" nillable="false" minOccurs="0" />
    <xs:element name="Measure" type="WeightMeasureType" nillable="false" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Measure Element

String Schema
Measure Element
String Schema > PackageWeightType Complex Type : Measure Element
Namespace http://string.drv.de/xmlschema/string
Type
WeightMeasureType Simple Type
Overview
Measure optional WeightMeasureType Simple Type
Source
<xs:element name="Measure" type="WeightMeasureType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PackageWeightType Complex Type | String Schema


Weight Element

String Schema
Weight Element
String Schema > PackageWeightType Complex Type : Weight Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
Weight optional xs:int
Source
<xs:element name="Weight" type="xs:int" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PackageWeightType Complex Type | String Schema


PassportCitizenOfForeignCountryEverSinceType Complex Type

String Schema
PassportCitizenOfForeignCountryEverSinceType Complex Type
String Schema : PassportCitizenOfForeignCountryEverSinceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Nationality Element IsCitizenOfForeignCountry Element Sequence PassportCitizenOfForeignCountryEverSinceType Complex Type
Overview
PassportCitizenOfForeignCountryEverSinceType
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Used By
CitizenOfForeignCountryEverSince Element
Source
<xs:complexType name="PassportCitizenOfForeignCountryEverSinceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="IsCitizenOfForeignCountry" type="xs:boolean" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Nationality" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


IsCitizenOfForeignCountry Element

String Schema
IsCitizenOfForeignCountry Element
String Schema > PassportCitizenOfForeignCountryEverSinceType Complex Type : IsCitizenOfForeignCountry Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
IsCitizenOfForeignCountry optional xs:boolean
Source
<xs:element name="IsCitizenOfForeignCountry" type="xs:boolean" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportCitizenOfForeignCountryEverSinceType Complex Type | String Schema


Nationality Element

String Schema
Nationality Element
String Schema > PassportCitizenOfForeignCountryEverSinceType Complex Type : Nationality Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Nationality optional xs:string
Source
<xs:element name="Nationality" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportCitizenOfForeignCountryEverSinceType Complex Type | String Schema


PassportCitizenOfForeignCountryNowType Complex Type

String Schema
PassportCitizenOfForeignCountryNowType Complex Type
String Schema : PassportCitizenOfForeignCountryNowType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence PassportCitizenOfForeignCountryNowType Complex Type
Overview
PassportCitizenOfForeignCountryNowType
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
Used By
CitizenOfForeignCountryNow Element
Source
<xs:complexType name="PassportCitizenOfForeignCountryNowType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="IsCitizenOfForeignCountry" type="xs:boolean" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Nationality" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Source" type="NationalitySourceType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="SourceOtherInfo" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


IsCitizenOfForeignCountry Element

String Schema
IsCitizenOfForeignCountry Element
String Schema > PassportCitizenOfForeignCountryNowType Complex Type : IsCitizenOfForeignCountry Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
IsCitizenOfForeignCountry optional xs:boolean
Source
<xs:element name="IsCitizenOfForeignCountry" type="xs:boolean" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportCitizenOfForeignCountryNowType Complex Type | String Schema


Nationality Element

String Schema
Nationality Element
String Schema > PassportCitizenOfForeignCountryNowType Complex Type : Nationality Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Nationality optional xs:string
Source
<xs:element name="Nationality" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportCitizenOfForeignCountryNowType Complex Type | String Schema


Source Element

String Schema
Source Element
String Schema > PassportCitizenOfForeignCountryNowType Complex Type : Source Element
Namespace http://string.drv.de/xmlschema/string
Type
NationalitySourceType Simple Type
Overview
Source optional NationalitySourceType Simple Type
Source
<xs:element name="Source" type="NationalitySourceType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportCitizenOfForeignCountryNowType Complex Type | String Schema


SourceOtherInfo Element

String Schema
SourceOtherInfo Element
String Schema > PassportCitizenOfForeignCountryNowType Complex Type : SourceOtherInfo Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
SourceOtherInfo optional xs:string
Source
<xs:element name="SourceOtherInfo" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportCitizenOfForeignCountryNowType Complex Type | String Schema


PassportParentInfoType Complex Type

String Schema
PassportParentInfoType Complex Type
String Schema : PassportParentInfoType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Prename Element Surname Element Sequence PassportParentInfoType Complex Type
Overview
PassportParentInfoType
Sequence
Surname optional xs:string
Prename optional xs:string
Used By
FatherInfo Element
MotherInfo Element
Source
<xs:complexType name="PassportParentInfoType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Surname" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="Prename" type="xs:string" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Prename Element

String Schema
Prename Element
String Schema > PassportParentInfoType Complex Type : Prename Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Prename optional xs:string
Source
<xs:element name="Prename" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportParentInfoType Complex Type | String Schema


Surname Element

String Schema
Surname Element
String Schema > PassportParentInfoType Complex Type : Surname Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Surname optional xs:string
Source
<xs:element name="Surname" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportParentInfoType Complex Type | String Schema


PassportStayInfoType Complex Type

String Schema
PassportStayInfoType Complex Type
String Schema : PassportStayInfoType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Phone Element CountryCode Element Name Element Sequence Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence PassportStayInfoType Complex Type
Overview
PassportStayInfoType
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Used By
StayInfo Element
Source
<xs:complexType name="PassportStayInfoType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Address1" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="Address2" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="Appartement" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="City" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="StateOrRegion" type="xs:string" minOccurs="0" maxOccurs="1" />
    <xs:element name="Country" type="CountryType" minOccurs="0" maxOccurs="1" />
    <xs:element name="Phone" type="xs:string" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Address1 Element

String Schema
Address1 Element
String Schema > PassportStayInfoType Complex Type : Address1 Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Address1 optional xs:string
Source
<xs:element name="Address1" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


Address2 Element

String Schema
Address2 Element
String Schema > PassportStayInfoType Complex Type : Address2 Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Address2 optional xs:string
Source
<xs:element name="Address2" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


Appartement Element

String Schema
Appartement Element
String Schema > PassportStayInfoType Complex Type : Appartement Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Appartement optional xs:string
Source
<xs:element name="Appartement" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


City Element

String Schema
City Element
String Schema > PassportStayInfoType Complex Type : City Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
City optional xs:string
Source
<xs:element name="City" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


Country Element

String Schema
Country Element
String Schema > PassportStayInfoType Complex Type : Country Element
Namespace http://string.drv.de/xmlschema/string
Type
CountryType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element
Overview
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Country" type="CountryType" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


Phone Element

String Schema
Phone Element
String Schema > PassportStayInfoType Complex Type : Phone Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Phone optional xs:string
Source
<xs:element name="Phone" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


StateOrRegion Element

String Schema
StateOrRegion Element
String Schema > PassportStayInfoType Complex Type : StateOrRegion Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
StateOrRegion optional xs:string
Source
<xs:element name="StateOrRegion" type="xs:string" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportStayInfoType Complex Type | String Schema


PassportType Complex Type

String Schema
PassportType Complex Type
String Schema : PassportType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence PassportType Complex Type
Overview
PassportType
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
Used By
Passport Element
Passport Element
Passport Element
Source
<xs:complexType name="PassportType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="PassportNumber" type="xs:string" minOccurs="1" maxOccurs="1" />
    <xs:element name="Surname" type="xs:string" minOccurs="1" maxOccurs="1" />
    <xs:element name="BirthName" type="xs:string" minOccurs="1" maxOccurs="1" />
    <xs:element name="Prename" type="xs:string" minOccurs="1" maxOccurs="1" />
    <xs:element name="BirthDate" type="DateType" minOccurs="1" maxOccurs="1" />
    <xs:element name="Nationality" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Gender" type="GenderType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="IssueDate" type="DateType" minOccurs="1" maxOccurs="1" />
    <xs:element name="ExpirationDate" type="DateType" minOccurs="1" maxOccurs="1" />
    <xs:element name="CityOfBirth" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="CountryOfBirth" type="CountryType" minOccurs="0" maxOccurs="1" nillable="true" />
    <xs:element name="Authority" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Authority Element

String Schema
Authority Element
String Schema > PassportType Complex Type : Authority Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Authority optional xs:string
Source
<xs:element name="Authority" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


BirthDate Element

String Schema
BirthDate Element
String Schema > PassportType Complex Type : BirthDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
BirthDate DateType Simple Type
Source
<xs:element name="BirthDate" type="DateType" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


BirthName Element

String Schema
BirthName Element
String Schema > PassportType Complex Type : BirthName Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
BirthName xs:string
Source
<xs:element name="BirthName" type="xs:string" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


CityOfBirth Element

String Schema
CityOfBirth Element
String Schema > PassportType Complex Type : CityOfBirth Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
CityOfBirth optional xs:string
Source
<xs:element name="CityOfBirth" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


CountryOfBirth Element

String Schema
CountryOfBirth Element
String Schema > PassportType Complex Type : CountryOfBirth Element
Namespace http://string.drv.de/xmlschema/string
Type
CountryType Complex Type
Diagram
CountryCode Element Name Element Sequence CountryOfBirth Element
Overview
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="CountryOfBirth" type="CountryType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


ExpirationDate Element

String Schema
ExpirationDate Element
String Schema > PassportType Complex Type : ExpirationDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
ExpirationDate DateType Simple Type
Source
<xs:element name="ExpirationDate" type="DateType" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


Gender Element

String Schema
Gender Element
String Schema > PassportType Complex Type : Gender Element
Namespace http://string.drv.de/xmlschema/string
Type
GenderType Simple Type
Overview
Gender optional GenderType Simple Type
Source
<xs:element name="Gender" type="GenderType" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


IssueDate Element

String Schema
IssueDate Element
String Schema > PassportType Complex Type : IssueDate Element
Namespace http://string.drv.de/xmlschema/string
Type
DateType Simple Type
Overview
IssueDate DateType Simple Type
Source
<xs:element name="IssueDate" type="DateType" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


Nationality Element

String Schema
Nationality Element
String Schema > PassportType Complex Type : Nationality Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Nationality optional xs:string
Source
<xs:element name="Nationality" type="xs:string" minOccurs="0" maxOccurs="1" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


PassportNumber Element

String Schema
PassportNumber Element
String Schema > PassportType Complex Type : PassportNumber Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
PassportNumber xs:string
Source
<xs:element name="PassportNumber" type="xs:string" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


Prename Element

String Schema
Prename Element
String Schema > PassportType Complex Type : Prename Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Prename xs:string
Source
<xs:element name="Prename" type="xs:string" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


Surname Element

String Schema
Surname Element
String Schema > PassportType Complex Type : Surname Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Surname xs:string
Source
<xs:element name="Surname" type="xs:string" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PassportType Complex Type | String Schema


PosType Complex Type

String Schema
PosType Complex Type
String Schema : PosType Complex Type
Description
Provides information on the originator of the query
Namespace http://string.drv.de/xmlschema/string
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element Sequence BookingChannel Element ReceiverMatch Element Organisation Element OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element ID Element Sequence Requestor Element Languages Element Currency Element Country Element Agency Element Sequence Sequence PosType Complex Type
Overview
PosType
Provides information on the originator of the query
Sequence
Sequence
Agency
Identification of the executing agency
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Currency CurrencyCodeType Simple Type
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Used By
POS Element
POS Element
Source
<xs:complexType name="PosType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Provides information on the originator of the query</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:sequence>
      <xs:element name="Agency">
        <xs:annotation>
          <xs:documentation>Identification of the executing agency</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="Country" type="CountryType" minOccurs="0" maxOccurs="1" />
      <xs:element name="Currency" type="CurrencyCodeType" />
      <xs:element name="Languages">
        <xs:annotation>
          <xs:documentation>ISO Language Code of the generated Language(s) of the originator instance.
In case of a multiple language support one is defined as the primary language</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PrimaryLanguage" type="xs:language" />
            <xs:element name="AdditionalLanguages" type="xs:language" minOccurs="0" maxOccurs="3" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:element name="Requestor" type="RequestorInformationType" />
    <xs:element name="ReceiverMatch" minOccurs="0">
      <xs:annotation>
        <xs:documentation>The corresponding ID, the RequestorID is mapped with in the receivers system</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="ID" />
        </xs:sequence>
      </xs:complexType>
    </xs:element>
    <xs:element name="BookingChannel" type="BookingChannelType" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


BookingChannel Element

String Schema
BookingChannel Element
String Schema > PosType Complex Type : BookingChannel Element
Namespace http://string.drv.de/xmlschema/string
Type
BookingChannelType Complex Type
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element Sequence BookingChannel Element
Overview
BookingChannel BookingChannelType Complex Type
Sequence
Type
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="BookingChannel" type="BookingChannelType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PosType Complex Type | String Schema


ReceiverMatch Element

String Schema
ReceiverMatch Element
String Schema > PosType Complex Type : ReceiverMatch Element
Description
The corresponding ID, the RequestorID is mapped with in the receivers system
Namespace http://string.drv.de/xmlschema/string
Diagram
ID Element Sequence ReceiverMatch Element
Overview
ReceiverMatch optional
The corresponding ID, the RequestorID is mapped with in the receivers system
Sequence
ID
Source
<xs:element name="ReceiverMatch" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>The corresponding ID, the RequestorID is mapped with in the receivers system</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ID" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PosType Complex Type | String Schema


ID Element

String Schema
ID Element
String Schema > PosType Complex Type > ReceiverMatch Element : ID Element
Namespace http://string.drv.de/xmlschema/string
Overview
ID
Source
<xs:element name="ID" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceiverMatch Element | PosType Complex Type | String Schema


Requestor Element

String Schema
Requestor Element
String Schema > PosType Complex Type : Requestor Element
Namespace http://string.drv.de/xmlschema/string
Type
RequestorInformationType Complex Type
Diagram
Organisation Element OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element ID Element Sequence Requestor Element
Overview
Requestor RequestorInformationType Complex Type
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
Source
<xs:element name="Requestor" type="RequestorInformationType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PosType Complex Type | String Schema


Agency Element

String Schema
Agency Element
String Schema > PosType Complex Type : Agency Element
Description
Identification of the executing agency
Namespace http://string.drv.de/xmlschema/string
Overview
Agency
Identification of the executing agency
Source
<xs:element name="Agency" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Identification of the executing agency</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PosType Complex Type | String Schema


Country Element

String Schema
Country Element
String Schema > PosType Complex Type : Country Element
Namespace http://string.drv.de/xmlschema/string
Type
CountryType Complex Type
Diagram
CountryCode Element Name Element Sequence Country Element
Overview
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Source
<xs:element name="Country" type="CountryType" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PosType Complex Type | String Schema


Currency Element

String Schema
Currency Element
String Schema > PosType Complex Type : Currency Element
Namespace http://string.drv.de/xmlschema/string
Type
CurrencyCodeType Simple Type
Overview
Currency CurrencyCodeType Simple Type
Source
<xs:element name="Currency" type="CurrencyCodeType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PosType Complex Type | String Schema


Languages Element

String Schema
Languages Element
String Schema > PosType Complex Type : Languages Element
Description
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Namespace http://string.drv.de/xmlschema/string
Diagram
AdditionalLanguages Element PrimaryLanguage Element Sequence Languages Element
Overview
Languages
ISO Language Code of the generated Language(s) of the originator instance. In case of a multiple language support one is defined as the primary language
Sequence
PrimaryLanguage xs:language
AdditionalLanguages 0..3 xs:language
Source
<xs:element name="Languages" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ISO Language Code of the generated Language(s) of the originator instance.
In case of a multiple language support one is defined as the primary language</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PrimaryLanguage" type="xs:language" />
      <xs:element name="AdditionalLanguages" type="xs:language" minOccurs="0" maxOccurs="3" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PosType Complex Type | String Schema


AdditionalLanguages Element

String Schema
AdditionalLanguages Element
String Schema > PosType Complex Type > Languages Element : AdditionalLanguages Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:language
Overview
AdditionalLanguages 0..3 xs:language
Source
<xs:element name="AdditionalLanguages" type="xs:language" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Languages Element | PosType Complex Type | String Schema


PrimaryLanguage Element

String Schema
PrimaryLanguage Element
String Schema > PosType Complex Type > Languages Element : PrimaryLanguage Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:language
Overview
PrimaryLanguage xs:language
Source
<xs:element name="PrimaryLanguage" type="xs:language" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Languages Element | PosType Complex Type | String Schema


PricesRequestType Complex Type

String Schema
PricesRequestType Complex Type
String Schema : PricesRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence PricesRequestType Complex Type
Overview
PricesRequestType
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Used By
RequestedPrices Element
RequestedPrices Element
RequestedPrices Element
RequestedPrices Element
RequestedPrices Element
Source
<xs:complexType name="PricesRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="DetailPrices" type="CommonPriceRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


DetailPrices Element

String Schema
DetailPrices Element
String Schema > PricesRequestType Complex Type : DetailPrices Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonPriceRequestType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element
Overview
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="DetailPrices" type="CommonPriceRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PricesRequestType Complex Type | String Schema


PricesResponseType Complex Type

String Schema
PricesResponseType Complex Type
String Schema : PricesResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Sequence BookingPrice Element Sequence TravellerPrice Element Sequence ServiceTypePrice Element Sequence ServicePrice Element Choice Sequence TotalPrices Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element Sequence PricesResponseType Complex Type
Overview
PricesResponseType
Sequence
DetailPrices 0..∞ CommonPriceResponseType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
TotalPrices 0..∞ TotalPriceType Complex Type
Sequence
Choice
ServicePrice CommonTotalServicePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
ServiceTypePrice CommonTotalServiceTypePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
TravellerPrice CommonTotalTravellerPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
BookingPrice CommonTotalBookingPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Used By
Prices Element
Source
<xs:complexType name="PricesResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="DetailPrices" type="CommonPriceResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="TotalPrices" type="TotalPriceType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


DetailPrices Element

String Schema
DetailPrices Element
String Schema > PricesResponseType Complex Type : DetailPrices Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonPriceResponseType Complex Type
Diagram
AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element VATIncluded Element VATPercentage Element Currency Element Amount Element Sequence VATAmount Element Currency Element Amount Element Sequence Price Element Quantity Element LanguageCode Element Text Element Sequence PriceName Element Sequence DetailPrices Element
Overview
DetailPrices 0..∞ CommonPriceResponseType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
Source
<xs:element name="DetailPrices" type="CommonPriceResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PricesResponseType Complex Type | String Schema


TotalPrices Element

String Schema
TotalPrices Element
String Schema > PricesResponseType Complex Type : TotalPrices Element
Namespace http://string.drv.de/xmlschema/string
Type
TotalPriceType Complex Type
Diagram
BookingPrice Element TravellerPrice Element ServiceTypePrice Element ServicePrice Element Choice Sequence TotalPrices Element
Overview
TotalPrices 0..∞ TotalPriceType Complex Type
Sequence
Choice
ServicePrice CommonTotalServicePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
ServiceTypePrice CommonTotalServiceTypePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
TravellerPrice CommonTotalTravellerPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
BookingPrice CommonTotalBookingPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="TotalPrices" type="TotalPriceType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PricesResponseType Complex Type | String Schema


ProductCodeRequestType Complex Type

String Schema
ProductCodeRequestType Complex Type
String Schema : ProductCodeRequestType Complex Type
Description
Touroperator specific product code
Namespace http://string.drv.de/xmlschema/string
Diagram
Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence ProductCodeRequestType Complex Type
Overview
ProductCodeRequestType
Touroperator specific product code
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Used By
Product Element
Product Element
Product Element
Product Element
Product Element
Source
<xs:complexType name="ProductCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator specific product code</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" />
    <xs:element name="Type" type="xs:token" minOccurs="0" />
    <xs:element name="Catalogue" type="CatalogueRequestType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Catalogue Element

String Schema
Catalogue Element
String Schema > ProductCodeRequestType Complex Type : Catalogue Element
Namespace http://string.drv.de/xmlschema/string
Type
CatalogueRequestType Complex Type
Diagram
Page Element Season Element Code Element Sequence Catalogue Element
Overview
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Source
<xs:element name="Catalogue" type="CatalogueRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeRequestType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > ProductCodeRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeRequestType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > ProductCodeRequestType Complex Type : Type Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeRequestType Complex Type | String Schema


ProductCodeResponseType Complex Type

String Schema
ProductCodeResponseType Complex Type
String Schema : ProductCodeResponseType Complex Type
Description
Touroperator specific product code
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence ProductCodeResponseType Complex Type
Overview
ProductCodeResponseType
Touroperator specific product code
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Product Element
Product Element
Product Element
Product Element
Product Element
Source
<xs:complexType name="ProductCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator specific product code</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" />
    <xs:element name="Type" type="xs:token" minOccurs="0" />
    <xs:element name="Description" type="TextLanguageType" minOccurs="0" />
    <xs:element name="Catalogue" type="CatalogueResponseType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Catalogue Element

String Schema
Catalogue Element
String Schema > ProductCodeResponseType Complex Type : Catalogue Element
Namespace http://string.drv.de/xmlschema/string
Type
CatalogueResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Page Element Season Element Code Element Sequence Catalogue Element
Overview
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Catalogue" type="CatalogueResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeResponseType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > ProductCodeResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > ProductCodeResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeResponseType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > ProductCodeResponseType Complex Type : Type Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Type optional xs:token
Source
<xs:element name="Type" type="xs:token" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductCodeResponseType Complex Type | String Schema


RegionsType Complex Type

String Schema
RegionsType Complex Type
String Schema : RegionsType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Region Element Sequence RegionsType Complex Type
Overview
RegionsType
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Regions Element
Source
<xs:complexType name="RegionsType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Region" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="Code" />
          <xs:element name="Description" type="TextLanguageType" minOccurs="0" />
        </xs:sequence>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Region Element

String Schema
Region Element
String Schema > RegionsType Complex Type : Region Element
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence Region Element
Overview
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Region" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Code" />
      <xs:element name="Description" type="TextLanguageType" minOccurs="0" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RegionsType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > RegionsType Complex Type > Region Element : Code Element
Namespace http://string.drv.de/xmlschema/string
Overview
Code
Source
<xs:element name="Code" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Region Element | RegionsType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > RegionsType Complex Type > Region Element : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Region Element | RegionsType Complex Type | String Schema


RequestorInformationType Complex Type

String Schema
RequestorInformationType Complex Type
String Schema : RequestorInformationType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Organisation Element OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element Type Element ID Element Sequence RequestorInformationType Complex Type
Overview
RequestorInformationType
Sequence
ID
ID of the requestor which must be unique within the requestors overall system
Type optional
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
Used By
Requestor Element
Source
<xs:complexType name="RequestorInformationType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:annotation>
      <xs:documentation>Details on the requestor which at least must be a RequestorID</xs:documentation>
    </xs:annotation>
    <xs:element name="ID">
      <xs:annotation>
        <xs:documentation>ID of the requestor which must be unique within the requestors overall system</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Type" minOccurs="0" />
    <xs:element name="CompanyName" type="CompanyNameType" minOccurs="0" />
    <xs:element name="Organisation" minOccurs="0">
      <xs:annotation>
        <xs:documentation>As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization
Thereby a hierarchy will be represented by a LevelID
Only 1 digit LevelIds are provided</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="Level" maxOccurs="10">
            <xs:annotation>
              <xs:documentation>A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="LevelID" type="xs:int">
                  <xs:annotation>
                    <xs:documentation>Only 1 digit LevelIds are provided</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="Name" />
                <xs:element name="Value" />
              </xs:sequence>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CompanyName Element

String Schema
CompanyName Element
String Schema > RequestorInformationType Complex Type : CompanyName Element
Namespace http://string.drv.de/xmlschema/string
Type
CompanyNameType Complex Type
Diagram
OrganisationLevelID Element Code Element ShortName Element Sequence CompanyName Element
Overview
CompanyName optional CompanyNameType Complex Type
Sequence
ShortName optional
Code optional
OrganisationLevelID optional xs:int
As the company could be part of a bigger organization, one might provide the level in the hierarchy of that organization Only 1 digit LevelIds are provided
Source
<xs:element name="CompanyName" type="CompanyNameType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RequestorInformationType Complex Type | String Schema


ID Element

String Schema
ID Element
String Schema > RequestorInformationType Complex Type : ID Element
Description
ID of the requestor which must be unique within the requestors overall system
Namespace http://string.drv.de/xmlschema/string
Overview
ID
ID of the requestor which must be unique within the requestors overall system
Source
<xs:element name="ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ID of the requestor which must be unique within the requestors overall system</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RequestorInformationType Complex Type | String Schema


Organisation Element

String Schema
Organisation Element
String Schema > RequestorInformationType Complex Type : Organisation Element
Description
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Namespace http://string.drv.de/xmlschema/string
Diagram
Level Element Sequence Organisation Element
Overview
Organisation optional
As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization Thereby a hierarchy will be represented by a LevelID Only 1 digit LevelIds are provided
Sequence
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
Source
<xs:element name="Organisation" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>As the company could be part of a bigger organization, one might provide the hierarchial structure of that organization
Thereby a hierarchy will be represented by a LevelID
Only 1 digit LevelIds are provided</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Level" maxOccurs="10">
        <xs:annotation>
          <xs:documentation>A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LevelID" type="xs:int">
              <xs:annotation>
                <xs:documentation>Only 1 digit LevelIds are provided</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="Name" />
            <xs:element name="Value" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RequestorInformationType Complex Type | String Schema


Level Element

String Schema
Level Element
String Schema > RequestorInformationType Complex Type > Organisation Element : Level Element
Description
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Namespace http://string.drv.de/xmlschema/string
Diagram
Value Element Name Element LevelID Element Sequence Level Element
Overview
Level 1..10
A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair
Sequence
LevelID xs:int
Only 1 digit LevelIds are provided
Name
Value
Source
<xs:element name="Level" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>A level will be represented by a LevelID (1 digit) and a corresponding key (name) value pair</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LevelID" type="xs:int">
        <xs:annotation>
          <xs:documentation>Only 1 digit LevelIds are provided</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="Name" />
      <xs:element name="Value" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
Organisation Element | RequestorInformationType Complex Type | String Schema


LevelID Element

String Schema
LevelID Element
String Schema > RequestorInformationType Complex Type > Organisation Element > Level Element : LevelID Element
Description
Only 1 digit LevelIds are provided
Namespace http://string.drv.de/xmlschema/string
Type
xs:int
Overview
LevelID xs:int
Only 1 digit LevelIds are provided
Source
<xs:element name="LevelID" type="xs:int" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Only 1 digit LevelIds are provided</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Level Element | Organisation Element | RequestorInformationType Complex Type | String Schema


Name Element

String Schema
Name Element
String Schema > RequestorInformationType Complex Type > Organisation Element > Level Element : Name Element
Namespace http://string.drv.de/xmlschema/string
Overview
Name
Source
<xs:element name="Name" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Level Element | Organisation Element | RequestorInformationType Complex Type | String Schema


Value Element

String Schema
Value Element
String Schema > RequestorInformationType Complex Type > Organisation Element > Level Element : Value Element
Namespace http://string.drv.de/xmlschema/string
Overview
Value
Source
<xs:element name="Value" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Level Element | Organisation Element | RequestorInformationType Complex Type | String Schema


Type Element

String Schema
Type Element
String Schema > RequestorInformationType Complex Type : Type Element
Namespace http://string.drv.de/xmlschema/string
Overview
Type optional
Source
<xs:element name="Type" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RequestorInformationType Complex Type | String Schema


RoomCodeRequestType Complex Type

String Schema
RoomCodeRequestType Complex Type
String Schema : RoomCodeRequestType Complex Type
Description
Touroperator specific room code
Namespace http://string.drv.de/xmlschema/string
Diagram
Code Element Sequence RoomCodeRequestType Complex Type
Overview
RoomCodeRequestType
Touroperator specific room code
Sequence
Code xs:token
Used By
RoomCode Element
Source
<xs:complexType name="RoomCodeRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator specific room code</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Code" type="xs:token" nillable="false" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > RoomCodeRequestType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomCodeRequestType Complex Type | String Schema


RoomCodeResponseType Complex Type

String Schema
RoomCodeResponseType Complex Type
String Schema : RoomCodeResponseType Complex Type
Description
Touroperator specific room code
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of RoomCodeRequestType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence RoomCodeResponseType Complex Type
Overview
RoomCodeResponseType Extension of RoomCodeRequestType Complex Type
Touroperator specific room code
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
RoomCode Element
Source
<xs:complexType name="RoomCodeResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Touroperator specific room code</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="RoomCodeRequestType">
      <xs:sequence>
        <xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


Code Element

String Schema
Code Element
String Schema > RoomCodeResponseType Complex Type : Code Element
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Source
<xs:element name="Code" type="xs:token" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomCodeResponseType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > RoomCodeResponseType Complex Type : Description Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomCodeResponseType Complex Type | String Schema


RoomRequestType Complex Type

String Schema
RoomRequestType Complex Type
String Schema : RoomRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonRoomType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element Attribute Element Sequence Attributes Element Code Element Sequence Board Element Code Element Sequence RoomCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence RoomRequestType Complex Type
Overview
RoomRequestType Extension of CommonRoomType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Used By
Room Element
Source
<xs:complexType name="RoomRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonRoomType">
      <xs:annotation>
        <xs:documentation>Room information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="RoomCode" type="RoomCodeRequestType" minOccurs="0" />
        <xs:element name="Board" type="BoardCodeRequestType" minOccurs="0" />
        <xs:element name="IncludedExtras" type="IncludedExtrasRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Included extras for this room</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>List of customer requests</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > RoomRequestType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomRequestType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > RoomRequestType Complex Type : Attributes Element
Description
List of attributes of this room
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this room</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomRequestType Complex Type | String Schema


Board Element

String Schema
Board Element
String Schema > RoomRequestType Complex Type : Board Element
Namespace http://string.drv.de/xmlschema/string
Type
BoardCodeRequestType Complex Type
Diagram
AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Code Element Sequence Board Element
Overview
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Board" type="BoardCodeRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomRequestType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > RoomRequestType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CustomerRequests" type="CustomerRequestRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomRequestType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > RoomRequestType Complex Type : Identifier Element
Description
Unique room identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique room identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique room identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomRequestType Complex Type | String Schema


IncludedExtras Element

String Schema
IncludedExtras Element
String Schema > RoomRequestType Complex Type : IncludedExtras Element
Description
Included extras for this room
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtrasRequestType Complex Type
Diagram
Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element
Overview
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="IncludedExtras" type="IncludedExtrasRequestType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Included extras for this room</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomRequestType Complex Type | String Schema


RoomCode Element

String Schema
RoomCode Element
String Schema > RoomRequestType Complex Type : RoomCode Element
Namespace http://string.drv.de/xmlschema/string
Type
RoomCodeRequestType Complex Type
Diagram
Code Element Sequence RoomCode Element
Overview
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Source
<xs:element name="RoomCode" type="RoomCodeRequestType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomRequestType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > RoomRequestType Complex Type : State Element
Description
Room bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Room bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Room bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomRequestType Complex Type | String Schema


RoomResponseType Complex Type

String Schema
RoomResponseType Complex Type
String Schema : RoomResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of CommonRoomType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element ExtraCode Element AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element LanguageCode Element Text Element Sequence Description Element Attribute Element Sequence Attributes Element Code Element Sequence Board Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence RoomCode Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element State Element Identifier Element Sequence RoomResponseType Complex Type
Overview
RoomResponseType Extension of CommonRoomType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Used By
Room Element
Source
<xs:complexType name="RoomResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="CommonRoomType">
      <xs:annotation>
        <xs:documentation>Room information</xs:documentation>
      </xs:annotation>
      <xs:sequence>
        <xs:element name="RoomCode" type="RoomCodeResponseType" minOccurs="0" />
        <xs:element name="Board" type="BoardCodeResponseType" minOccurs="0" />
        <xs:element name="IncludedExtras" type="IncludedExtrasResponseType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Included extras for this room</xs:documentation>
          </xs:annotation>
        </xs:element>
        <xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0">
          <xs:annotation>
            <xs:documentation>List of customer requests</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > RoomResponseType Complex Type : AssignedTravellers Element
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomResponseType Complex Type | String Schema


Attributes Element

String Schema
Attributes Element
String Schema > RoomResponseType Complex Type : Attributes Element
Description
List of attributes of this room
Namespace http://string.drv.de/xmlschema/string
Type
AttributesType Complex Type
Diagram
AttributeSource Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence Attribute Element Sequence Attributes Element
Overview
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Source
<xs:element name="Attributes" type="AttributesType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of attributes of this room</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomResponseType Complex Type | String Schema


Board Element

String Schema
Board Element
String Schema > RoomResponseType Complex Type : Board Element
Namespace http://string.drv.de/xmlschema/string
Type
BoardCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Code Element Sequence Board Element
Overview
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Board" type="BoardCodeResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomResponseType Complex Type | String Schema


CustomerRequests Element

String Schema
CustomerRequests Element
String Schema > RoomResponseType Complex Type : CustomerRequests Element
Description
List of customer requests
Namespace http://string.drv.de/xmlschema/string
Type
CustomerRequestResponseType Complex Type
Diagram
State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element
Overview
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Source
<xs:element name="CustomerRequests" type="CustomerRequestResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of customer requests</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomResponseType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > RoomResponseType Complex Type : Identifier Element
Description
Unique room identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique room identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique room identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomResponseType Complex Type | String Schema


IncludedExtras Element

String Schema
IncludedExtras Element
String Schema > RoomResponseType Complex Type : IncludedExtras Element
Description
Included extras for this room
Namespace http://string.drv.de/xmlschema/string
Type
IncludedExtrasResponseType Complex Type
Diagram
Description Element Code Element Sequence ExtraCode Element Identifier Element Sequence AssignedTravellers Element Sequence IncludedExtra Element Sequence IncludedExtras Element
Overview
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="IncludedExtras" type="IncludedExtrasResponseType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Included extras for this room</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomResponseType Complex Type | String Schema


RoomCode Element

String Schema
RoomCode Element
String Schema > RoomResponseType Complex Type : RoomCode Element
Namespace http://string.drv.de/xmlschema/string
Type
RoomCodeResponseType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element Sequence RoomCode Element
Overview
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="RoomCode" type="RoomCodeResponseType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
RoomResponseType Complex Type | String Schema


State Element

String Schema
State Element
String Schema > RoomResponseType Complex Type : State Element
Description
Room bookability state
Namespace http://string.drv.de/xmlschema/string
Type
BookabilityStateType Simple Type
Overview
State BookabilityStateType Simple Type
Room bookability state
Source
<xs:element name="State" type="BookabilityStateType" nillable="false" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Room bookability state</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RoomResponseType Complex Type | String Schema


ServiceRequestReferencesType Complex Type

String Schema
ServiceRequestReferencesType Complex Type
String Schema : ServiceRequestReferencesType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element Sequence ServiceRequestReferencesType Complex Type
Overview
ServiceRequestReferencesType
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
References Element
Source
<xs:complexType name="ServiceRequestReferencesType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="ExternalReference" type="ExternalReferenceType" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


ExternalReference Element

String Schema
ExternalReference Element
String Schema > ServiceRequestReferencesType Complex Type : ExternalReference Element
Namespace http://string.drv.de/xmlschema/string
Type
ExternalReferenceType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element
Overview
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="ExternalReference" type="ExternalReferenceType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ServiceRequestReferencesType Complex Type | String Schema


ServiceResponseReferencesType Complex Type

String Schema
ServiceResponseReferencesType Complex Type
String Schema : ServiceResponseReferencesType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
URL Element Id Element Provider Element Sequence ExternalContent Element LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element Sequence ServiceResponseReferencesType Complex Type
Overview
ServiceResponseReferencesType
Sequence
ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Used By
References Element
Source
<xs:complexType name="ServiceResponseReferencesType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="ExternalReference" type="ExternalReferenceType">
      <xs:annotation>
        <xs:documentation>Reference in an "external" system</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="ExternalContent" type="ExternalContentRequestType">
      <xs:annotation>
        <xs:documentation>Reference onto "Rich / Non Bookable Content"</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


ExternalContent Element

String Schema
ExternalContent Element
String Schema > ServiceResponseReferencesType Complex Type : ExternalContent Element
Description
Reference onto "Rich / Non Bookable Content"
Namespace http://string.drv.de/xmlschema/string
Type
ExternalContentRequestType Complex Type
Diagram
URL Element Id Element Provider Element Sequence ExternalContent Element
Overview
ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Source
<xs:element name="ExternalContent" type="ExternalContentRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference onto "Rich / Non Bookable Content"</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ServiceResponseReferencesType Complex Type | String Schema


ExternalReference Element

String Schema
ExternalReference Element
String Schema > ServiceResponseReferencesType Complex Type : ExternalReference Element
Description
Reference in an "external" system
Namespace http://string.drv.de/xmlschema/string
Type
ExternalReferenceType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element
Overview
ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="ExternalReference" type="ExternalReferenceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Reference in an "external" system</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ServiceResponseReferencesType Complex Type | String Schema


ServicesRequestType Complex Type

String Schema
ServicesRequestType Complex Type
String Schema : ServicesRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Service Element Sequence ServicesRequestType Complex Type
Overview
ServicesRequestType
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
MarketingCarrier optional AirlineRequestType Complex Type
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
Services Element
Source
<xs:complexType name="ServicesRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Service" nillable="true" minOccurs="0" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:choice>
            <xs:element name="Accommodation" type="AccommodationRequestType" />
            <xs:element name="Flight" type="FlightRequestType" />
            <xs:element name="CommonService" type="CommonServiceRequestType" />
          </xs:choice>
          <xs:element name="References" type="ServiceRequestReferencesType" minOccurs="0" />
        </xs:sequence>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Service Element

String Schema
Service Element
String Schema > ServicesRequestType Complex Type : Service Element
Namespace http://string.drv.de/xmlschema/string
Diagram
Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element Sequence References Element CommonService Element Flight Element Accommodation Element Choice Sequence Service Element
Overview
Service 0..∞
Sequence
Choice
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
MarketingCarrier optional AirlineRequestType Complex Type
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
MarketingCarrier optional AirlineRequestType Complex Type
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
ExtraCode optional IncludedExtraRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
VATAmount optional CurrencyAmountType Complex Type
VAT amount
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Class optional ClassBaseRequestType Complex Type
Class information of the segment
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
AssignedLegs optional IdentifiersType Complex Type
AssignedSegments optional IdentifiersType Complex Type
BaggageInfo optional BaggageInfoType Complex Type
Meal optional MealRequestType Complex Type
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
ClassCode optional ClassRequestType Complex Type
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Service" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:element name="Accommodation" type="AccommodationRequestType" />
        <xs:element name="Flight" type="FlightRequestType" />
        <xs:element name="CommonService" type="CommonServiceRequestType" />
      </xs:choice>
      <xs:element name="References" type="ServiceRequestReferencesType" minOccurs="0" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ServicesRequestType Complex Type | String Schema


References Element

String Schema
References Element
String Schema > ServicesRequestType Complex Type > Service Element : References Element
Namespace http://string.drv.de/xmlschema/string
Type
ServiceRequestReferencesType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element Sequence References Element
Overview
References optional ServiceRequestReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="References" type="ServiceRequestReferencesType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesRequestType Complex Type | String Schema


Accommodation Element

String Schema
Accommodation Element
String Schema > ServicesRequestType Complex Type > Service Element : Accommodation Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationRequestType Complex Type
Diagram
CheckInOut Element Sequence StayRequest Element CustomerRequests Element IncludedExtras Element Board Element RoomCode Element Attributes Element AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence Rooms Element Departure Element Arrival Element Sequence Bus Element Departure Element Arrival Element Sequence Ship Element Departure Element Arrival Element Sequence Rail Element Departure Element Arrival Element Sequence Flight Element Sequence InformationForTransfer Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Accommodation Element
Overview
Accommodation AccommodationRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
InformationForTransfer optional AccommodationTransferInfoRequestType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Departure optional AccommodationTransferFlightInfoRequestType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Rail optional AccommodationTransferRailInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoRequestType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoRequestType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoRequestDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoRequestType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Rooms optional AccommodationRoomsRequestType Complex Type
Sequence
Room 0..∞ RoomRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeRequestType Complex Type
Sequence
Code xs:token
Board optional BoardCodeRequestType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraRequestType Complex Type
Sequence
Code xs:token
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
StayRequest optional AccommodationStayRequestType Complex Type
Sequence
CheckInOut optional AccommodationCheckInOutType Complex Type
Check In/Out Date and Time requested by the customer
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Source
<xs:element name="Accommodation" type="AccommodationRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesRequestType Complex Type | String Schema


CommonService Element

String Schema
CommonService Element
String Schema > ServicesRequestType Complex Type > Service Element : CommonService Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonServiceRequestType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element AssignedToBooking Element AssignedServiceTypes Element AssignedServices Element AssignedTravellers Element VATIncluded Element VATPercentage Element VATAmount Element Price Element Quantity Element PriceName Element Sequence DetailPrices Element Sequence RequestedPrices Element Page Element Season Element Code Element Sequence Catalogue Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CommonService Element
Overview
CommonService CommonServiceRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="CommonService" type="CommonServiceRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesRequestType Complex Type | String Schema


Flight Element

String Schema
Flight Element
String Schema > ServicesRequestType Complex Type > Service Element : Flight Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightRequestType Complex Type
Diagram
Classes Element Carrier Element ArrivalAirport Element DepartureAirport Element TariffDetails Element Segments Element Data Element CustomerRequests Element RequestedPrices Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence Legs Element Sequence Flight Element
Overview
Flight FlightRequestType Complex Type
Sequence
Legs optional FlightLegsRequestType Complex Type
Sequence
Leg 0..∞ FlightLegRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeRequestType Complex Type
Sequence
Code xs:token
Type optional xs:token
Catalogue optional CatalogueRequestType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
RequestedPrices optional PricesRequestType Complex Type
Prices of an offer or the prices resulting from an external search
Sequence
DetailPrices 0..∞ CommonPriceRequestType Complex Type
Sequence
PriceName 0..∞ TextLanguageType Complex Type
Price description
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Quantity xs:int
Quantity of price
Price CurrencyAmountType Complex Type
Price amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATAmount optional CurrencyAmountType Complex Type
VAT amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
VATPercentage optional xs:decimal
VAT percentage
VATIncluded optional xs:boolean
Flag if VAT is included or additional
AssignedTravellers optional IdentifiersType Complex Type
List of assigned participants for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of assigned services for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of assigned service types (e.g. rooms, flight classes) for this detail price
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this price is assigned to the whole booking
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsRequestType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportRequestType Complex Type
Departure airport for the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport AirportRequestType Complex Type
Arrival airport of the segment
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
MarketingCarrier optional AirlineRequestType Complex Type
Class optional ClassBaseRequestType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassRequestType Complex Type
TariffDetails optional FlightTariffsRequestType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffRequestType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Meal optional MealRequestType Complex Type
Sequence
Code xs:token
DepartureAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
ArrivalAirport optional AirportRequestType Complex Type
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
Carrier optional AirlineRequestTypes Complex Type
Sequence
OperatingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
MarketingCarrier optional AirlineRequestType Complex Type
Choice
IataCode
IcaoCode
Classes optional FlightClassesRequestType Complex Type
Sequence
FlightClass 0..∞ BookableClassRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
ClassCode optional ClassRequestType Complex Type
Sequence
Code xs:token
IncludedExtras optional IncludedExtrasRequestType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseRequestType Complex Type
CustomerRequests optional CustomerRequestRequestType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Source
<xs:element name="Flight" type="FlightRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesRequestType Complex Type | String Schema


ServicesResponseAdditionalInfoType Complex Type

String Schema
ServicesResponseAdditionalInfoType Complex Type
String Schema : ServicesResponseAdditionalInfoType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Choice From Element Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element Choice From Element Description Element Sequence Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence ServicesResponseAdditionalInfoType Complex Type
Overview
ServicesResponseAdditionalInfoType
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Used By
AdditionalInfos Element
AdditionalInfos Element
AdditionalInfos Element
AdditionalInfos Element
AdditionalInfos Element
Source
<xs:complexType name="ServicesResponseAdditionalInfoType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="GeneralInformation" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="CancellationPolicies" type="CancellationPoliciesType" minOccurs="0" />
    <xs:element name="ModificationPolicies" type="ModficationPoliciesType" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


CancellationPolicies Element

String Schema
CancellationPolicies Element
String Schema > ServicesResponseAdditionalInfoType Complex Type : CancellationPolicies Element
Namespace http://string.drv.de/xmlschema/string
Type
CancellationPoliciesType Complex Type
Diagram
Percentage Element Sequence Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence Fees Element Sequence CancellationPolicies Element
Overview
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="CancellationPolicies" type="CancellationPoliciesType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ServicesResponseAdditionalInfoType Complex Type | String Schema


GeneralInformation Element

String Schema
GeneralInformation Element
String Schema > ServicesResponseAdditionalInfoType Complex Type : GeneralInformation Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence GeneralInformation Element
Overview
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="GeneralInformation" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ServicesResponseAdditionalInfoType Complex Type | String Schema


ModificationPolicies Element

String Schema
ModificationPolicies Element
String Schema > ServicesResponseAdditionalInfoType Complex Type : ModificationPolicies Element
Namespace http://string.drv.de/xmlschema/string
Type
ModficationPoliciesType Complex Type
Diagram
Percentage Element Sequence Amount Element Nights Element Choice From Element LanguageCode Element Text Element Sequence Description Element Sequence Fees Element Permitted Element Sequence ModificationPolicies Element
Overview
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="ModificationPolicies" type="ModficationPoliciesType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ServicesResponseAdditionalInfoType Complex Type | String Schema


ServicesResponseType Complex Type

String Schema
ServicesResponseType Complex Type
String Schema : ServicesResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Service Element Sequence ServicesResponseType Complex Type
Overview
ServicesResponseType
Sequence
Service 0..∞
Sequence
Choice
Accommodation AccommodationResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
LocationDetails AccommodationProductResponseType Complex Type
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
BusNumber optional xs:string
Rooms optional AccommodationRoomsResponseType Complex Type
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Description 0..∞ TextLanguageType Complex Type
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Stay AccommodationStayResponseType Complex Type
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightResponseType Complex Type
Sequence
Legs optional FlightLegsResponseType Complex Type
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Catalogue optional CatalogueResponseType Complex Type
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
CancellationPolicies optional CancellationPoliciesType Complex Type
ModificationPolicies optional ModficationPoliciesType Complex Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CommonService CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
References optional ServiceResponseReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Used By
Services Element
Source
<xs:complexType name="ServicesResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Service" nillable="true" minOccurs="0" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:choice>
            <xs:element name="Accommodation" type="AccommodationResponseType" />
            <xs:element name="Flight" type="FlightResponseType" />
            <xs:element name="CommonService" type="CommonServiceResponseType" />
          </xs:choice>
          <xs:element name="References" type="ServiceResponseReferencesType" minOccurs="0" />
        </xs:sequence>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Service Element

String Schema
Service Element
String Schema > ServicesResponseType Complex Type : Service Element
Namespace http://string.drv.de/xmlschema/string
Diagram
URL Element Id Element Provider Element Sequence ExternalContent Element Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element Sequence References Element CommonService Element Flight Element Accommodation Element Choice Sequence Service Element
Overview
Service 0..∞
Sequence
Choice
Accommodation AccommodationResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
LocationDetails AccommodationProductResponseType Complex Type
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Rooms optional AccommodationRoomsResponseType Complex Type
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
ExtraCode optional IncludedExtraResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Stay AccommodationStayResponseType Complex Type
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Flight FlightResponseType Complex Type
Sequence
Legs optional FlightLegsResponseType Complex Type
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Fees 0..∞ FeeType Complex Type
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Class optional ClassBaseResponseType Complex Type
Class information of the segment
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
AssignedLegs optional IdentifiersType Complex Type
AssignedSegments optional IdentifiersType Complex Type
BaggageInfo optional BaggageInfoType Complex Type
Meal optional MealResponseType Complex Type
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
ClassCode optional ClassResponseType Complex Type
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CommonService CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
References optional ServiceResponseReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Source
<xs:element name="Service" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:element name="Accommodation" type="AccommodationResponseType" />
        <xs:element name="Flight" type="FlightResponseType" />
        <xs:element name="CommonService" type="CommonServiceResponseType" />
      </xs:choice>
      <xs:element name="References" type="ServiceResponseReferencesType" minOccurs="0" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ServicesResponseType Complex Type | String Schema


References Element

String Schema
References Element
String Schema > ServicesResponseType Complex Type > Service Element : References Element
Namespace http://string.drv.de/xmlschema/string
Type
ServiceResponseReferencesType Complex Type
Diagram
URL Element Id Element Provider Element Sequence ExternalContent Element LanguageCode Element Text Element Sequence Description Element Code Element ReferenceNumber Element Sequence ExternalReference Element Sequence References Element
Overview
References optional ServiceResponseReferencesType Complex Type
Sequence
ExternalReference ExternalReferenceType Complex Type
Reference in an "external" system
Sequence
ReferenceNumber xs:int
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ExternalContent ExternalContentRequestType Complex Type
Reference onto "Rich / Non Bookable Content"
Sequence
Provider optional xs:string
Id optional xs:string
URL optional xs:string
Source
<xs:element name="References" type="ServiceResponseReferencesType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesResponseType Complex Type | String Schema


Accommodation Element

String Schema
Accommodation Element
String Schema > ServicesResponseType Complex Type > Service Element : Accommodation Element
Namespace http://string.drv.de/xmlschema/string
Type
AccommodationResponseType Complex Type
Diagram
CheckInOut Element ChargedNights Element Sequence Stay Element CustomerRequests Element IncludedExtras Element Board Element RoomCode Element Attributes Element AssignedTravellers Element State Element Identifier Element Sequence Room Element Sequence Rooms Element Departure Element Arrival Element Sequence Bus Element Departure Element Arrival Element Sequence Ship Element Departure Element Arrival Element Sequence Rail Element Departure Element Arrival Element Sequence Flight Element Sequence InformationForTransfer Element Region Element Sequence Regions Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Latitude Element Longitude Element Sequence GeoLocation Element Sequence LocationDetails Element Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Accommodation Element
Overview
Accommodation AccommodationResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
LocationDetails AccommodationProductResponseType Complex Type
Sequence
GeoLocation optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Address 0..3 AddressType Complex Type
Possibility to provide the address data in up to 3 different languages
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Regions optional RegionsType Complex Type
Sequence
Region 1..∞
Sequence
Code
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
InformationForTransfer optional AccommodationTransferInfoResponseType Complex Type
Sequence
Flight optional AccommodationTransferFlightInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Departure optional AccommodationTransferFlightInfoResponseType Complex Type
Choice
FlightReference optional
Sequence
ArrivalDate optional DateTimeType Simple Type
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
FlightNumber optional FlightNumberType Simple Type
Carrier optional AirlineResponseTypes Complex Type
Carrier information of the flight
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Rail optional AccommodationTransferRailInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Departure optional AccommodationTransferRailInfoResponseType Complex Type
Choice
RailReference optional
Sequence
Date optional DateTimeType Simple Type
Station optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
TrainNumber optional xs:string
Ship optional AccommodationTransferShipInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Departure optional AccommodationTransferShipInfoResponseType Complex Type
Choice
ShipReference optional
Sequence
Date optional DateTimeType Simple Type
Harbour optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
ShipNumber optional xs:string
Bus optional AccommodationTransferBusInfoResponseDataType Complex Type
Sequence
Arrival optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Departure optional AccommodationTransferBusInfoResponseType Complex Type
Choice
BusReference optional
Sequence
Date optional DateTimeType Simple Type
BusStation optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
BusNumber optional xs:string
Rooms optional AccommodationRoomsResponseType Complex Type
Sequence
Room 0..∞ RoomResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique room identifier
State BookabilityStateType Simple Type
Room bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this room
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
RoomCode optional RoomCodeResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Board optional BoardCodeResponseType Complex Type
Sequence
Code xs:token
Attributes 0..∞ AttributesType Complex Type
List of attributes of this board
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
AttributeSource AttributeSourceType Simple Type
Source of the attribute
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this room
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this included extra
Sequence
Identifier 1..∞ IdentifierType Simple Type
ExtraCode optional IncludedExtraResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
Stay AccommodationStayResponseType Complex Type
Sequence
ChargedNights xs:int
Charged nights for the accommodation calculated by the touroperator
CheckInOut AccommodationCheckInOutType Complex Type
Check In/Out Date and Time confirmed by the provider
CheckIn optional DateTimeType Simple Type
CheckOut optional DateTimeType Simple Type
Source
<xs:element name="Accommodation" type="AccommodationResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesResponseType Complex Type | String Schema


CommonService Element

String Schema
CommonService Element
String Schema > ServicesResponseType Complex Type > Service Element : CommonService Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonServiceResponseType Complex Type
Diagram
Fees Element Permitted Element Sequence ModificationPolicies Element Fees Element Sequence CancellationPolicies Element LanguageCode Element Text Element Sequence GeneralInformation Element Sequence AdditionalInfos Element State Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Sequence CustomerRequests Element State Element Description Element Page Element Season Element Code Element Sequence Catalogue Element LanguageCode Element Text Element Sequence Description Element Type Element Code Element Sequence Product Element PackageReference Element AttributeSource Element Description Element Code Element Sequence Attribute Element Sequence Attributes Element Identifier Element Sequence AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence CommonService Element
Overview
CommonService CommonServiceResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Percentage optional xs:decimal
Fee as percentage value
Source
<xs:element name="CommonService" type="CommonServiceResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesResponseType Complex Type | String Schema


Flight Element

String Schema
Flight Element
String Schema > ServicesResponseType Complex Type > Service Element : Flight Element
Namespace http://string.drv.de/xmlschema/string
Type
FlightResponseType Complex Type
Diagram
FlightDescription Element Classes Element Carrier Element ArrivalAirport Element DepartureAirport Element TariffDetails Element Segments Element Data Element AdditionalInfos Element CustomerRequests Element State Element Product Element PackageReference Element Attributes Element AssignedTravellers Element Quantity Element EndDate Element StartDate Element Type Element Identifier Element Sequence Leg Element Sequence Legs Element Sequence Flight Element
Overview
Flight FlightResponseType Complex Type
Sequence
Legs optional FlightLegsResponseType Complex Type
Sequence
Leg 0..∞ FlightLegResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique service identifier
Type optional xs:token
For optionally specifying the service type / kind of service
StartDate DateType Simple Type
Start date of the service
EndDate DateType Simple Type
End Date of the service
Quantity optional xs:int
Quantity of the service
AssignedTravellers optional IdentifiersType Complex Type
List of traveller identifiers assigned to this service
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this service
Sequence
Attribute 1..∞ AttributeType Complex Type
Sequence
Code xs:token
Code for the attribute
Description 0..∞ TextLanguageType Complex Type
Description for the attribute
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AttributeSource AttributeSourceType Simple Type
Source of the attribute
PackageReference optional IdentifierType Simple Type
Reference to a package in case that the current service is part of a package
Product ProductCodeResponseType Complex Type
Sequence
Code xs:token
Type optional xs:token
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Catalogue optional CatalogueResponseType Complex Type
Sequence
Code xs:token
Season optional xs:token
Page optional xs:integer
Description optional TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
State BookabilityStateType Simple Type
Service bookability state
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
Sequence
Identifier 1..∞ IdentifierType Simple Type
State ConfirmationStateType Simple Type
Confirmation state of the customer request
AdditionalInfos optional ServicesResponseAdditionalInfoType Complex Type
Additional infos (e.g. cancellation and modifications conditions)
Sequence
GeneralInformation 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
CancellationPolicies optional CancellationPoliciesType Complex Type
Free optional xs:boolean
True if cancelable for free
FreeTo optional xs:dateTime
End of "Free Cancellation" period
Full optional xs:boolean
True if noncancelable
FullFrom optional DateTimeType Simple Type
Start date-time of 100% penalty
Sequence
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
ModificationPolicies optional ModficationPoliciesType Complex Type
Free optional xs:boolean
True if modifiable for free
Upgradable optional xs:boolean
True if upgradable for free
Unchangeable optional xs:boolean
True if not changeable at all
Sequence
Permitted optional
Passengers optional xs:boolean
From optional xs:boolean
To optional xs:boolean
Duration optional xs:boolean
Room optional xs:boolean
Board optional xs:token
Fees 0..∞ FeeType Complex Type
Sequence
Description 0..∞ TextLanguageType Complex Type
From DateTimeType Simple Type
Start date/time of according fee
Choice
Nights xs:int
Fee in number of nights
Amount optional CurrencyAmountType Complex Type
Fee as absolute amount
Percentage optional xs:decimal
Fee as percentage value
Data optional CommonFlightDataType Complex Type
Sequence
PNR optional ListType Complex Type
PNR reference
Sequence
Value 1..∞ xs:string
PointOfTurnAround optional xs:string
Point of turnaround of the flight (in case of return flight)
Segments optional FlightSegmentsResponseType Complex Type
Sequence
Segment 0..∞ CommonFlightSegmentResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique flight segment identifier
DepartureDate optional DateTimeType Simple Type
Departure date and time of the segment
ArrivalDate optional DateTimeType Simple Type
Arrival date and time of the segment
FlightNumber optional FlightNumberType Simple Type
Flight number of the segment
PNR optional ListType Complex Type
PNR reference for the segment
Sequence
Value 1..∞ xs:string
State optional BookabilityStateType Simple Type
Bookability state for the segment
CheckInData optional CheckInData Complex Type
Check-In information of the segment
Sequence
Time optional TimeType Simple Type
Counter optional xs:string
Terminal optional xs:string
Gate optional xs:string
ArrivalTerminal optional xs:string
Arrival terminal of the segment
ETIX optional xs:string
ETIX reference of the segment
Overnights optional xs:int
Overnight counter of the segment
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
DepartureAirport AirportResponseType Complex Type
Departure airport for the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
ArrivalAirport AirportResponseType Complex Type
Arrival airport of the segment
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Location optional GeoLocationType Complex Type
Carrier AirlineResponseTypes Complex Type
Carrier information of the segment
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
MarketingCarrier optional AirlineResponseType Complex Type
Class optional ClassBaseResponseType Complex Type
Class information of the segment
Sequence
CabinClass optional CabinClassType Simple Type
ClassCode optional ClassResponseType Complex Type
HasSeatmap optional xs:boolean
Flag if a seatmap information can be requested for the segment
TariffDetails optional FlightTariffsResponseType Complex Type
Sequence
TariffDetail 0..∞ CommonTariffResponseType Complex Type
Sequence
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedLegs optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedSegments optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
BaggageInfo optional BaggageInfoType Complex Type
Sequence
Pieces optional xs:int
Weight optional PackageWeightType Complex Type
Meal optional MealResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
DepartureAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
ArrivalAirport optional AirportResponseType Complex Type
Sequence
Choice
IataCode IataAirportCode Simple Type
IcaoCode IcaoAirportCode Simple Type
AirportName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Location optional GeoLocationType Complex Type
Sequence
Longitude xs:string
Latitude xs:string
Carrier optional AirlineResponseTypes Complex Type
Sequence
OperatingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
MarketingCarrier optional AirlineResponseType Complex Type
Sequence
Choice
IataCode
IcaoCode
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Classes optional FlightClassesResponseType Complex Type
Sequence
FlightClass 0..∞ BookableClassResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique class identifier
CabinClass optional CabinClassType Simple Type
State BookabilityStateType Simple Type
Flight class bookability state
AssignedTravellers optional IdentifiersType Complex Type
Sequence
Identifier 1..∞ IdentifierType Simple Type
Attributes 0..∞ AttributesType Complex Type
List of attributes of this class
Sequence
Attribute 1..∞ AttributeType Complex Type
ClassCode optional ClassResponseType Complex Type
Sequence
Code xs:token
Description 0..∞ TextLanguageType Complex Type
IncludedExtras optional IncludedExtrasResponseType Complex Type
Included extras for this class
Sequence
IncludedExtra 0..∞ IncludedExtraBaseResponseType Complex Type
CustomerRequests optional CustomerRequestResponseType Complex Type
List of customer requests
Sequence
Code optional xs:token
Touroperator code for the customer request
Description 0..∞ TextLanguageType Complex Type
Description for the customer request
AssignedTravellers optional IdentifiersType Complex Type
List of assigend participants
State ConfirmationStateType Simple Type
Confirmation state of the customer request
FlightDescription 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Flight" type="FlightResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Service Element | ServicesResponseType Complex Type | String Schema


TextLanguageType Complex Type

String Schema
TextLanguageType Complex Type
String Schema : TextLanguageType Complex Type
Description
Type for region/country specific text information
Namespace http://string.drv.de/xmlschema/string
Diagram
LanguageCode Element Text Element Sequence TextLanguageType Complex Type
Overview
TextLanguageType
Type for region/country specific text information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Used By
PriceName Element
PriceName Element
PriceName Element
Description Element
Description Element
Description Element
GeneralInformation Element
AirportName Element
AirlineName Element
Description Element
Description Element
FlightDescription Element
BusStation Element
BusStation Element
Station Element
Station Element
Harbour Element
Harbour Element
Description Element
Description Element
Description Element
Description Element
Description Element
Description Element
Description Element
Description Element
Description Element
Description Element
Description Element
Source
<xs:complexType name="TextLanguageType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type for region/country specific text information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Text" type="xs:string">
      <xs:annotation>
        <xs:documentation>Text in the given language</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="LanguageCode" type="xs:language">
      <xs:annotation>
        <xs:documentation>ISO language code: either XX or XX_yy</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


LanguageCode Element

String Schema
LanguageCode Element
String Schema > TextLanguageType Complex Type : LanguageCode Element
Description
ISO language code: either XX or XX_yy
Namespace http://string.drv.de/xmlschema/string
Type
xs:language
Overview
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="LanguageCode" type="xs:language" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ISO language code: either XX or XX_yy</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
TextLanguageType Complex Type | String Schema


Text Element

String Schema
Text Element
String Schema > TextLanguageType Complex Type : Text Element
Description
Text in the given language
Namespace http://string.drv.de/xmlschema/string
Type
xs:string
Overview
Text xs:string
Text in the given language
Source
<xs:element name="Text" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Text in the given language</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
TextLanguageType Complex Type | String Schema


TotalPriceType Complex Type

String Schema
TotalPriceType Complex Type
String Schema : TotalPriceType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
BookingPrice Element TravellerPrice Element ServiceTypePrice Element ServicePrice Element Choice Sequence TotalPriceType Complex Type
Overview
TotalPriceType
Sequence
Choice
ServicePrice CommonTotalServicePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
ServiceTypePrice CommonTotalServiceTypePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
TravellerPrice CommonTotalTravellerPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
BookingPrice CommonTotalBookingPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Used By
TotalPrices Element
Source
<xs:complexType name="TotalPriceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:choice>
      <xs:element name="ServicePrice" type="CommonTotalServicePriceType" nillable="true" />
      <xs:element name="ServiceTypePrice" type="CommonTotalServiceTypePriceType" nillable="true" />
      <xs:element name="TravellerPrice" type="CommonTotalTravellerPriceType" nillable="true" />
      <xs:element name="BookingPrice" type="CommonTotalBookingPriceType" nillable="true" />
    </xs:choice>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


BookingPrice Element

String Schema
BookingPrice Element
String Schema > TotalPriceType Complex Type : BookingPrice Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTotalBookingPriceType Complex Type
Diagram
Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence BookingPrice Element
Overview
BookingPrice CommonTotalBookingPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="BookingPrice" type="CommonTotalBookingPriceType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalPriceType Complex Type | String Schema


ServicePrice Element

String Schema
ServicePrice Element
String Schema > TotalPriceType Complex Type : ServicePrice Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTotalServicePriceType Complex Type
Diagram
AssignedService Element Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence ServicePrice Element
Overview
ServicePrice CommonTotalServicePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedService IdentifierType Simple Type
Reference to a servicer or package in case that the price is included in another component
Source
<xs:element name="ServicePrice" type="CommonTotalServicePriceType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalPriceType Complex Type | String Schema


ServiceTypePrice Element

String Schema
ServiceTypePrice Element
String Schema > TotalPriceType Complex Type : ServiceTypePrice Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTotalServiceTypePriceType Complex Type
Diagram
AssignedServiceType Element Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence ServiceTypePrice Element
Overview
ServiceTypePrice CommonTotalServiceTypePriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedServiceType IdentifierType Simple Type
Reference to a service type (e.g. room, flight class)
Source
<xs:element name="ServiceTypePrice" type="CommonTotalServiceTypePriceType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalPriceType Complex Type | String Schema


TravellerPrice Element

String Schema
TravellerPrice Element
String Schema > TotalPriceType Complex Type : TravellerPrice Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTotalTravellerPriceType Complex Type
Diagram
AssignedTraveller Element Currency Element Amount Element Sequence TotalIncentivesPrice Element Currency Element Amount Element Sequence TotalSalesTaxes Element Currency Element Amount Element Sequence RecommendedRetailPrice Element Currency Element Amount Element Sequence TotalSalesPrice Element Sequence TravellerPrice Element
Overview
TravellerPrice CommonTotalTravellerPriceType Complex Type
Sequence
TotalSalesPrice CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
RecommendedRetailPrice optional CurrencyAmountType Complex Type
Recommended price from touroperator
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalSalesTaxes optional CurrencyAmountType Complex Type
Total sales taxes included in the sales price
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
TotalIncentivesPrice optional CurrencyAmountType Complex Type
Total amount of in centivese
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
AssignedTraveller IdentifierType Simple Type
Reference to a traveller
Source
<xs:element name="TravellerPrice" type="CommonTotalTravellerPriceType" nillable="true" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalPriceType Complex Type | String Schema


TravellersRequestType Complex Type

String Schema
TravellersRequestType Complex Type
String Schema : TravellersRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence TravellersRequestType Complex Type
Overview
TravellersRequestType
Sequence
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Used By
Travellers Element
Source
<xs:complexType name="TravellersRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Traveller" type="CommonTravellerRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Traveller Element

String Schema
Traveller Element
String Schema > TravellersRequestType Complex Type : Traveller Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTravellerRequestType Complex Type
Diagram
ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element
Overview
Traveller 0..∞ CommonTravellerRequestType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
Source
<xs:element name="Traveller" type="CommonTravellerRequestType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TravellersRequestType Complex Type | String Schema


TravellersResponseType Complex Type

String Schema
TravellersResponseType Complex Type
String Schema : TravellersResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element ClientNumber Element Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element StayInfo Element MotherInfo Element FatherInfo Element CitizenOfForeignCountryEverSince Element CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element Sequence TravellersResponseType Complex Type
Overview
TravellersResponseType
Sequence
Traveller 0..∞ CommonTravellerResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Used By
Travellers Element
Source
<xs:complexType name="TravellersResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Traveller" type="CommonTravellerResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Traveller Element

String Schema
Traveller Element
String Schema > TravellersResponseType Complex Type : Traveller Element
Namespace http://string.drv.de/xmlschema/string
Type
CommonTravellerResponseType Complex Type
Diagram
Currency Element Amount Element Sequence TotalSalesPrice Element ClientNumber Element CountryCode Element Name Element Sequence Country Element City Element ZIPCode Element HouseNumber Element Street Element Sequence Address Element Mail Element Phone Element Country Element StateOrRegion Element City Element Appartement Element Address2 Element Address1 Element Sequence StayInfo Element Prename Element Surname Element Sequence MotherInfo Element Prename Element Surname Element Sequence FatherInfo Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryEverSince Element SourceOtherInfo Element Source Element Nationality Element IsCitizenOfForeignCountry Element Sequence CitizenOfForeignCountryNow Element Sequence ESTA_Information Element Authority Element CountryCode Element Name Element Sequence CountryOfBirth Element CityOfBirth Element ExpirationDate Element IssueDate Element Gender Element Nationality Element BirthDate Element Prename Element BirthName Element Surname Element PassportNumber Element Sequence Passport Element Emergency Element Mobile Element Phone Element Mail Element Sequence ContactDetails Element BirthDate Element AgeCategory Element Gender Element Salutation Element Prename Element Surname Element Identifier Element Sequence Traveller Element
Overview
Traveller 0..∞ CommonTravellerResponseType Complex Type
Sequence
Identifier IdentifierType Simple Type
Surname optional xs:string
Prename optional xs:string
Salutation optional SalutationType Simple Type
Gender optional GenderType Simple Type
AgeCategory optional AgeCategoryType Simple Type
BirthDate optional DateType Simple Type
ContactDetails optional ContactDetailsType Complex Type
Sequence
Mail optional xs:string
Phone optional xs:string
Mobile optional xs:string
Emergency optional xs:boolean
Flag that indicates if this contact type should be used in case of an emergency
Passport 0..∞ PassportType Complex Type
Sequence
PassportNumber xs:string
Surname xs:string
BirthName xs:string
Prename xs:string
BirthDate DateType Simple Type
Nationality optional xs:string
Gender optional GenderType Simple Type
IssueDate DateType Simple Type
ExpirationDate DateType Simple Type
CityOfBirth optional xs:string
CountryOfBirth optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Authority optional xs:string
ESTA_Information optional AdditionalESTAInformationType Complex Type
Sequence
CitizenOfForeignCountryNow optional PassportCitizenOfForeignCountryNowType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
Source optional NationalitySourceType Simple Type
SourceOtherInfo optional xs:string
CitizenOfForeignCountryEverSince optional PassportCitizenOfForeignCountryEverSinceType Complex Type
Sequence
IsCitizenOfForeignCountry optional xs:boolean
Nationality optional xs:string
FatherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
MotherInfo optional PassportParentInfoType Complex Type
Sequence
Surname optional xs:string
Prename optional xs:string
StayInfo optional PassportStayInfoType Complex Type
Sequence
Address1 optional xs:string
Address2 optional xs:string
Appartement optional xs:string
City optional xs:string
StateOrRegion optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
Phone optional xs:string
Mail optional xs:string
Address optional AddressType Complex Type
Language optional xs:language
Sequence
Street optional xs:string
HouseNumber optional xs:string
ZIPCode optional xs:string
City optional xs:string
Country optional CountryType Complex Type
Sequence
Name xs:string
Name of the country
CountryCode CountryCodeType Simple Type
ISO code
ClientNumber optional xs:string
TotalSalesPrice optional CurrencyAmountType Complex Type
Total sales amount
Sequence
Amount xs:decimal
Currency optional CurrencyCodeType Simple Type
Source
<xs:element name="Traveller" type="CommonTravellerResponseType" nillable="true" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TravellersResponseType Complex Type | String Schema


VersionRequestType Complex Type

String Schema
VersionRequestType Complex Type
String Schema : VersionRequestType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Version Element Sequence VersionRequestType Complex Type
Overview
VersionRequestType
Sequence
Version xs:decimal
version of client system
Used By
VersionRequest Element
Source
<xs:complexType name="VersionRequestType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Version" type="xs:decimal">
      <xs:annotation>
        <xs:documentation>version of client system</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Version Element

String Schema
Version Element
String Schema > VersionRequestType Complex Type : Version Element
Description
version of client system
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
Version xs:decimal
version of client system
Source
<xs:element name="Version" type="xs:decimal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>version of client system</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
VersionRequestType Complex Type | String Schema


VersionResponseType Complex Type

String Schema
VersionResponseType Complex Type
String Schema : VersionResponseType Complex Type
Namespace http://string.drv.de/xmlschema/string
Diagram
Version Element Sequence VersionResponseType Complex Type
Overview
VersionResponseType
Sequence
Version xs:decimal
version of operator system
Used By
VersionResponse Element
Source
<xs:complexType name="VersionResponseType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="Version" type="xs:decimal">
      <xs:annotation>
        <xs:documentation>version of operator system</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
String Schema


Version Element

String Schema
Version Element
String Schema > VersionResponseType Complex Type : Version Element
Description
version of operator system
Namespace http://string.drv.de/xmlschema/string
Type
xs:decimal
Overview
Version xs:decimal
version of operator system
Source
<xs:element name="Version" type="xs:decimal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>version of operator system</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
VersionResponseType Complex Type | String Schema


WarningsType Complex Type

String Schema
WarningsType Complex Type
String Schema : WarningsType Complex Type
Description
List of warnings
Namespace http://string.drv.de/xmlschema/string
Diagram
HasToBeConfirmed Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence WarningDetail Element Sequence WarningsType Complex Type
Overview
WarningsType
List of warnings
Sequence
WarningDetail 1..∞ WarningType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user
Used By
Warnings Element
Source
<xs:complexType name="WarningsType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of warnings</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="WarningDetail" type="WarningType" nillable="false" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
String Schema


WarningDetail Element

String Schema
WarningDetail Element
String Schema > WarningsType Complex Type : WarningDetail Element
Namespace http://string.drv.de/xmlschema/string
Type
WarningType Complex Type
Diagram
HasToBeConfirmed Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence WarningDetail Element
Overview
WarningDetail 1..∞ WarningType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user
Source
<xs:element name="WarningDetail" type="WarningType" nillable="false" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
WarningsType Complex Type | String Schema


WarningType Complex Type

String Schema
WarningType Complex Type
String Schema : WarningType Complex Type
Namespace http://string.drv.de/xmlschema/string
Base Type
Extension of InformationType Complex Type
Diagram
HasToBeConfirmed Element AssignedToBooking Element Identifier Element Sequence AssignedServiceTypes Element Identifier Element Sequence AssignedServices Element Identifier Element Sequence AssignedTravellers Element LanguageCode Element Text Element Sequence Description Element Code Element Identifier Element Sequence WarningType Complex Type
Overview
WarningType Extension of InformationType Complex Type
Sequence
Identifier IdentifierType Simple Type
Unique information identifier
Code xs:token
Code for the information defined by the touroperator
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
AssignedToBooking optional xs:boolean
Flag if this information is booking related
HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user
Used By
WarningDetail Element
Source
<xs:complexType name="WarningType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent>
    <xs:extension base="InformationType">
      <xs:sequence>
        <xs:element name="HasToBeConfirmed" type="xs:boolean" nillable="false" minOccurs="0">
          <xs:annotation>
            <xs:documentation>Flag if this warning has to be explitly confirmed by the user</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
String Schema


AssignedServices Element

String Schema
AssignedServices Element
String Schema > WarningType Complex Type : AssignedServices Element
Description
List of services which caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServices Element
Overview
AssignedServices optional IdentifiersType Complex Type
List of services which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServices" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of services which caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


AssignedServiceTypes Element

String Schema
AssignedServiceTypes Element
String Schema > WarningType Complex Type : AssignedServiceTypes Element
Description
List of service types (e.g. rooms, flight classes) which caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedServiceTypes Element
Overview
AssignedServiceTypes optional IdentifiersType Complex Type
List of service types (e.g. rooms, flight classes) which caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedServiceTypes" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of service types (e.g. rooms, flight classes) which caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


AssignedToBooking Element

String Schema
AssignedToBooking Element
String Schema > WarningType Complex Type : AssignedToBooking Element
Description
Flag if this information is booking related
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
AssignedToBooking optional xs:boolean
Flag if this information is booking related
Source
<xs:element name="AssignedToBooking" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this information is booking related</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


AssignedTravellers Element

String Schema
AssignedTravellers Element
String Schema > WarningType Complex Type : AssignedTravellers Element
Description
List of participants who caused this information
Namespace http://string.drv.de/xmlschema/string
Type
IdentifiersType Complex Type
Diagram
Identifier Element Sequence AssignedTravellers Element
Overview
AssignedTravellers optional IdentifiersType Complex Type
List of participants who caused this information
Sequence
Identifier 1..∞ IdentifierType Simple Type
Source
<xs:element name="AssignedTravellers" type="IdentifiersType" nillable="true" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>List of participants who caused this information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


Code Element

String Schema
Code Element
String Schema > WarningType Complex Type : Code Element
Description
Code for the information defined by the touroperator
Namespace http://string.drv.de/xmlschema/string
Type
xs:token
Overview
Code xs:token
Code for the information defined by the touroperator
Source
<xs:element name="Code" type="xs:token" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Code for the information defined by the touroperator</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


Description Element

String Schema
Description Element
String Schema > WarningType Complex Type : Description Element
Description
Description for the information
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence Description Element
Overview
Description 0..∞ TextLanguageType Complex Type
Description for the information
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="Description" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Description for the information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


HasToBeConfirmed Element

String Schema
HasToBeConfirmed Element
String Schema > WarningType Complex Type : HasToBeConfirmed Element
Description
Flag if this warning has to be explitly confirmed by the user
Namespace http://string.drv.de/xmlschema/string
Type
xs:boolean
Overview
HasToBeConfirmed optional xs:boolean
Flag if this warning has to be explitly confirmed by the user
Source
<xs:element name="HasToBeConfirmed" type="xs:boolean" nillable="false" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag if this warning has to be explitly confirmed by the user</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


Identifier Element

String Schema
Identifier Element
String Schema > WarningType Complex Type : Identifier Element
Description
Unique information identifier
Namespace http://string.drv.de/xmlschema/string
Type
IdentifierType Simple Type
Overview
Identifier IdentifierType Simple Type
Unique information identifier
Source
<xs:element name="Identifier" type="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Unique information identifier</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
WarningType Complex Type | String Schema


AgeCategoryType Simple Type

String Schema
AgeCategoryType Simple Type
String Schema : AgeCategoryType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
AgeCategoryType Restriction of xs:string
Facets
Enumeration | Adult
Enumeration | Child
Enumeration | Infant
Enumeration | Unknown
Source
<xs:simpleType name="AgeCategoryType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="Adult" />
    <xs:enumeration value="Child" />
    <xs:enumeration value="Infant" />
    <xs:enumeration value="Unknown" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


AttributeSourceType Simple Type

String Schema
AttributeSourceType Simple Type
String Schema : AttributeSourceType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
AttributeSourceType Restriction of xs:string
Facets
Enumeration | Touroperator
Enumeration | DRV
Enumeration | OTDS
Enumeration | GIATA
Enumeration | Other
Source
<xs:simpleType name="AttributeSourceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="Touroperator" />
    <xs:enumeration value="DRV" />
    <xs:enumeration value="OTDS" />
    <xs:enumeration value="GIATA" />
    <xs:enumeration value="Other" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


BookabilityStateType Simple Type

String Schema
BookabilityStateType Simple Type
String Schema : BookabilityStateType Simple Type
Description
Type for specifying touristical bookability states
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
BookabilityStateType Restriction of xs:string
Type for specifying touristical bookability states
Facets
Enumeration | Ok
Enumeration | Cancelled
Enumeration | Request
Enumeration | Option
Enumeration | Declined
Source
<xs:simpleType name="BookabilityStateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type for specifying touristical bookability states</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:enumeration value="Ok" />
    <xs:enumeration value="Cancelled" />
    <xs:enumeration value="Request" />
    <xs:enumeration value="Option" />
    <xs:enumeration value="Declined" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


CabinClassType Simple Type

String Schema
CabinClassType Simple Type
String Schema : CabinClassType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
CabinClassType Restriction of xs:string
Facets
Enumeration | First
Enumeration | Business
Enumeration | Economy
Enumeration | PremiumEconomy
Source
<xs:simpleType name="CabinClassType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="First" />
    <xs:enumeration value="Business" />
    <xs:enumeration value="Economy" />
    <xs:enumeration value="PremiumEconomy" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


ConfirmationStateType Simple Type

String Schema
ConfirmationStateType Simple Type
String Schema : ConfirmationStateType Simple Type
Description
Type for specifying touristical confirmation states
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
ConfirmationStateType Restriction of xs:string
Type for specifying touristical confirmation states
Facets
Enumeration | Ok
Enumeration | Declined
Enumeration | Request
Source
<xs:simpleType name="ConfirmationStateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type for specifying touristical confirmation states</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:enumeration value="Ok" />
    <xs:enumeration value="Declined" />
    <xs:enumeration value="Request" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


CountryCodeType Simple Type

String Schema
CountryCodeType Simple Type
String Schema : CountryCodeType Simple Type
Description
ISO country code
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:token
Overview
CountryCodeType Restriction of xs:token
ISO country code
Facets
MinLength | 2
MaxLength | 5
Source
<xs:simpleType name="CountryCodeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>ISO country code</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:token">
    <xs:minLength value="2" />
    <xs:maxLength value="5" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


CurrencyCodeType Simple Type

String Schema
CurrencyCodeType Simple Type
String Schema : CurrencyCodeType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
CurrencyCodeType Restriction of xs:string
Facets
Length 3
Source
<xs:simpleType name="CurrencyCodeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:length value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


DateTimeType Simple Type

String Schema
DateTimeType Simple Type
String Schema : DateTimeType Simple Type
Description
Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttThh:miZ)
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
DateTimeType Restriction of xs:string
Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttThh:miZ)
Source
<xs:simpleType name="DateTimeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttThh:miZ)</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string" />
</xs:simpleType>
See Also
String Schema


DateType Simple Type

String Schema
DateType Simple Type
String Schema : DateType Simple Type
Description
Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttZ)
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
DateType Restriction of xs:string
Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttZ)
Source
<xs:simpleType name="DateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Date value in ISO8601 format including the timezone (e.g. jjjj-mm-ttZ)</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string" />
</xs:simpleType>
See Also
String Schema


ErrorCategoryType Simple Type

String Schema
ErrorCategoryType Simple Type
String Schema : ErrorCategoryType Simple Type
Description
Error category
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
ErrorCategoryType Restriction of xs:string
Error category
Facets
Enumeration | TimeoutError
Enumeration | UnexpectedError
Enumeration | UnkownError
Enumeration | InputDataError
Enumeration | AuthenticationError
Enumeration | AuthorizationError
Enumeration | ExternalSystemError
Enumeration | TemporarilyUnavailable
Enumeration | OutboundUnavailable
Enumeration | InboundUnavailable
Enumeration | FlightUnavailable
Enumeration | AccommodationUnavailable
Enumeration | ServiceUnavailable
Enumeration | TravellerError
Enumeration | AgencyClearanceError
Enumeration | DirectBookingOnlyError
Enumeration | PriceError
Enumeration | PaymentFailedError
Source
<xs:simpleType name="ErrorCategoryType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Error category</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:enumeration value="TimeoutError" />
    <xs:enumeration value="UnexpectedError" />
    <!-- error which should really not happen under normal circumstances (e.g. system instable)-->
    <xs:enumeration value="UnkownError" />
    <!-- error which cannot be specified in detail-->
    <xs:enumeration value="InputDataError" />
    <xs:enumeration value="AuthenticationError" />
    <xs:enumeration value="AuthorizationError" />
    <xs:enumeration value="ExternalSystemError" />
    <xs:enumeration value="TemporarilyUnavailable" />
    <xs:enumeration value="OutboundUnavailable" />
    <xs:enumeration value="InboundUnavailable" />
    <xs:enumeration value="FlightUnavailable" />
    <xs:enumeration value="AccommodationUnavailable" />
    <xs:enumeration value="ServiceUnavailable" />
    <xs:enumeration value="TravellerError" />
    <xs:enumeration value="AgencyClearanceError" />
    <xs:enumeration value="DirectBookingOnlyError" />
    <xs:enumeration value="PriceError" />
    <xs:enumeration value="PaymentFailedError" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


FlightNumberType Simple Type

String Schema
FlightNumberType Simple Type
String Schema : FlightNumberType Simple Type
Description
Flight number, is always only the number part. The carrier code should be transmitted in the according separate carrier field.
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:int
Overview
FlightNumberType Restriction of xs:int
Flight number, is always only the number part. The carrier code should be transmitted in the according separate carrier field.
Source
<xs:simpleType name="FlightNumberType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flight number, is always only the number part. The carrier code should be transmitted in the according separate carrier field.</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:int" />
</xs:simpleType>
See Also
String Schema


GenderType Simple Type

String Schema
GenderType Simple Type
String Schema : GenderType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
GenderType Restriction of xs:string
Facets
Enumeration | Male
Enumeration | Female
Enumeration | Unknown
Source
<xs:simpleType name="GenderType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="Male" />
    <xs:enumeration value="Female" />
    <xs:enumeration value="Unknown" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


IataAirlineCode Simple Type

String Schema
IataAirlineCode Simple Type
String Schema : IataAirlineCode Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
IataAirlineCode Restriction of xs:string
Facets
Length 2
Source
<xs:simpleType name="IataAirlineCode" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:length value="2" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


IataAirportCode Simple Type

String Schema
IataAirportCode Simple Type
String Schema : IataAirportCode Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
IataAirportCode Restriction of xs:string
Facets
Length 3
Source
<xs:simpleType name="IataAirportCode" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:length value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


IcaoAirlineCode Simple Type

String Schema
IcaoAirlineCode Simple Type
String Schema : IcaoAirlineCode Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
IcaoAirlineCode Restriction of xs:string
Facets
Length 3
Source
<xs:simpleType name="IcaoAirlineCode" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:length value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


IcaoAirportCode Simple Type

String Schema
IcaoAirportCode Simple Type
String Schema : IcaoAirportCode Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
IcaoAirportCode Restriction of xs:string
Facets
Length 4
Source
<xs:simpleType name="IcaoAirportCode" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:length value="4" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


IdentifierList Simple Type

String Schema
IdentifierList Simple Type
String Schema : IdentifierList Simple Type
Description
White space separated list of identifiers
Namespace http://string.drv.de/xmlschema/string
Type
List of IdentifierType Simple Type
Overview
IdentifierList List of IdentifierType Simple Type
White space separated list of identifiers
Source
<xs:simpleType name="IdentifierList" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>White space separated list of identifiers</xs:documentation>
  </xs:annotation>
  <xs:list itemType="IdentifierType" />
</xs:simpleType>
See Also
String Schema


IdentifierType Simple Type

String Schema
IdentifierType Simple Type
String Schema : IdentifierType Simple Type
Description
Type for an unique identifier
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
IdentifierType Restriction of xs:string
Type for an unique identifier
Source
<xs:simpleType name="IdentifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type for an unique identifier</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string" />
</xs:simpleType>
See Also
String Schema


NationalitySourceType Simple Type

String Schema
NationalitySourceType Simple Type
String Schema : NationalitySourceType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
NationalitySourceType Restriction of xs:string
Facets
Enumeration | ByBirth
Enumeration | ByDescent
Enumeration | Naturalized
Enumeration | Other
Source
<xs:simpleType name="NationalitySourceType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="ByBirth" />
    <xs:enumeration value="ByDescent" />
    <xs:enumeration value="Naturalized" />
    <xs:enumeration value="Other" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


ProcessStateType Simple Type

String Schema
ProcessStateType Simple Type
String Schema : ProcessStateType Simple Type
Description
Type which indicates next possible process states of the result
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
ProcessStateType Restriction of xs:string
Type which indicates next possible process states of the result
Facets
Enumeration | BookingPossible
Enumeration | RebookPossible
Enumeration | CancellationPossible
Enumeration | OptionPossible
Enumeration | RequestPossible
Enumeration | BookingOk
Enumeration | RebookOk
Enumeration | CancellationOk
Enumeration | OptionOk
Enumeration | RequestOk
Enumeration | Error
Source
<xs:simpleType name="ProcessStateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type which indicates next possible process states of the result</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:enumeration value="BookingPossible" />
    <xs:enumeration value="RebookPossible" />
    <xs:enumeration value="CancellationPossible" />
    <xs:enumeration value="OptionPossible" />
    <xs:enumeration value="RequestPossible" />
    <xs:enumeration value="BookingOk" />
    <xs:enumeration value="RebookOk" />
    <xs:enumeration value="CancellationOk" />
    <xs:enumeration value="OptionOk" />
    <xs:enumeration value="RequestOk" />
    <xs:enumeration value="Error" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


RequestTriggerType Simple Type

String Schema
RequestTriggerType Simple Type
String Schema : RequestTriggerType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
RequestTriggerType Restriction of xs:string
Facets
Enumeration | Interactive
Enumeration | Automatic
Source
<xs:simpleType name="RequestTriggerType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="Interactive" />
    <xs:enumeration value="Automatic" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


SalutationType Simple Type

String Schema
SalutationType Simple Type
String Schema : SalutationType Simple Type
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
SalutationType Restriction of xs:string
Facets
Enumeration | Mr
Enumeration | Mrs
Enumeration | Unknown
Source
<xs:simpleType name="SalutationType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:enumeration value="Mr" />
    <xs:enumeration value="Mrs" />
    <xs:enumeration value="Unknown" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


TimeType Simple Type

String Schema
TimeType Simple Type
String Schema : TimeType Simple Type
Description
Date value in ISO8601 format including the timezone (e.g. Thh:miZ)
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
TimeType Restriction of xs:string
Date value in ISO8601 format including the timezone (e.g. Thh:miZ)
Source
<xs:simpleType name="TimeType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Date value in ISO8601 format including the timezone (e.g. Thh:miZ)</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string" />
</xs:simpleType>
See Also
String Schema


TransactionStateType Simple Type

String Schema
TransactionStateType Simple Type
String Schema : TransactionStateType Simple Type
Description
Type which indicates an technical error while processing a request
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
TransactionStateType Restriction of xs:string
Type which indicates an technical error while processing a request
Facets
Enumeration | Ok
Enumeration | Timeout
Enumeration | InvalidFormat
Enumeration | NoConnectionPossible
Source
<xs:simpleType name="TransactionStateType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Type which indicates an technical error while processing a request</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:enumeration value="Ok" />
    <xs:enumeration value="Timeout" />
    <xs:enumeration value="InvalidFormat" />
    <xs:enumeration value="NoConnectionPossible" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


WeightMeasureType Simple Type

String Schema
WeightMeasureType Simple Type
String Schema : WeightMeasureType Simple Type
Description
Weight scale information
Namespace http://string.drv.de/xmlschema/string
Type
Restriction of xs:string
Overview
WeightMeasureType Restriction of xs:string
Weight scale information
Facets
Enumeration | Kilogram
Enumeration | Gram
Enumeration | Pound
Source
<xs:simpleType name="WeightMeasureType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Weight scale information</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:enumeration value="Kilogram" />
    <xs:enumeration value="Gram" />
    <xs:enumeration value="Pound" />
  </xs:restriction>
</xs:simpleType>
See Also
String Schema


IataCode Element

String Schema
IataCode Element
String Schema > AirlineRequestType Complex Type : IataCode Element
Namespace http://string.drv.de/xmlschema/string
Overview
IataCode
Source
<xs:element name="IataCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineRequestType Complex Type | String Schema


IcaoCode Element

String Schema
IcaoCode Element
String Schema > AirlineRequestType Complex Type : IcaoCode Element
Namespace http://string.drv.de/xmlschema/string
Overview
IcaoCode
Source
<xs:element name="IcaoCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineRequestType Complex Type | String Schema


AirlineName Element

String Schema
AirlineName Element
String Schema > AirlineResponseType Complex Type : AirlineName Element
Namespace http://string.drv.de/xmlschema/string
Type
TextLanguageType Complex Type
Diagram
LanguageCode Element Text Element Sequence AirlineName Element
Overview
AirlineName 0..∞ TextLanguageType Complex Type
Sequence
Text xs:string
Text in the given language
LanguageCode xs:language
ISO language code: either XX or XX_yy
Source
<xs:element name="AirlineName" type="TextLanguageType" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineResponseType Complex Type | String Schema


IataCode Element

String Schema
IataCode Element
String Schema > AirlineResponseType Complex Type : IataCode Element
Namespace http://string.drv.de/xmlschema/string
Overview
IataCode
Source
<xs:element name="IataCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineResponseType Complex Type | String Schema


IcaoCode Element

String Schema
IcaoCode Element
String Schema > AirlineResponseType Complex Type : IcaoCode Element
Namespace http://string.drv.de/xmlschema/string
Overview
IcaoCode
Source
<xs:element name="IcaoCode" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AirlineResponseType Complex Type | String Schema